summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-03-31 12:06:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-03-31 12:06:01 +0000
commit23c0e75479b2fd06c8a5b8ed64744fae1efce969 (patch)
tree8e8609f611d833ab39333b4b4053b21d7c2418c2 /media-tv/xbmc/files
parentDrop ia64/sparc keywords (diff)
downloadgentoo-2-23c0e75479b2fd06c8a5b8ed64744fae1efce969.tar.gz
gentoo-2-23c0e75479b2fd06c8a5b8ed64744fae1efce969.tar.bz2
gentoo-2-23c0e75479b2fd06c8a5b8ed64744fae1efce969.zip
Add also the 3rd patch from libav bug#406215 that fixes the latest api include issues.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/xbmc/files')
-rw-r--r--media-tv/xbmc/files/xbmc-11.0-ffmpeg-0.10.2.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-tv/xbmc/files/xbmc-11.0-ffmpeg-0.10.2.patch b/media-tv/xbmc/files/xbmc-11.0-ffmpeg-0.10.2.patch
new file mode 100644
index 000000000000..b6a2d731dc13
--- /dev/null
+++ b/media-tv/xbmc/files/xbmc-11.0-ffmpeg-0.10.2.patch
@@ -0,0 +1,41 @@
+From 4d74bd14c0fa158c5a2bcf18192f418fafc3a053 Mon Sep 17 00:00:00 2001
+From: Tomas Chvatal <tchvatal@suse.cz>
+Date: Fri, 23 Mar 2012 11:59:02 +0100
+Subject: [PATCH 1/2] Add support for new ffmpeg-10/11 api.
+
+---
+ configure.in | 3 +++
+ lib/DllAvUtil.h | 3 +++
+ 2 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index bca9239..bea66ac 100755
+--- a/configure.in
++++ b/configure.in
+@@ -1225,6 +1225,9 @@ if test "$use_external_ffmpeg" = "yes"; then
+ # old FFmpeg have this in libavcodec/opt.h instead:
+ AC_CHECK_HEADERS([libavutil/opt.h])
+
++ # new FFmpeg have math headers
++ AC_CHECK_HEADERS([libavutil/mathematics.h],,)
++
+ # We'll support the use of rgb2rgb.h if it exists.
+ AC_CHECK_HEADERS([libswscale/rgb2rgb.h],,)
+ AC_CHECK_HEADERS([ffmpeg/rgb2rgb.h],,)
+diff --git a/lib/DllAvUtil.h b/lib/DllAvUtil.h
+index e882cac..e3b8a02 100644
+--- a/lib/DllAvUtil.h
++++ b/lib/DllAvUtil.h
+@@ -59,6 +59,9 @@ extern "C" {
+ #else
+ #include <ffmpeg/mem.h>
+ #endif
++ #if (defined HAVE_LIBAVUTIL_MATHEMATICS_H)
++ #include <libavutil/mathematics.h>
++ #endif
+ #else
+ #include "libavutil/avutil.h"
+ #include "libavutil/crc.h"
+--
+1.7.3.4
+