summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2011-10-14 21:16:50 +0000
committerAlex Legler <a3li@gentoo.org>2011-10-14 21:16:50 +0000
commit18107274008f825bfe6ce40f54b34e8681d0a442 (patch)
tree24d9361bac3612545a6679221352591e34db7e46 /media-tv
parentamd64 stable wrt #385699 (diff)
downloadgentoo-2-18107274008f825bfe6ce40f54b34e8681d0a442.tar.gz
gentoo-2-18107274008f825bfe6ce40f54b34e8681d0a442.tar.bz2
gentoo-2-18107274008f825bfe6ce40f54b34e8681d0a442.zip
Add additional patch to fix alsa issues, bug 384215. Minor ebuild fixes from bug 385353 and idl0r.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/tvtime/ChangeLog10
-rw-r--r--media-tv/tvtime/files/tvtime-1.0.2_p20110131-underlinking.patch11
-rw-r--r--media-tv/tvtime/metadata.xml6
-rw-r--r--media-tv/tvtime/tvtime-1.0.2_p20110131-r3.ebuild (renamed from media-tv/tvtime/tvtime-1.0.2_p20110131-r2.ebuild)22
4 files changed, 36 insertions, 13 deletions
diff --git a/media-tv/tvtime/ChangeLog b/media-tv/tvtime/ChangeLog
index f89063c39f5f..5d9d635a9f51 100644
--- a/media-tv/tvtime/ChangeLog
+++ b/media-tv/tvtime/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-tv/tvtime
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.53 2011/10/13 08:13:56 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.54 2011/10/14 21:16:50 a3li Exp $
+
+*tvtime-1.0.2_p20110131-r3 (14 Oct 2011)
+
+ 14 Oct 2011; Alex Legler <a3li@gentoo.org> -tvtime-1.0.2_p20110131-r2.ebuild,
+ +tvtime-1.0.2_p20110131-r3.ebuild,
+ +files/tvtime-1.0.2_p20110131-underlinking.patch, metadata.xml:
+ Add additional patch to fix alsa issues, bug 384215. Minor ebuild fixes from
+ bug 385353 and idl0r.
*tvtime-1.0.2_p20110131-r2 (13 Oct 2011)
diff --git a/media-tv/tvtime/files/tvtime-1.0.2_p20110131-underlinking.patch b/media-tv/tvtime/files/tvtime-1.0.2_p20110131-underlinking.patch
new file mode 100644
index 000000000000..eed4beac34d5
--- /dev/null
+++ b/media-tv/tvtime/files/tvtime-1.0.2_p20110131-underlinking.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.am.orig 2011-10-14 22:21:20.897781921 +0200
++++ src/Makefile.am 2011-10-14 22:21:30.368781581 +0200
+@@ -74,7 +74,7 @@
+ $(PLUGIN_CFLAGS) $(X11_CFLAGS) $(XML2_FLAG) \
+ $(FONT_CFLAGS) $(AM_CFLAGS)
+ tvtime_LDADD = $(TTF_LIBS) $(ZLIB_LIBS) $(PNG_LIBS) \
+- $(X11_LIBS) $(XML2_LIBS) $(ASOUND_LIBS) -lm -lsupc++
++ $(X11_LIBS) $(XML2_LIBS) $(ASOUND_LIBS) -lm -lsupc++ -lpthread
+
+ tvtime_command_SOURCES = utils.h utils.c tvtimeconf.h tvtimeconf.c \
+ tvtime-command.c
diff --git a/media-tv/tvtime/metadata.xml b/media-tv/tvtime/metadata.xml
index 987c4080e67d..58373b196d2a 100644
--- a/media-tv/tvtime/metadata.xml
+++ b/media-tv/tvtime/metadata.xml
@@ -7,4 +7,10 @@
<name>Alex Legler</name>
<description>Please CC on bugs</description>
</maintainer>
+ <use>
+ <flag name="alsa">
+ Enables an EXPERIMENTAL ALSA patch by the Ubuntu maintainers.
+ Several problems were reported, use with care.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/media-tv/tvtime/tvtime-1.0.2_p20110131-r2.ebuild b/media-tv/tvtime/tvtime-1.0.2_p20110131-r3.ebuild
index 41f639b24354..12b7413bf0f3 100644
--- a/media-tv/tvtime/tvtime-1.0.2_p20110131-r2.ebuild
+++ b/media-tv/tvtime/tvtime-1.0.2_p20110131-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2_p20110131-r2.ebuild,v 1.1 2011/10/13 08:13:56 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2_p20110131-r3.ebuild,v 1.1 2011/10/14 21:16:50 a3li Exp $
EAPI=4
inherit eutils autotools
@@ -10,8 +10,9 @@ TVTIME_HGREV="111b28cca42d"
DESCRIPTION="High quality television application for use with video capture cards"
HOMEPAGE="http://tvtime.sourceforge.net/"
SRC_URI="http://www.kernellabs.com/hg/~dheitmueller/tvtime/archive/${TVTIME_HGREV}.tar.bz2 -> ${P}.tar.bz2
-http://dev.gentoo.org/~a3li/distfiles/${PN}-1.0.2-alsa.patch
-http://dev.gentoo.org/~a3li/distfiles/${PN}-1.0.2-alsamixer.patch"
+http://dev.gentoo.org/~a3li/distfiles/${PN}-1.0.2-alsamixer-r1.patch
+http://dev.gentoo.org/~a3li/distfiles/${PN}-1.0.2-alsa-r1.patch
+http://dev.gentoo.org/~a3li/distfiles/${PN}-1.0.2-alsa-fixes.patch"
LICENSE="GPL-2"
SLOT="0"
@@ -40,6 +41,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
S="${WORKDIR}/${PN}-${TVTIME_HGREV}"
+DOCS=( ChangeLog AUTHORS NEWS README )
src_prepare() {
# Rename the desktop file, bug #308297
@@ -62,10 +64,12 @@ src_prepare() {
epatch "${FILESDIR}/${P}-autotools.patch"
epatch "${FILESDIR}/${P}-gettext.patch"
epatch "${FILESDIR}/${PN}-libpng-1.5.patch"
+ epatch "${FILESDIR}/${P}-underlinking.patch" #370025
if use alsa; then
- epatch "${DISTDIR}/${PN}-1.0.2-alsa.patch"
- epatch "${DISTDIR}/${PN}-1.0.2-alsamixer.patch"
+ epatch "${DISTDIR}/${PN}-1.0.2-alsa-r1.patch"
+ epatch "${DISTDIR}/${PN}-1.0.2-alsamixer-r1.patch"
+ epatch "${DISTDIR}/${PN}-1.0.2-alsa-fixes.patch"
fi
AT_M4DIR="m4" eautoreconf
@@ -77,16 +81,10 @@ src_configure() {
$(use_with xinerama) || die "econf failed"
}
-src_compile() {
- # Fix underlinking, #370025
- emake LDFLAGS="${LDFLAGS} -lpthread" || die "compile problem"
-}
-
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ default
dohtml docs/html/*
- dodoc ChangeLog AUTHORS NEWS README
}
pkg_postinst() {