summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-04-22 17:39:35 +0000
committerChristian Heim <phreak@gentoo.org>2007-04-22 17:39:35 +0000
commita22845a9b3fb3062abc78b3c206e23a9f632c3b2 (patch)
tree1f503384cef356b9e4038bb05df4232c18c34188 /media-tv
parentx86 stable wrt #175141 (diff)
downloadgentoo-2-a22845a9b3fb3062abc78b3c206e23a9f632c3b2.tar.gz
gentoo-2-a22845a9b3fb3062abc78b3c206e23a9f632c3b2.tar.bz2
gentoo-2-a22845a9b3fb3062abc78b3c206e23a9f632c3b2.zip
Use newconfd/newinitd for #174266; Properly quote variables.
(Portage version: 2.1.2.4)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/freevo/ChangeLog6
-rw-r--r--media-tv/freevo/freevo-1.5.4-r2.ebuild15
-rw-r--r--media-tv/freevo/freevo-1.5.4.ebuild14
-rw-r--r--media-tv/freevo/freevo-1.6.0.ebuild15
-rw-r--r--media-tv/freevo/freevo-1.6.1.ebuild15
5 files changed, 32 insertions, 33 deletions
diff --git a/media-tv/freevo/ChangeLog b/media-tv/freevo/ChangeLog
index 10f98c39ccc9..c92981a7dd0b 100644
--- a/media-tv/freevo/ChangeLog
+++ b/media-tv/freevo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/freevo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/ChangeLog,v 1.44 2007/03/19 15:05:41 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/ChangeLog,v 1.45 2007/04/22 17:39:35 phreak Exp $
+
+ 22 Apr 2007; Christian Heim <phreak@gentoo.org> freevo-1.5.4.ebuild,
+ freevo-1.5.4-r2.ebuild, freevo-1.6.0.ebuild, freevo-1.6.1.ebuild:
+ Use newconfd/newinitd for #174266; Properly quote variables.
19 Mar 2007; Marius Mauch <genone@gentoo.org> freevo-1.5.4.ebuild,
freevo-1.5.4-r2.ebuild, freevo-1.6.0.ebuild, freevo-1.6.1.ebuild:
diff --git a/media-tv/freevo/freevo-1.5.4-r2.ebuild b/media-tv/freevo/freevo-1.5.4-r2.ebuild
index 17144051d558..61942936c7e9 100644
--- a/media-tv/freevo/freevo-1.5.4-r2.ebuild
+++ b/media-tv/freevo/freevo-1.5.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.5.4-r2.ebuild,v 1.3 2007/03/19 15:05:41 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.5.4-r2.ebuild,v 1.4 2007/04/22 17:39:35 phreak Exp $
inherit distutils
@@ -23,11 +23,11 @@ DEPEND=">=dev-python/pygame-1.5.6
>=media-video/mplayer-0.92
>=media-libs/freetype-2.1.4
>=media-libs/libsdl-1.2.5
- >=sys-apps/sed-4
dvd? ( >=media-video/xine-ui-0.9.22 >=media-video/lsdvd-0.10 )
encode? ( >=media-sound/cdparanoia-3.9.8 >=media-sound/lame-3.93.1 )
matrox? ( >=media-video/matroxset-0.3 )
lirc? ( app-misc/lirc >=dev-python/pylirc-0.0.3 )"
+RDEPEND="${DEPEND}"
pkg_setup() {
if ! built_with_use media-libs/sdl-image png; then
@@ -56,7 +56,7 @@ src_install() {
if [ "${PROFILE_ARCH}" == "xbox" ]; then
sed -i -e "s/# MPLAYER_AO_DEV.*/MPLAYER_AO_DEV='alsa1x'/" ${D}/etc/freevo/local_conf.py
- newins ${FILESDIR}/xbox-lircrc lircrc
+ newins "${FILESDIR}"/xbox-lircrc lircrc
fi
if use X; then
@@ -70,18 +70,17 @@ src_install() {
FREEVOSESSION=`grep ^SessionsDirs= ${KDFREEVO}/share/config/kdm/kdmrc | cut -d= -f 2 | cut -d: -f1`
if [ "x${FREEVOSESSION}" != "x" ]; then
insinto ${FREEVOSESSION}
- doins ${FILESDIR}/freevo.desktop freevo.desktop
+ doins "${FILESDIR}"/freevo.desktop freevo.desktop
fi
fi
insinto /etc/X11/dm/Sessions
- doins ${FILESDIR}/freevo.desktop freevo.desktop
+ doins "${FILESDIR}"/freevo.desktop freevo.desktop
fi
exeinto /usr/bin
newexe "${FILESDIR}/freevo.boot" freevoboot
- insinto /etc/conf.d
- newins "${FILESDIR}/freevo.conf" freevo
+ newconfd "${FILESDIR}/freevo.conf" freevo
rm -rf "${D}/usr/share/doc"
newdoc Docs/README README.docs
@@ -89,7 +88,7 @@ src_install() {
Docs/{CREDITS,NOTES,plugins/*.txt}
cp -r Docs/{installation,plugin_writing} "${D}/usr/share/doc/${PF}"
- use nls || rm -rf ${D}/usr/share/locale
+ use nls || rm -rf "${D}"/usr/share/locale
}
pkg_postinst() {
diff --git a/media-tv/freevo/freevo-1.5.4.ebuild b/media-tv/freevo/freevo-1.5.4.ebuild
index 4e9a6a7dfd22..ee19e5ad223a 100644
--- a/media-tv/freevo/freevo-1.5.4.ebuild
+++ b/media-tv/freevo/freevo-1.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.5.4.ebuild,v 1.8 2007/03/19 15:05:41 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.5.4.ebuild,v 1.9 2007/04/22 17:39:35 phreak Exp $
inherit distutils
@@ -23,11 +23,11 @@ DEPEND=">=dev-python/pygame-1.5.6
>=media-video/mplayer-0.92
>=media-libs/freetype-2.1.4
>=media-libs/libsdl-1.2.5
- >=sys-apps/sed-4
dvd? ( >=media-video/xine-ui-0.9.22 >=media-video/lsdvd-0.10 )
encode? ( >=media-sound/cdparanoia-3.9.8 >=media-sound/lame-3.93.1 )
matrox? ( >=media-video/matroxset-0.3 )
lirc? ( app-misc/lirc >=dev-python/pylirc-0.0.3 )"
+RDEPEND="${DEPEND}"
pkg_setup() {
if ! built_with_use media-libs/sdl-image png; then
@@ -46,13 +46,11 @@ src_install() {
if [ "${PROFILE_ARCH}" == "xbox" ]; then
sed -i -e "s/# MPLAYER_AO_DEV.*/MPLAYER_AO_DEV='alsa1x'/" ${D}/etc/freevo/local_conf.py
- newins ${FILESDIR}/xbox-lircrc lircrc
+ newins "${FILESDIR}"/xbox-lircrc lircrc
fi
- exeinto /etc/init.d
- newexe "${FILESDIR}/freevo.rc6" freevo
- insinto /etc/conf.d
- newins "${FILESDIR}/freevo.conf" freevo
+ newinitd "${FILESDIR}/freevo.rc6" freevo
+ newconfd "${FILESDIR}/freevo.conf" freevo
rm -rf "${D}/usr/share/doc"
newdoc Docs/README README.docs
@@ -60,7 +58,7 @@ src_install() {
Docs/{CREDITS,NOTES,plugins/*.txt}
cp -r Docs/{installation,plugin_writing} "${D}/usr/share/doc/${PF}"
- use nls || rm -rf ${D}/usr/share/locale
+ use nls || rm -rf "${D}"/usr/share/locale
}
pkg_postinst() {
diff --git a/media-tv/freevo/freevo-1.6.0.ebuild b/media-tv/freevo/freevo-1.6.0.ebuild
index 65fd9c8c5072..e4bcc62d0125 100644
--- a/media-tv/freevo/freevo-1.6.0.ebuild
+++ b/media-tv/freevo/freevo-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.6.0.ebuild,v 1.4 2007/03/19 15:05:41 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.6.0.ebuild,v 1.5 2007/04/22 17:39:35 phreak Exp $
inherit distutils
@@ -23,12 +23,12 @@ DEPEND=">=dev-python/pygame-1.5.6
>=media-video/mplayer-0.92
>=media-libs/freetype-2.1.4
>=media-libs/libsdl-1.2.5
- >=sys-apps/sed-4
dev-python/elementtree
dvd? ( >=media-video/xine-ui-0.9.22 >=media-video/lsdvd-0.10 )
encode? ( >=media-sound/cdparanoia-3.9.8 >=media-sound/lame-3.93.1 )
matrox? ( >=media-video/matroxset-0.3 )
lirc? ( app-misc/lirc >=dev-python/pylirc-0.0.3 )"
+RDEPEND="${DEPEND}"
pkg_setup() {
if ! built_with_use media-libs/sdl-image png; then
@@ -57,7 +57,7 @@ src_install() {
if [ "${PROFILE_ARCH}" == "xbox" ]; then
sed -i -e "s/# MPLAYER_AO_DEV.*/MPLAYER_AO_DEV='alsa1x'/" ${D}/etc/freevo/local_conf.py
- newins ${FILESDIR}/xbox-lircrc lircrc
+ newins "${FILESDIR}"/xbox-lircrc lircrc
fi
if use X; then
@@ -71,18 +71,17 @@ src_install() {
FREEVOSESSION=`grep ^SessionsDirs= ${KDFREEVO}/share/config/kdm/kdmrc | cut -d= -f 2 | cut -d: -f1`
if [ "x${FREEVOSESSION}" != "x" ]; then
insinto ${FREEVOSESSION}
- doins ${FILESDIR}/freevo.desktop freevo.desktop
+ doins "${FILESDIR}"/freevo.desktop freevo.desktop
fi
fi
insinto /etc/X11/dm/Sessions
- doins ${FILESDIR}/freevo.desktop freevo.desktop
+ doins "${FILESDIR}"/freevo.desktop freevo.desktop
fi
exeinto /usr/bin
newexe "${FILESDIR}/freevo.boot" freevoboot
- insinto /etc/conf.d
- newins "${FILESDIR}/freevo.conf" freevo
+ newconfd "${FILESDIR}/freevo.conf" freevo
rm -rf "${D}/usr/share/doc"
newdoc Docs/README README.docs
@@ -90,7 +89,7 @@ src_install() {
Docs/{CREDITS,NOTES,plugins/*.txt}
cp -r Docs/{installation,plugin_writing} "${D}/usr/share/doc/${PF}"
- use nls || rm -rf ${D}/usr/share/locale
+ use nls || rm -rf "${D}"/usr/share/locale
}
pkg_postinst() {
diff --git a/media-tv/freevo/freevo-1.6.1.ebuild b/media-tv/freevo/freevo-1.6.1.ebuild
index 1c80f750bd87..4225dc314d76 100644
--- a/media-tv/freevo/freevo-1.6.1.ebuild
+++ b/media-tv/freevo/freevo-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.6.1.ebuild,v 1.3 2007/03/19 15:05:41 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.6.1.ebuild,v 1.4 2007/04/22 17:39:35 phreak Exp $
inherit distutils
@@ -23,12 +23,12 @@ DEPEND=">=dev-python/pygame-1.5.6
>=media-video/mplayer-0.92
>=media-libs/freetype-2.1.4
>=media-libs/libsdl-1.2.5
- >=sys-apps/sed-4
dev-python/elementtree
dvd? ( >=media-video/xine-ui-0.9.22 >=media-video/lsdvd-0.10 )
encode? ( >=media-sound/cdparanoia-3.9.8 >=media-sound/lame-3.93.1 )
matrox? ( >=media-video/matroxset-0.3 )
lirc? ( app-misc/lirc >=dev-python/pylirc-0.0.3 )"
+RDEPEND="${DEPEND}"
pkg_setup() {
if ! built_with_use media-libs/sdl-image png; then
@@ -57,7 +57,7 @@ src_install() {
if [ "${PROFILE_ARCH}" == "xbox" ]; then
sed -i -e "s/# MPLAYER_AO_DEV.*/MPLAYER_AO_DEV='alsa1x'/" ${D}/etc/freevo/local_conf.py
- newins ${FILESDIR}/xbox-lircrc lircrc
+ newins "${FILESDIR}"/xbox-lircrc lircrc
fi
if use X; then
@@ -71,18 +71,17 @@ src_install() {
FREEVOSESSION=`grep ^SessionsDirs= ${KDFREEVO}/share/config/kdm/kdmrc | cut -d= -f 2 | cut -d: -f1`
if [ "x${FREEVOSESSION}" != "x" ]; then
insinto ${FREEVOSESSION}
- doins ${FILESDIR}/freevo.desktop freevo.desktop
+ doins "${FILESDIR}"/freevo.desktop freevo.desktop
fi
fi
insinto /etc/X11/dm/Sessions
- doins ${FILESDIR}/freevo.desktop freevo.desktop
+ doins "${FILESDIR}"/freevo.desktop freevo.desktop
fi
exeinto /usr/bin
newexe "${FILESDIR}/freevo.boot" freevoboot
- insinto /etc/conf.d
- newins "${FILESDIR}/freevo.conf" freevo
+ newconfd "${FILESDIR}/freevo.conf" freevo
rm -rf "${D}/usr/share/doc"
newdoc Docs/README README.docs
@@ -90,7 +89,7 @@ src_install() {
Docs/{CREDITS,NOTES,plugins/*.txt}
cp -r Docs/{installation,plugin_writing} "${D}/usr/share/doc/${PF}"
- use nls || rm -rf ${D}/usr/share/locale
+ use nls || rm -rf "${D}"/usr/share/locale
}
pkg_postinst() {