summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-07-23 16:31:26 +0000
committerMike Gilbert <floppym@gentoo.org>2012-07-23 16:31:26 +0000
commitd6eab3fd96380b328f55ab4c09f4bbb83f08e20d (patch)
tree87248218566ed3d2bb3c396fc6982ec3bbafab29 /media-tv
parentFix build issue. bug #427678 (diff)
downloadgentoo-2-d6eab3fd96380b328f55ab4c09f4bbb83f08e20d.tar.gz
gentoo-2-d6eab3fd96380b328f55ab4c09f4bbb83f08e20d.tar.bz2
gentoo-2-d6eab3fd96380b328f55ab4c09f4bbb83f08e20d.zip
Do not call python_convert_shebangs() on files, which are not Python scripts. Patch by Arfrever.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog7
-rw-r--r--media-tv/mythtv/mythtv-0.25.1_p20120708.ebuild8
-rw-r--r--media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild8
-rw-r--r--media-tv/mythtv/mythtv-0.25.2_p20120716.ebuild8
4 files changed, 21 insertions, 10 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 6bb6f6e1855f..492920964d97 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythtv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.374 2012/07/21 21:47:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.375 2012/07/23 16:31:26 floppym Exp $
+
+ 23 Jul 2012; Mike Gilbert <floppym@gentoo.org> mythtv-0.25.1_p20120708.ebuild,
+ mythtv-0.25.1_p20120715.ebuild, mythtv-0.25.2_p20120716.ebuild:
+ Do not call python_convert_shebangs() on files, which are not Python scripts.
+ Patch by Arfrever.
21 Jul 2012; Doug Goldstein <cardoe@gentoo.org>
mythtv-0.25.2_p20120716.ebuild:
diff --git a/media-tv/mythtv/mythtv-0.25.1_p20120708.ebuild b/media-tv/mythtv/mythtv-0.25.1_p20120708.ebuild
index 4ac396bfe7ae..c9b70410b244 100644
--- a/media-tv/mythtv/mythtv-0.25.1_p20120708.ebuild
+++ b/media-tv/mythtv/mythtv-0.25.1_p20120708.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.25.1_p20120708.ebuild,v 1.10 2012/07/12 03:03:14 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.25.1_p20120708.ebuild,v 1.11 2012/07/23 16:31:26 floppym Exp $
EAPI=4
@@ -266,14 +266,16 @@ src_install() {
newins "${FILESDIR}"/xinitrc-r1 .xinitrc
fi
- # Make Python files executable and ensure they are executed by Python 2
+ # Make Python files executable
find "${ED}/usr/share/mythtv" -type f -name '*.py' | while read file; do
if [[ ! "${file##*/}" = "__init__.py" ]]; then
chmod a+x "${file}"
- python_convert_shebangs -q 2 "${file}"
fi
done
+ # Ensure that Python scripts are executed by Python 2
+ python_convert_shebangs -q -r 2 "${ED}/usr/share/mythtv"
+
# Make shell & perl scripts executable
find "${ED}" -type f -name '*.sh' -o -type f -name '*.pl' | \
while read file; do
diff --git a/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild b/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild
index 9a693f2a2f4f..6ec9f7a85748 100644
--- a/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild
+++ b/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild,v 1.1 2012/07/15 22:40:09 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.25.1_p20120715.ebuild,v 1.2 2012/07/23 16:31:26 floppym Exp $
EAPI=4
@@ -262,14 +262,16 @@ src_install() {
newins "${FILESDIR}"/xinitrc-r1 .xinitrc
fi
- # Make Python files executable and ensure they are executed by Python 2
+ # Make Python files executable
find "${ED}/usr/share/mythtv" -type f -name '*.py' | while read file; do
if [[ ! "${file##*/}" = "__init__.py" ]]; then
chmod a+x "${file}"
- python_convert_shebangs -q 2 "${file}"
fi
done
+ # Ensure that Python scripts are executed by Python 2
+ python_convert_shebangs -q -r 2 "${ED}/usr/share/mythtv"
+
# Make shell & perl scripts executable
find "${ED}" -type f -name '*.sh' -o -type f -name '*.pl' | \
while read file; do
diff --git a/media-tv/mythtv/mythtv-0.25.2_p20120716.ebuild b/media-tv/mythtv/mythtv-0.25.2_p20120716.ebuild
index c3c16b3f785e..28c13b1fa021 100644
--- a/media-tv/mythtv/mythtv-0.25.2_p20120716.ebuild
+++ b/media-tv/mythtv/mythtv-0.25.2_p20120716.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.25.2_p20120716.ebuild,v 1.7 2012/07/21 21:47:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.25.2_p20120716.ebuild,v 1.8 2012/07/23 16:31:26 floppym Exp $
EAPI=4
@@ -287,14 +287,16 @@ src_install() {
newins "${FILESDIR}"/xinitrc-r1 .xinitrc
fi
- # Make Python files executable and ensure they are executed by Python 2
+ # Make Python files executable
find "${ED}/usr/share/mythtv" -type f -name '*.py' | while read file; do
if [[ ! "${file##*/}" = "__init__.py" ]]; then
chmod a+x "${file}"
- python_convert_shebangs -q 2 "${file}"
fi
done
+ # Ensure that Python scripts are executed by Python 2
+ python_convert_shebangs -q -r 2 "${ED}/usr/share/mythtv"
+
# Make shell & perl scripts executable
find "${ED}" -type f -name '*.sh' -o -type f -name '*.pl' | \
while read file; do