summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-19 18:40:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-19 18:40:25 +0000
commit03ed9ad44862621551c57c55c78992bdb1b7e2a2 (patch)
tree3a69bc5def364862cd606f66d1cb398f56ec8c99 /media-video/alevt
parentfixing keywords on new version (diff)
downloadgentoo-2-03ed9ad44862621551c57c55c78992bdb1b7e2a2.tar.gz
gentoo-2-03ed9ad44862621551c57c55c78992bdb1b7e2a2.tar.bz2
gentoo-2-03ed9ad44862621551c57c55c78992bdb1b7e2a2.zip
Respect LDFLAGS, add -fno-strict-aliasing, remove stale file.
(Portage version: 2.1_pre6-r4)
Diffstat (limited to 'media-video/alevt')
-rw-r--r--media-video/alevt/ChangeLog7
-rw-r--r--media-video/alevt/alevt-1.6.1-r3.ebuild18
-rw-r--r--media-video/alevt/files/alevt-1.6.0-gentoo.diff40
-rw-r--r--media-video/alevt/files/alevt-1.6.1-respectflags.patch44
4 files changed, 60 insertions, 49 deletions
diff --git a/media-video/alevt/ChangeLog b/media-video/alevt/ChangeLog
index 54991f7e5836..9c45d145da60 100644
--- a/media-video/alevt/ChangeLog
+++ b/media-video/alevt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/alevt
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/ChangeLog,v 1.21 2006/01/15 23:01:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/ChangeLog,v 1.22 2006/03/19 18:40:25 flameeyes Exp $
+
+ 19 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/alevt-1.6.0-gentoo.diff, +files/alevt-1.6.1-respectflags.patch,
+ alevt-1.6.1-r3.ebuild:
+ Respect LDFLAGS, add -fno-strict-aliasing, remove stale file.
15 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> -files/alevt.desktop,
-files/xio_timer.patch, -alevt-1.6.1-r2.ebuild:
diff --git a/media-video/alevt/alevt-1.6.1-r3.ebuild b/media-video/alevt/alevt-1.6.1-r3.ebuild
index e317dc0ff0b7..87d3c864ced1 100644
--- a/media-video/alevt/alevt-1.6.1-r3.ebuild
+++ b/media-video/alevt/alevt-1.6.1-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/alevt-1.6.1-r3.ebuild,v 1.1 2005/12/20 13:00:46 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/alevt-1.6.1-r3.ebuild,v 1.2 2006/03/19 18:40:25 flameeyes Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="Teletext viewer for X11"
HOMEPAGE="http://www.goron.de/~froese/"
@@ -24,14 +24,16 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
- epatch ${FILESDIR}/${P}-gcc4.patch
- epatch ${DISTDIR}/${PN}-dvb.patch
- epatch ${FILESDIR}/${P}-v4l2.patch
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${DISTDIR}/${PN}-dvb.patch"
+ epatch "${FILESDIR}/${P}-v4l2.patch"
+ epatch "${FILESDIR}/${P}-respectflags.patch"
}
src_compile() {
- emake CC="$(tc-getCC)" OPT="${CFLAGS}" || die
+ append-flags -fno-strict-aliasing
+ emake CC="$(tc-getCC)" || die
}
src_install() {
diff --git a/media-video/alevt/files/alevt-1.6.0-gentoo.diff b/media-video/alevt/files/alevt-1.6.0-gentoo.diff
deleted file mode 100644
index 06abd4e907f4..000000000000
--- a/media-video/alevt/files/alevt-1.6.0-gentoo.diff
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -ru alevt-1.6.0.orig/Makefile alevt-1.6.0/Makefile
---- alevt-1.6.0.orig/Makefile Wed Oct 11 20:08:29 2000
-+++ alevt-1.6.0/Makefile Thu Apr 11 19:56:50 2002
-@@ -126,3 +126,5 @@
- ui.o: search.h export.h ui.h
- vbi.o: os.h vt.h misc.h vbi.h dllist.h cache.h lang.h fdset.h hamm.h
- xio.o: vt.h misc.h dllist.h xio.h fdset.h lang.h icon.xbm font.h
-+font.o: font1.xbm font2.xbm
-+
-diff -ru alevt-1.6.0.orig/alevt-date.c alevt-1.6.0/alevt-date.c
---- alevt-1.6.0.orig/alevt-date.c Sat Sep 16 23:34:42 2000
-+++ alevt-1.6.0/alevt-date.c Wed Apr 10 21:48:09 2002
-@@ -1,5 +1,6 @@
- #include <stdio.h>
- #include <sys/time.h>
-+#include <time.h>
- #include <stdlib.h>
- #include <unistd.h>
- #include <signal.h>
-diff -ru alevt-1.6.0.orig/main.c alevt-1.6.0/main.c
---- alevt-1.6.0.orig/main.c Sat Sep 16 23:34:18 2000
-+++ alevt-1.6.0/main.c Wed Apr 10 23:09:40 2002
-@@ -15,7 +15,7 @@
- /* current args for next start() */
- static char *geometry;
- static char *dpy_name;
--static char *vbi_name = "/dev/vbi";
-+static char *vbi_name = "/dev/v4l/vbi0";
- static struct xio *xio;
- static struct vbi *vbi;
- static int fine_tune = 1; // auto = 999;
-@@ -32,7 +32,7 @@
- " Valid options:\t\tDefault:\n"
- " --help\n"
- " --version\n"
-- " -vbi <vbidev>\t\t/dev/vbi\n"
-+ " -vbi <vbidev>\t\t/dev/v4l/vbi0\n"
- " -display <dpy>\t\t$DISPLAY\n"
- " -geometry <geo>\t\t41x25\n"
- " -finetune <-4..4|auto>\t0\n"
diff --git a/media-video/alevt/files/alevt-1.6.1-respectflags.patch b/media-video/alevt/files/alevt-1.6.1-respectflags.patch
new file mode 100644
index 000000000000..d8eafe504863
--- /dev/null
+++ b/media-video/alevt/files/alevt-1.6.1-respectflags.patch
@@ -0,0 +1,44 @@
+Index: alevt-1.6.1/Makefile
+===================================================================
+--- alevt-1.6.1.orig/Makefile
++++ alevt-1.6.1/Makefile
+@@ -1,12 +1,11 @@
+ VER=1.6.1
+-OPT=-O2 -s
+ #OPT=-O -g
+ DEFS=-DWITH_PNG
+ FONT=vtxt
+ # a smaller and thinner font
+ #FONT=neep9
+
+-CFLAGS=$(OPT) -DVERSION=\"$(VER)\" $(DEFS) -I/usr/X11R6/include -I/usr/local/include -W
++CFLAGS+=-DVERSION=\"$(VER)\" $(DEFS)
+
+ EXPOBJS=export.o exp-txt.o exp-html.o exp-gfx.o font.o
+ OBJS=main.o ui.o xio.o fdset.o vbi.o cache.o help.o edline.o search.o edit.o misc.o hamm.o lang.o $(EXPOBJS)
+@@ -21,13 +20,13 @@ all: alevt alevt-date alevt-cap alevt.1x
+ sync
+
+ alevt: $(OBJS)
+- $(CC) $(OPT) $(OBJS) -o alevt -L/usr/X11R6/lib -lX11 $(EXPLIBS)
++ $(CC) $(LDFLAGS) $(OPT) $(OBJS) -o alevt -L/usr/X11R6/lib -lX11 $(EXPLIBS)
+
+ alevt-date: $(TOBJS)
+- $(CC) $(OPT) $(TOBJS) -o alevt-date
++ $(CC) $(LDFLAGS) $(OPT) $(TOBJS) -o alevt-date
+
+ alevt-cap: $(COBJS)
+- $(CC) $(OPT) $(COBJS) -o alevt-cap $(EXPLIBS)
++ $(CC) $(LDFLAGS) $(OPT) $(COBJS) -o alevt-cap $(EXPLIBS)
+
+ font.o: font1.xbm font2.xbm
+ fontsize.h: font1.xbm font2.xbm
+@@ -40,7 +39,7 @@ font2.xbm: bdf2xbm $(FONT)-latin-2.bdf
+ ./bdf2xbm font2 <$(FONT)-latin-2.bdf >font2.xbm
+
+ bdf2xbm: bdf2xbm.c
+- $(CC) -O -s bdf2xbm.c -o bdf2xbm
++ $(CC) $(CFLAGS) $(LDFLAGS) bdf2xbm.c -o bdf2xbm
+
+ alevt.1x: alevt.1x.in
+ sed s/VERSION/$(VER)/g <alevt.1x.in >alevt.1x