summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-10-19 14:20:48 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-10-19 14:20:48 +0000
commit7fb8f298b47bf3ef127d12e7abed112694ff3890 (patch)
tree7d83bab13291913c63362d2808b0410157a69dad /media-video/ati-drivers
parentMarking curl-7.15.0 ppc64 stable for bug 109097 (diff)
downloadgentoo-2-7fb8f298b47bf3ef127d12e7abed112694ff3890.tar.gz
gentoo-2-7fb8f298b47bf3ef127d12e7abed112694ff3890.tar.bz2
gentoo-2-7fb8f298b47bf3ef127d12e7abed112694ff3890.zip
access_ok bug #109493 fixed and drm support as module bug #109689 fixed
(Portage version: 1.589-cvs)
Diffstat (limited to 'media-video/ati-drivers')
-rw-r--r--media-video/ati-drivers/ChangeLog7
-rw-r--r--media-video/ati-drivers/ati-drivers-8.18.6.ebuild17
2 files changed, 15 insertions, 9 deletions
diff --git a/media-video/ati-drivers/ChangeLog b/media-video/ati-drivers/ChangeLog
index 8957091c188f..c22591e28c2c 100644
--- a/media-video/ati-drivers/ChangeLog
+++ b/media-video/ati-drivers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ati-drivers
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ChangeLog,v 1.118 2005/10/16 15:27:48 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ChangeLog,v 1.119 2005/10/19 14:20:48 lu_zero Exp $
+
+ 19 Oct 2005; Luca Barbato <lu_zero@gentoo.org> ati-drivers-8.18.6.ebuild:
+ Fix the verify_area/access_ok symbol, as reported in bug #109493 (thank you
+ Alex Giouzenis <agios@computer.org>), fixed the bug #109689 ( thank you Jakub
+ Argasiñski <argasek@tekla.art.pl>)
16 Oct 2005; Luca Barbato <lu_zero@gentoo.org>
files/digest-ati-drivers-8.18.6, Manifest:
diff --git a/media-video/ati-drivers/ati-drivers-8.18.6.ebuild b/media-video/ati-drivers/ati-drivers-8.18.6.ebuild
index 058118b78f39..ad5b3c698ec8 100644
--- a/media-video/ati-drivers/ati-drivers-8.18.6.ebuild
+++ b/media-video/ati-drivers/ati-drivers-8.18.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ati-drivers-8.18.6.ebuild,v 1.1 2005/10/15 16:18:38 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-drivers/ati-drivers-8.18.6.ebuild,v 1.2 2005/10/19 14:20:48 lu_zero Exp $
IUSE="opengl"
@@ -32,7 +32,6 @@ pkg_setup(){
#check kernel and sets up KV_OBJ
linux-mod_pkg_setup
local agp
-
ebegin "Checking for MTRR support enabled"
linux_chkconfig_present MTRR
eend $?
@@ -58,10 +57,10 @@ pkg_setup(){
fi
ebegin "Checking for DRM support disabled"
- ! linux_chkconfig_present DRM
+ ! linux_chkconfig_builtin DRM
eend $?
if [[ $? -ne 0 ]] ; then
- ewarn "You have DRM support enabled, the direct rendering"
+ ewarn "You have DRM support enabled builtin, the direct rendering"
ewarn "will not work."
fi
@@ -80,11 +79,13 @@ src_unpack() {
cd ${WORKDIR}/lib/modules/fglrx/build_mod
-# if kernel_is 2 6
-# then
+ if kernel_is 2 6
+ then
+ sed -i -e "s:verify_area:access_ok:g" \
+ drm_os_linux.h firegl_public.c firegl_public.h
# epatch ${FILESDIR}/fglrx-2.6.12-pci_name.patch
# epatch ${FILESDIR}/fglrx-2.6.12-inter_module_get.patch
-# fi
+ fi
# epatch ${FILESDIR}/8.8.25-via-amd64.patch
# epatch ${FILESDIR}/8.8.25-smp.patch
# epatch ${FILESDIR}/8.14.13-amd64.patch
@@ -119,7 +120,7 @@ src_compile() {
-e "s:\`uname -r\`:${KV_FULL}:" \
-i make.sh
chmod +x make.sh
- ./make.sh || die "DRM module not built"
+ ./make.sh || ewarn "DRM module not built"
fi
}