summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-21 11:10:53 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-21 11:10:53 +0000
commitbc451eea392fbc9c923202b418e72533d7debc21 (patch)
tree28bfc26d83ee615b6f5c1f8d3e754eee20f03fe1 /media-video/avidemux/avidemux-2.0.20.ebuild
parentVersion bumped. Closes 36224. (diff)
downloadgentoo-2-bc451eea392fbc9c923202b418e72533d7debc21.tar.gz
gentoo-2-bc451eea392fbc9c923202b418e72533d7debc21.tar.bz2
gentoo-2-bc451eea392fbc9c923202b418e72533d7debc21.zip
Version bumped. Closes 36224.
Diffstat (limited to 'media-video/avidemux/avidemux-2.0.20.ebuild')
-rw-r--r--media-video/avidemux/avidemux-2.0.20.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/media-video/avidemux/avidemux-2.0.20.ebuild b/media-video/avidemux/avidemux-2.0.20.ebuild
new file mode 100644
index 000000000000..daaf2588508a
--- /dev/null
+++ b/media-video/avidemux/avidemux-2.0.20.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.0.20.ebuild,v 1.1 2003/12/21 11:10:33 mholzer Exp $
+
+IUSE="debug nls oggvorbis arts truetype alsa"
+filter-flags "-funroll-loops"
+filter-flags "-maltivec -mabi=altivec"
+inherit eutils
+
+MY_P=${P}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Great Video editing/encoding tool. New, gtk2 version"
+HOMEPAGE="http://fixounet.free.fr/avidemux/"
+SRC_URI="http://fixounet.free.fr/avidemux/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/x11
+ media-sound/mad
+ >=media-libs/a52dec-0.7.4
+ >=media-sound/lame-3.93
+ >=media-video/mjpegtools-1.6
+ >=media-libs/xvid-0.9
+ >=dev-libs/libxml2-2.5.7
+ >=x11-libs/gtk+-2.2.4-r1
+ x86? ( >=media-libs/divx4linux-20030428 )
+ x86? ( dev-lang/nasm )
+ nls? ( >=sys-devel/gettext-0.11.2 )
+ oggvorbis? ( >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0 )
+ arts? ( >=kde-base/arts-1.1.1 )
+ truetype? ( >=media-libs/freetype-2.1.2 )
+ alsa? ( >=media-libs/alsa-lib-0.9.1 )"
+# media-sound/toolame is supported as well
+
+
+src_compile() {
+ # Fixes a possible automake error due to clock skew
+ touch -r *
+
+ export WANT_AUTOCONF_2_5=1
+ autoconf
+
+ # invalid cast
+ use ppc \
+ && sed -i -e '188s/const//g' avidemux/ADM_video/ADM_vidFont.cpp
+
+ local myconf
+ myconf="--with-gnu-ld --disable-warnings"
+
+ # --enable-profile creates profiling infos default=no
+ # --enable-pch enables precompiled header support
+ # (currently only KCC) default=no
+ # --enable-final build size optimized apps
+ # (experimental - needs lots of memory)
+ # --disable-closure don't delay template instantiation
+
+ use debug && myconf="${myconf} --enable-debug=full"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die "configure failed"
+
+ make || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog History README TODO
+}
+
+pkg_postinst() {
+
+ if [ -n "`use pcc`" ]
+ then
+ echo
+ einfo "OSS sound output may not work on ppc"
+ einfo "If your hear only static noise, try"
+ einfo "changing the sound device to ALSA or arts"
+ fi
+}