summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-09-06 02:20:56 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-09-06 02:20:56 +0000
commit0864d61fff4950fa12d7cfe7273f3278b3f22506 (patch)
treea234673e496af1f5e943ebd63253fad77c366196 /media-video/codeine/codeine-1.0.ebuild
parentcheck the return value of find_unpackable_file in case it failed (diff)
downloadgentoo-2-0864d61fff4950fa12d7cfe7273f3278b3f22506.tar.gz
gentoo-2-0864d61fff4950fa12d7cfe7273f3278b3f22506.tar.bz2
gentoo-2-0864d61fff4950fa12d7cfe7273f3278b3f22506.zip
Version bump, fixed multilib issues, closes bug 104500.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-video/codeine/codeine-1.0.ebuild')
-rw-r--r--media-video/codeine/codeine-1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-video/codeine/codeine-1.0.ebuild b/media-video/codeine/codeine-1.0.ebuild
new file mode 100644
index 000000000000..2fda7bfb441c
--- /dev/null
+++ b/media-video/codeine/codeine-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/codeine/codeine-1.0.ebuild,v 1.1 2005/09/06 02:20:56 cryos Exp $
+
+inherit kde multilib
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Simple KDE frontend for xine-lib."
+HOMEPAGE="http://kde-apps.org/content/show.php?content=17161"
+SRC_URI="http://www.methylblue.com/codeine/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="media-libs/xine-lib"
+
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+need-kde 3.3
+
+src_compile(){
+ local myconf="prefix=/usr"
+ use debug && myconf="${myconf} debug=full"
+ # Fix multilib issue.
+ myconf="${myconf} libdir=/usr/$(get_libdir)"
+
+ scons configure ${myconf} || die
+ scons || die
+}
+
+src_install() {
+ DESTDIR="${D}" scons install || die
+ dodoc README ChangeLog VERSION
+}