summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-01-11 20:25:04 +0000
committerMichael Weber <xmw@gentoo.org>2011-01-11 20:25:04 +0000
commita02fb251ab400b5b5922bedb5ba61cd0e31c32dd (patch)
treeaacbbb0bc9719ddcbf963ed198980fef86a1459e /media-video/coherence/coherence-0.6.6.1.ebuild
parentNeeds gnome-panel with bonobo support (bug #348185). (diff)
downloadgentoo-2-a02fb251ab400b5b5922bedb5ba61cd0e31c32dd.tar.gz
gentoo-2-a02fb251ab400b5b5922bedb5ba61cd0e31c32dd.tar.bz2
gentoo-2-a02fb251ab400b5b5922bedb5ba61cd0e31c32dd.zip
Fix python issues (bug 313987) and version bump (bug 349476).
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'media-video/coherence/coherence-0.6.6.1.ebuild')
-rw-r--r--media-video/coherence/coherence-0.6.6.1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-video/coherence/coherence-0.6.6.1.ebuild b/media-video/coherence/coherence-0.6.6.1.ebuild
index 79c94ef5de9f..9ac2ae45603e 100644
--- a/media-video/coherence/coherence-0.6.6.1.ebuild
+++ b/media-video/coherence/coherence-0.6.6.1.ebuild
@@ -1,13 +1,18 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/coherence/coherence-0.6.6.1.ebuild,v 1.5 2011/01/07 09:37:06 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/coherence/coherence-0.6.6.1.ebuild,v 1.6 2011/01/11 20:25:04 xmw Exp $
EAPI=2
-inherit distutils
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="sqlite"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils python
MY_P="Coherence-${PV}"
-DESCRIPTION="Coherence is a framework written in Python for DLNA/UPnP components"
+DESCRIPTION="A framework written in Python for DLNA/UPnP components"
HOMEPAGE="https://coherence.beebits.net/"
SRC_URI="http://coherence.beebits.net/download/${MY_P}.tar.gz"
@@ -27,7 +32,6 @@ RDEPEND="${DEPEND}
dev-python/axiom
dev-python/gdata
dev-python/feedparser
- dev-lang/python[sqlite]
dev-python/tagpy"
S="${WORKDIR}/${MY_P}"