summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-18 13:25:07 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-18 13:25:07 +0000
commitbbd35478c713eabe05d2b8b241a83733aabe8bb6 (patch)
treecfa2e556346963a4e9ed856b1acfa247164033dd /media-video/dvdstyler
parentDropped dependency on notification-daemon*, bug #253334. (diff)
downloadgentoo-2-bbd35478c713eabe05d2b8b241a83733aabe8bb6.tar.gz
gentoo-2-bbd35478c713eabe05d2b8b241a83733aabe8bb6.tar.bz2
gentoo-2-bbd35478c713eabe05d2b8b241a83733aabe8bb6.zip
version bump as per bug #215665. Thanks to all that waited so long and provided feedback
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-thinkpad-r1 i686)
Diffstat (limited to 'media-video/dvdstyler')
-rw-r--r--media-video/dvdstyler/ChangeLog10
-rw-r--r--media-video/dvdstyler/dvdstyler-1.5-r1.ebuild4
-rw-r--r--media-video/dvdstyler/dvdstyler-1.7.1.ebuild53
-rw-r--r--media-video/dvdstyler/dvdstyler-1.7.2_beta3.ebuild50
4 files changed, 114 insertions, 3 deletions
diff --git a/media-video/dvdstyler/ChangeLog b/media-video/dvdstyler/ChangeLog
index 29335f5a90bc..a6b693381da8 100644
--- a/media-video/dvdstyler/ChangeLog
+++ b/media-video/dvdstyler/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/dvdstyler
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.31 2009/01/03 15:15:28 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.32 2009/01/18 13:25:07 dragonheart Exp $
+
+*dvdstyler-1.7.2_beta3 (18 Jan 2009)
+*dvdstyler-1.7.1 (18 Jan 2009)
+
+ 18 Jan 2009; Daniel Black <dragonheart@gentoo.org>
+ +dvdstyler-1.7.1.ebuild, +dvdstyler-1.7.2_beta3.ebuild:
+ version bump as per bug #215665. Thanks to all that waited so long and
+ provided feedback
03 Jan 2009; Christoph Mende <angelos@gentoo.org> dvdstyler-1.5.1.ebuild,
dvdstyler-1.5.1_p2.ebuild:
diff --git a/media-video/dvdstyler/dvdstyler-1.5-r1.ebuild b/media-video/dvdstyler/dvdstyler-1.5-r1.ebuild
index 048e06d49119..362b55a5cb6d 100644
--- a/media-video/dvdstyler/dvdstyler-1.5-r1.ebuild
+++ b/media-video/dvdstyler/dvdstyler-1.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.5-r1.ebuild,v 1.4 2008/04/01 15:17:39 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.5-r1.ebuild,v 1.5 2009/01/18 13:25:07 dragonheart Exp $
inherit wxwidgets
diff --git a/media-video/dvdstyler/dvdstyler-1.7.1.ebuild b/media-video/dvdstyler/dvdstyler-1.7.1.ebuild
new file mode 100644
index 000000000000..1a944cd7edb6
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-1.7.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.1.ebuild,v 1.1 2009/01/18 13:25:07 dragonheart Exp $
+
+WX_GTK_VER=2.8
+inherit eutils autotools wxwidgets
+
+MY_P=DVDStyler-${PV}
+
+DESCRIPTION="DVDStyler is a cross-platform DVD authoring System"
+HOMEPAGE="http://www.dvdstyler.de"
+SRC_URI="mirror://sourceforge/dvdstyler/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome"
+
+COMMON_DEPEND="
+ media-video/ffmpeg
+ =x11-libs/wxGTK-2.8*
+ >=media-libs/wxsvg-1.0
+ >=media-libs/libexif-0.6.16
+ gnome? ( >=gnome-base/libgnomeui-2.0 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/cdrtools
+ >=media-video/dvdauthor-0.6.14
+ >=app-cdr/dvd+rw-tools-7.1
+ >=app-cdr/dvdisaster-0.71.0"
+# doco says .16 >=media-video/dvdauthor-0.6.16
+DEPEND="${COMMON_DEEND}
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-wx-config="${WX_CONFIG}"
+ emake || die 'compile failed'
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ rm "${D}"usr/share/doc/${PN}/COPYING "${D}"usr/share/doc/${PN}/INSTALL
+ mv "${D}"usr/share/doc/${PN} "${D}"usr/share/doc/${PF}
+
+ make_desktop_entry dvdstyler DVDStyler /usr/share/dvdstyler/rc/dvdstyler.png AudioVideo
+}
diff --git a/media-video/dvdstyler/dvdstyler-1.7.2_beta3.ebuild b/media-video/dvdstyler/dvdstyler-1.7.2_beta3.ebuild
new file mode 100644
index 000000000000..a389081750bc
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-1.7.2_beta3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.2_beta3.ebuild,v 1.1 2009/01/18 13:25:07 dragonheart Exp $
+
+EAPI=2
+inherit eutils wxwidgets
+
+MY_P=DVDStyler-${PV/_beta/b}
+
+DESCRIPTION="DVDStyler is a cross-platform DVD authoring System"
+HOMEPAGE="http://www.dvdstyler.de"
+SRC_URI="mirror://sourceforge/dvdstyler/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome"
+
+COMMON_DEPEND="
+ media-video/ffmpeg
+ x11-libs/wxGTK:2.8
+ >=media-libs/wxsvg-1.0
+ >=media-libs/libexif-0.6.16
+ gnome? ( >=gnome-base/libgnomeui-2.0 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/cdrtools
+ >=media-video/dvdauthor-0.6.14
+ >=app-cdr/dvd+rw-tools-7.1
+ >=app-cdr/dvdisaster-0.71.0"
+# >=media-video/dvdauthor-0.6.16
+DEPEND="${COMMON_DEEND}
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ export WX_GTK_VER="2.8"
+ need-wxwidgets gtk2
+ myconf="${myconf} --with-wx-config=${WX_CONFIG}"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ rm "${D}"usr/share/doc/${PN}/COPYING "${D}"usr/share/doc/${PN}/INSTALL
+ mv "${D}"usr/share/doc/${PN} "${D}"usr/share/doc/${PF}
+
+ make_desktop_entry dvdstyler DVDStyler /usr/share/dvdstyler/rc/dvdstyler.png AudioVideo
+}