summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-09-15 20:34:08 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-09-15 20:34:08 +0000
commitb0a0848ea54ec4b4c6994fb4fabb93de8becfffd (patch)
tree379fba3595f819f4cebb2baeb14d834289949004 /media-video/effectv
parentChange hard-coded /opt to GAMES_PREFIX_OPT. (diff)
downloadgentoo-2-b0a0848ea54ec4b4c6994fb4fabb93de8becfffd.tar.gz
gentoo-2-b0a0848ea54ec4b4c6994fb4fabb93de8becfffd.tar.bz2
gentoo-2-b0a0848ea54ec4b4c6994fb4fabb93de8becfffd.zip
Version bumped, thanks to Francisco Javier <ffelix@sshinf.com> for reporting, Bug #146749.
(Portage version: 2.1.1)
Diffstat (limited to 'media-video/effectv')
-rw-r--r--media-video/effectv/ChangeLog9
-rw-r--r--media-video/effectv/effectv-0.3.11.ebuild42
-rw-r--r--media-video/effectv/files/digest-effectv-0.3.113
-rw-r--r--media-video/effectv/files/effectv-0.3.11-timedist.patch51
4 files changed, 104 insertions, 1 deletions
diff --git a/media-video/effectv/ChangeLog b/media-video/effectv/ChangeLog
index 462f84855b34..4dcbb9cef9d7 100644
--- a/media-video/effectv/ChangeLog
+++ b/media-video/effectv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/effectv
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/effectv/ChangeLog,v 1.3 2006/08/30 15:42:47 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/effectv/ChangeLog,v 1.4 2006/09/15 20:34:08 zzam Exp $
+
+*effectv-0.3.11 (15 Sep 2006)
+
+ 15 Sep 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/effectv-0.3.11-timedist.patch, +effectv-0.3.11.ebuild:
+ Version bumped, thanks to Francisco Javier <ffelix@sshinf.com> for
+ reporting, Bug #146749.
30 Aug 2006; Matthias Schwarzott <zzam@gentoo.org>
+files/effectv-0.3.10-trunc-name-collision.patch, effectv-0.3.10.ebuild:
diff --git a/media-video/effectv/effectv-0.3.11.ebuild b/media-video/effectv/effectv-0.3.11.ebuild
new file mode 100644
index 000000000000..913f7bdf7c29
--- /dev/null
+++ b/media-video/effectv/effectv-0.3.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/effectv/effectv-0.3.11.ebuild,v 1.1 2006/09/15 20:34:08 zzam Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="EffecTV is a real-time video effect-processor"
+HOMEPAGE="http://effectv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mmx"
+DEPEND="x86? ( dev-lang/nasm )
+ media-libs/libsdl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${PN}-0.3.10-makefile.patch"
+ epatch "${FILESDIR}/${PN}-0.3.10-trunc-name-collision.patch"
+ epatch "${FILESDIR}/${P}-timedist.patch"
+}
+
+src_compile() {
+ local mmx
+ local nasm
+
+ use mmx && mmx="yes" || mmx="no"
+ [[ $(tc-arch) == "x86" ]] && nasm="yes" || nasm="no"
+
+ emake CC="$(tc-getCC)" PREFIX="/usr" CFLAGS.opt="${CFLAGS}" \
+ USE_MMX=${mmx} USE_NASM=${nasm} ARCH= || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${PN}
+ doman *.1
+ dodoc CREWS ChangeLog FAQ NEWS README TODO
+}
+
diff --git a/media-video/effectv/files/digest-effectv-0.3.11 b/media-video/effectv/files/digest-effectv-0.3.11
new file mode 100644
index 000000000000..2f2b92d29d6b
--- /dev/null
+++ b/media-video/effectv/files/digest-effectv-0.3.11
@@ -0,0 +1,3 @@
+MD5 28e2e0a6550ffe48d9e62252d6a6bbce effectv-0.3.11.tar.bz2 108010
+RMD160 6472000ca37ef3138ac4ac668356ce48de976628 effectv-0.3.11.tar.bz2 108010
+SHA256 51f0dfe915504ae95f8ae438f1abf9d8765ca6668b1f3d671b22f9c88ef663d2 effectv-0.3.11.tar.bz2 108010
diff --git a/media-video/effectv/files/effectv-0.3.11-timedist.patch b/media-video/effectv/files/effectv-0.3.11-timedist.patch
new file mode 100644
index 000000000000..e303d9290402
--- /dev/null
+++ b/media-video/effectv/files/effectv-0.3.11-timedist.patch
@@ -0,0 +1,51 @@
+This is a quick fix for bugs of effectv-0.3.11. TimeDistortion has a border
+crossing bug and a buffer uninitializing bug.
+
+Index: effects/timedist.c
+===================================================================
+--- effects/timedist.c (revision 478)
++++ effects/timedist.c (working copy)
+@@ -27,7 +27,16 @@
+ static int plane;
+ static int *warptime[2];
+ static int warptimeFrame;
++static int bgIsSet;
+
++static int setBackground(RGB32 *src)
++{
++ image_bgset_y(src);
++ bgIsSet = 1;
++
++ return 0;
++}
++
+ effect *timeDistortionRegister(void)
+ {
+ effect *entry;
+@@ -70,6 +79,7 @@
+
+ plane = 0;
+ image_set_threshold_y(MAGIC_THRESHOLD);
++ bgIsSet = 0;
+
+ state = 1;
+ return 0;
+@@ -94,6 +104,9 @@
+ int *p, *q;
+
+ memcpy(planetable[plane], src, PIXEL_SIZE * video_area);
++ if(!bgIsSet) {
++ setBackground(src);
++ }
+ diff = image_bgsubtract_update_y(src);
+
+ p = warptime[warptimeFrame ] + video_width + 1;
+@@ -109,7 +122,7 @@
+ q += 2;
+ }
+
+- q = warptime[warptimeFrame ^ 1] + video_width + 1;
++ q = warptime[warptimeFrame ^ 1];
+ for(i=0; i<video_area; i++) {
+ if(*diff++) {
+ *q = PLANES - 1;