summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-13 05:25:04 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-13 05:25:04 +0000
commit45883b615fadd42399e80d2a8fdfbec51561b4b2 (patch)
treeea9f7c8342dd1eb1733a6083e1d337a0323de760 /media-video/em8300-modules
parentforgot to add this (diff)
downloadgentoo-2-45883b615fadd42399e80d2a8fdfbec51561b4b2.tar.gz
gentoo-2-45883b615fadd42399e80d2a8fdfbec51561b4b2.tar.bz2
gentoo-2-45883b615fadd42399e80d2a8fdfbec51561b4b2.zip
bump
Diffstat (limited to 'media-video/em8300-modules')
-rw-r--r--media-video/em8300-modules/ChangeLog9
-rw-r--r--media-video/em8300-modules/em8300-modules-0.13.0.ebuild88
-rw-r--r--media-video/em8300-modules/files/digest-em8300-modules-0.13.01
3 files changed, 96 insertions, 2 deletions
diff --git a/media-video/em8300-modules/ChangeLog b/media-video/em8300-modules/ChangeLog
index 6dccd2b84765..28bfd28e649e 100644
--- a/media-video/em8300-modules/ChangeLog
+++ b/media-video/em8300-modules/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for media-video/em8300-modules
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.4 2002/05/11 17:04:54 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.5 2002/12/13 05:24:47 lostlogic Exp $
+*em8300-modules-0.13.0 (12 Dec 2002)
+
+ 12 Dec 2002; Brandon Low <lostlogic@gentoo.org> em8300-libraries-0.13.0 :
+ Bump.
+
*em8300-modules-0.12.0 (April 22, 2002)
11 May 2002; Arcady Genkin <agenkin@thpoon.com> em8300-libraries-0.12.0 :
@@ -18,4 +23,4 @@
22 April 2002; Arcady Genkin <agenkin@thpoon.com> em8300-libraries-0.12.0 :
- Initial version, submitted by Brandon Low <lostlogic@lostlogicx.com>. \ No newline at end of file
+ Initial version, submitted by Brandon Low <lostlogic@lostlogicx.com>.
diff --git a/media-video/em8300-modules/em8300-modules-0.13.0.ebuild b/media-video/em8300-modules/em8300-modules-0.13.0.ebuild
new file mode 100644
index 000000000000..c0e929f978d8
--- /dev/null
+++ b/media-video/em8300-modules/em8300-modules-0.13.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.13.0.ebuild,v 1.1 2002/12/13 05:24:47 lostlogic Exp $
+
+S="${WORKDIR}/${P}/modules"
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card kernel modules"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="mirror://sourceforge/dxr3/${P/-modules/}.tar.gz"
+
+DEPEND="virtual/linux-sources"
+RDEPEND="${DEPEND}
+ >=sys-apps/portage-1.9.10"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+
+src_unpack () {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ mv ${A/.tar.gz/} ${P}
+
+ # Portage should determine the version of the kernel sources
+ check_KV
+
+ cd ${S}
+ #Make the em8300 makefile cooperate with our kernel version
+ #and default to NTSC video output, xine and other players
+ #should be able to set this at runtime, but NTSC is a better
+ #default (I think)
+ sed -e 's/PAL/NTSC/g' \
+ -e "s/..shell.uname.-r./${KV}/" \
+ Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+
+}
+
+src_compile () {
+
+ make clean all || die
+
+}
+
+src_install () {
+
+ insinto "/usr/src/linux/include/linux"
+ doins ../include/linux/em8300.h
+
+ # The driver goes into the standard modules location
+ insinto "/lib/modules/${KV}/kernel/drivers/video"
+ doins em8300.o bt865.o adv717x.o
+
+ # Docs
+ dodoc README-modoptions \
+ README-modules.conf \
+ devfs_symlinks
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/modules.em8300 em8300
+
+}
+
+pkg_postinst () {
+
+ if [ "${ROOT}" = "/" ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "The em8300 kernel modules have been installed into the modules"
+ einfo "directory of your currently running kernel. They haven't been"
+ einfo "loaded. Please read the documentation, and if you would like"
+ einfo "to have the modules load at startup, add em8300, bt865, adv717x"
+ einfo "to your /etc/modules.autoload they may need module options to "
+ einfo "work correctly on your system. You will also need to add"
+ einfo "the contents of /usr/share/doc/${P}/devfs_symlinks.gz"
+ einfo "to your devfsd.conf so that the em8300 devices will be linked"
+ einfo "correctly."
+ einfo
+ einfo "You will also need to have the i2c kernel modules compiled for"
+ einfo "this to be happy, no need to patch any kernel though just turn"
+ einfo "all the i2c stuff in kernel config to M and you'll be fine."
+ einfo
+
+}
diff --git a/media-video/em8300-modules/files/digest-em8300-modules-0.13.0 b/media-video/em8300-modules/files/digest-em8300-modules-0.13.0
new file mode 100644
index 000000000000..16fb28e78d14
--- /dev/null
+++ b/media-video/em8300-modules/files/digest-em8300-modules-0.13.0
@@ -0,0 +1 @@
+MD5 306984dfd4f0f29538179cbbf391f5a8 em8300-0.13.0.tar.gz 383592