summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-05-21 20:21:40 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-05-21 20:21:40 +0000
commit5e4568a2f010778d339bfc073449dae5644c2809 (patch)
treeb872c7f98590c749e01067dbd1f7fb4a1b8535d4 /media-video/em84xx-modules/files
parentAdded patch to compile with >=media-gfx/exiv2-0.14. Fixes bug 178939. Fixed m... (diff)
downloadgentoo-2-5e4568a2f010778d339bfc073449dae5644c2809.tar.gz
gentoo-2-5e4568a2f010778d339bfc073449dae5644c2809.tar.bz2
gentoo-2-5e4568a2f010778d339bfc073449dae5644c2809.zip
Initial import of ebuild.
(Portage version: 2.1.2.7)
Diffstat (limited to 'media-video/em84xx-modules/files')
-rw-r--r--media-video/em84xx-modules/files/digest-em84xx-modules-0.2.13
-rw-r--r--media-video/em84xx-modules/files/em84xx-modules-0.2.1-kernel-2.6.19.diff75
2 files changed, 78 insertions, 0 deletions
diff --git a/media-video/em84xx-modules/files/digest-em84xx-modules-0.2.1 b/media-video/em84xx-modules/files/digest-em84xx-modules-0.2.1
new file mode 100644
index 000000000000..cd67ca19e81f
--- /dev/null
+++ b/media-video/em84xx-modules/files/digest-em84xx-modules-0.2.1
@@ -0,0 +1,3 @@
+MD5 dd7b11ea4121128bd0a7b8d27adea6e7 realmagic-0.2.1.tar.gz 8341
+RMD160 3a53bd86c79896e8c9979ed471328807cb579b0c realmagic-0.2.1.tar.gz 8341
+SHA256 235859c47841bc5a93343c29f4f282ca49be5c41e23fb568680f19b914af9cd4 realmagic-0.2.1.tar.gz 8341
diff --git a/media-video/em84xx-modules/files/em84xx-modules-0.2.1-kernel-2.6.19.diff b/media-video/em84xx-modules/files/em84xx-modules-0.2.1-kernel-2.6.19.diff
new file mode 100644
index 000000000000..e4f8bccd740c
--- /dev/null
+++ b/media-video/em84xx-modules/files/em84xx-modules-0.2.1-kernel-2.6.19.diff
@@ -0,0 +1,75 @@
+diff -ru realmagic-0.2.1/devfs.c realmagic-0.2.2/devfs.c
+--- realmagic-0.2.1/devfs.c 2006-02-24 00:58:38.000000000 +0100
++++ realmagic-0.2.2/devfs.c 2007-03-10 14:28:11.000000000 +0100
+@@ -22,13 +22,14 @@
+
+ /*****************************************************************************/
+
+-#include <linux/config.h>
+-#include <linux/devfs_fs_kernel.h>
+
+ #include "devfs.h"
+
+ #ifdef CONFIG_DEVFS_FS
+
++//#include <linux/config.h>
++#include <linux/devfs_fs_kernel.h>
++
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,5,70)
+ devfs_handle_t em84xx_handle[4];
+ #endif
+diff -ru realmagic-0.2.1/Makefile realmagic-0.2.2/Makefile
+--- realmagic-0.2.1/Makefile 2006-02-23 17:43:33.000000000 +0100
++++ realmagic-0.2.2/Makefile 2007-03-10 14:28:11.000000000 +0100
+@@ -10,9 +10,10 @@
+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+
+ install:
+- $(MAKE) -C $(KDIR) SUBDIRS=$(pwd) modules_install
++ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
+ endif
+
+
+ clean:
+- -rm *.o *.ko .*.cmd *.mod.c *~
++ -rm -f *.o *.ko .*.cmd *.mod.c *~
++ -rm -rf .tmp_versions
+Nur in realmagic-0.2.2/: Module.symvers.
+diff -ru realmagic-0.2.1/realmagicdev.c realmagic-0.2.2/realmagicdev.c
+--- realmagic-0.2.1/realmagicdev.c 2006-02-24 01:00:52.000000000 +0100
++++ realmagic-0.2.2/realmagicdev.c 2007-05-21 22:12:59.000000000 +0200
+@@ -29,6 +29,7 @@
+
+ #include <linux/init.h>
+ #include <linux/version.h>
++#include <linux/autoconf.h>
+ #include <linux/module.h>
+ #include <linux/moduleparam.h>
+ #include <linux/fs.h>
+@@ -161,7 +162,11 @@
+ #define writePIO(b,thisregister) writel((b),(em84xx_card.mem+((thisregister)<<2)))
+ #define readPIO(thisregister) readl(em84xx_card.mem+((thisregister)<<2))
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,19)
+ static irqreturn_t quasar_interrupt(int irq, void *dev_t, struct pt_regs * regs)
++#else
++static irqreturn_t quasar_interrupt(int irq, void *dev_t)
++#endif
+ {
+ static int otherirqcount = 0;
+ long keepme=0; // initialized because gcc makes pointless ``might be used uninitialized''
+@@ -183,10 +188,10 @@
+ em84xx_card.ring0_irqcount++;
+ em84xx_card.irqstilltobeserviced++;
+
+- // (playback) with 5000 this should log about every minute
+- if (em84xx_card.ring0_irqcount%5000 == 0)
+- printk("[ring0 received %ld interrupts so far (skipped %d for other devices sharing line)]\n",
+- em84xx_card.ring0_irqcount, otherirqcount);
++ // (playback) with 50000 this should log about every 20 minute
++// if (em84xx_card.ring0_irqcount%50000 == 0)
++// printk("[ring0 received %ld interrupts so far (skipped %d for other devices sharing line)]\n",
++// em84xx_card.ring0_irqcount, otherirqcount);
+
+ // FIXME: what sould make this part?
+ if (keepme & 0x1) {