summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-04-13 13:55:09 +0000
committerSamuli Suominen <drac@gentoo.org>2007-04-13 13:55:09 +0000
commite4c6e8a67c4bdc09d02d6ac8cbc3e33fb177408d (patch)
treebfc608e40eaa578719c6529b110bf31b4bc748f6 /media-video/ffmpegthumbnailer
parentFixed mis-detection of configure in certain locales (fixes bug#173274). (diff)
downloadgentoo-2-e4c6e8a67c4bdc09d02d6ac8cbc3e33fb177408d.tar.gz
gentoo-2-e4c6e8a67c4bdc09d02d6ac8cbc3e33fb177408d.tar.bz2
gentoo-2-e4c6e8a67c4bdc09d02d6ac8cbc3e33fb177408d.zip
Fix bug 173692.
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-video/ffmpegthumbnailer')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog10
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1-r1.ebuild29
-rw-r--r--media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1-r13
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1-inttypes.patch17
4 files changed, 58 insertions, 1 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 03b4be338ecc..88721b3a8176 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.6 2007/04/03 17:12:32 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.7 2007/04/13 13:55:09 drac Exp $
+
+*ffmpegthumbnailer-1.1-r1 (13 Apr 2007)
+
+ 13 Apr 2007; Samuli Suominen <drac@gentoo.org>
+ +files/ffmpegthumbnailer-1.1-inttypes.patch,
+ +ffmpegthumbnailer-1.1-r1.ebuild:
+ Fix compilation with new ffmpeg for bug 173692, thanks to ebfe
+ <knabberknusperhaus AT yahoo.de>
03 Apr 2007; Gustavo Zacarias <gustavoz@gentoo.org>
ffmpegthumbnailer-1.1.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1-r1.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1-r1.ebuild
new file mode 100644
index 000000000000..97bd974ca27b
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1-r1.ebuild,v 1.1 2007/04/13 13:55:09 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng
+ >=media-video/ffmpeg-0.4.9_p20070330"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-inttypes.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1-r1 b/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1-r1
new file mode 100644
index 000000000000..b3a505f69562
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1-r1
@@ -0,0 +1,3 @@
+MD5 20c6b80dbbcf7a2f73d8879dc9c94c93 ffmpegthumbnailer-1.1.tar.gz 79940
+RMD160 4ac4fd4dd19dd8d1e30d7157d08a216003d97f23 ffmpegthumbnailer-1.1.tar.gz 79940
+SHA256 6c9ab042d06ae183332117914521f4be323dd33aedf888efc4308d8b54679cf6 ffmpegthumbnailer-1.1.tar.gz 79940
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1-inttypes.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1-inttypes.patch
new file mode 100644
index 000000000000..ae3370e00146
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1-inttypes.patch
@@ -0,0 +1,17 @@
+diff -ur ffmpegthumbnailer-1.1.orig/src/moviedecoder.h ffmpegthumbnailer-1.1/src/moviedecoder.h
+--- ffmpegthumbnailer-1.1.orig/src/moviedecoder.h 2007-02-24 16:14:47.000000000 +0200
++++ ffmpegthumbnailer-1.1/src/moviedecoder.h 2007-04-13 16:48:13.000000000 +0300
+@@ -1,8 +1,11 @@
++#define __STDC_CONSTANT_MACROS
++#define INT64_C
++
++#include <inttypes.h>
++
+ #ifndef MOVIEDECODER_H
+ #define MOVIEDECODER_H
+
+-#define EMULATE_INTTYPES
+-
+ #include <string>
+ #include <vector>
+ #include <ffmpeg/avcodec.h>