summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-07-17 14:56:37 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-07-17 14:56:37 +0000
commit80b1724f32e0268d3904812380d79a9ec775e257 (patch)
tree77441dfec82a60ff241978b95cef626519009ec1 /media-video/istanbul
parentMarked stable on amd64 for bug #139612 (diff)
downloadgentoo-2-80b1724f32e0268d3904812380d79a9ec775e257.tar.gz
gentoo-2-80b1724f32e0268d3904812380d79a9ec775e257.tar.bz2
gentoo-2-80b1724f32e0268d3904812380d79a9ec775e257.zip
disable py compiling, use python eclass instead.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'media-video/istanbul')
-rw-r--r--media-video/istanbul/ChangeLog8
-rw-r--r--media-video/istanbul/files/digest-istanbul-0.2.0-r13
-rw-r--r--media-video/istanbul/istanbul-0.2.0-r1.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/media-video/istanbul/ChangeLog b/media-video/istanbul/ChangeLog
index ef2160a5d036..ae69e07423a2 100644
--- a/media-video/istanbul/ChangeLog
+++ b/media-video/istanbul/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/istanbul
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/ChangeLog,v 1.2 2006/07/15 11:17:40 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/ChangeLog,v 1.3 2006/07/17 14:56:37 allanonjl Exp $
+
+*istanbul-0.2.0-r1 (17 Jul 2006)
+
+ 17 Jul 2006; John N. Laliberte <allanonjl@gentoo.org>
+ +istanbul-0.2.0-r1.ebuild:
+ disable py compiling, use python eclass instead.
15 Jul 2006; <zaheerm@gentoo.org> istanbul-0.2.0.ebuild:
add description and iuse
diff --git a/media-video/istanbul/files/digest-istanbul-0.2.0-r1 b/media-video/istanbul/files/digest-istanbul-0.2.0-r1
new file mode 100644
index 000000000000..31f0701b4337
--- /dev/null
+++ b/media-video/istanbul/files/digest-istanbul-0.2.0-r1
@@ -0,0 +1,3 @@
+MD5 4dcf4caaad761962ec2fa9afb1014cf7 istanbul-0.2.0.tar.bz2 319887
+RMD160 cf9dcd1a921c44b641df3e86bfd6ed975880996d istanbul-0.2.0.tar.bz2 319887
+SHA256 eed28118b6581a9e77664e9079eb03f7be7f76b9a6e14e688243495473edd4c2 istanbul-0.2.0.tar.bz2 319887
diff --git a/media-video/istanbul/istanbul-0.2.0-r1.ebuild b/media-video/istanbul/istanbul-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..6d9466564786
--- /dev/null
+++ b/media-video/istanbul/istanbul-0.2.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.0-r1.ebuild,v 1.1 2006/07/17 14:56:37 allanonjl Exp $
+
+inherit eutils gnome2 python autotools
+
+KEYWORDS="~x86 ~amd64"
+
+HOMEPAGE="http://live.gnome.org/Istanbul"
+LICENSE="GPL-2"
+SLOT=0
+DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.8
+ dev-lang/python
+ >=dev-python/pygtk-2.6
+ >=dev-python/gnome-python-extras-2.11.3
+ gnome-base/gconf
+ >=dev-python/gst-python-0.10.0
+ media-plugins/gst-plugins-ogg
+ media-plugins/gst-plugins-theora
+ >=media-libs/libtheora-1.0_alpha6"
+
+DEPEND="${RDEPEND}"
+SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+ echo "py_compile = /bin/true" > common/python.mk
+
+ AT_M4DIR="common" eautoreconf
+}
+
+src_compile() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ econf
+ emake
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/istanbul
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}