summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-08-26 02:43:44 +0000
committerChris White <chriswhite@gentoo.org>2004-08-26 02:43:44 +0000
commit752df807b7ff08212e3107b0c1404290ecd7f9e5 (patch)
tree6030910efff31b0af0268419b9c12f252f34c23d /media-video/jahshaka
parenterr, left some debug code in (Manifest recommit) (diff)
downloadgentoo-2-752df807b7ff08212e3107b0c1404290ecd7f9e5.tar.gz
gentoo-2-752df807b7ff08212e3107b0c1404290ecd7f9e5.tar.bz2
gentoo-2-752df807b7ff08212e3107b0c1404290ecd7f9e5.zip
Initial import into the tree. This closes bug #33416.
Diffstat (limited to 'media-video/jahshaka')
-rw-r--r--media-video/jahshaka/ChangeLog11
-rw-r--r--media-video/jahshaka/Manifest4
-rw-r--r--media-video/jahshaka/files/FT_Open_Flags.patch12
-rw-r--r--media-video/jahshaka/files/digest-jahshaka-1.9_alpha51
-rw-r--r--media-video/jahshaka/files/ftgl.h.patch24
-rw-r--r--media-video/jahshaka/jahshaka-1.9_alpha5.ebuild75
-rw-r--r--media-video/jahshaka/metadata.xml8
7 files changed, 135 insertions, 0 deletions
diff --git a/media-video/jahshaka/ChangeLog b/media-video/jahshaka/ChangeLog
new file mode 100644
index 000000000000..2319a19128d9
--- /dev/null
+++ b/media-video/jahshaka/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-video/jahshaka
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/jahshaka/ChangeLog,v 1.1 2004/08/26 02:43:44 chriswhite Exp $
+
+*jahshaka-1.9_alpha5 (26 Aug 2004)
+
+ 26 Aug 2004; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +files/FT_Open_Flags.patch, +files/ftgl.h.patch,
+ +jahshaka-1.9_alpha5.ebuild:
+ Initial submit to the repository.
+
diff --git a/media-video/jahshaka/Manifest b/media-video/jahshaka/Manifest
new file mode 100644
index 000000000000..6ef3f6a8f632
--- /dev/null
+++ b/media-video/jahshaka/Manifest
@@ -0,0 +1,4 @@
+MD5 84b3b99babf32c2cb9dcc1768fe641ae jahshaka-1.9_alpha5.ebuild 1856
+MD5 313d2b2cfddddf54563e829bb1ffc688 files/digest-jahshaka-1.9_alpha5 67
+MD5 eccbf141ba80b57f8127d38e4fcda2ec files/FT_Open_Flags.patch 489
+MD5 c3cb7840c08ef0ced53f6b8d58442449 files/ftgl.h.patch 793
diff --git a/media-video/jahshaka/files/FT_Open_Flags.patch b/media-video/jahshaka/files/FT_Open_Flags.patch
new file mode 100644
index 000000000000..5ef25c60128a
--- /dev/null
+++ b/media-video/jahshaka/files/FT_Open_Flags.patch
@@ -0,0 +1,12 @@
+diff -Naur jahshaka/jah/objectlibs/FTGL/FTFace.cpp jahshaka.new/jah/objectlibs/FTGL/FTFace.cpp
+--- jahshaka/jah/objectlibs/FTGL/FTFace.cpp 2003-09-21 08:09:55.000000000 +0200
++++ jahshaka.new/jah/objectlibs/FTGL/FTFace.cpp 2004-06-26 08:59:58.229953432 +0200
+@@ -62,7 +62,7 @@
+ {
+ FT_Open_Args open;
+
+- open.flags = (FT_Open_Flags)1; // FT_OPEN_MEMORY;
++ open.flags = FT_OPEN_MEMORY;
+ open.memory_base = (FT_Byte *)pBufferBytes;
+ open.memory_size = bufferSizeInBytes;
+
diff --git a/media-video/jahshaka/files/digest-jahshaka-1.9_alpha5 b/media-video/jahshaka/files/digest-jahshaka-1.9_alpha5
new file mode 100644
index 000000000000..61ac1383a00c
--- /dev/null
+++ b/media-video/jahshaka/files/digest-jahshaka-1.9_alpha5
@@ -0,0 +1 @@
+MD5 3e45e077616ca5032104f008f883d9b0 jahshaka_1.9a5.tar.gz 4535953
diff --git a/media-video/jahshaka/files/ftgl.h.patch b/media-video/jahshaka/files/ftgl.h.patch
new file mode 100644
index 000000000000..540fa8b5fde0
--- /dev/null
+++ b/media-video/jahshaka/files/ftgl.h.patch
@@ -0,0 +1,24 @@
+*** jah/objectlibs/FTGL/FTGL.h Sun Sep 21 08:13:01 2003
+--- jah/objectlibs/FTGL/FTGL.h.new Fri Jan 9 10:17:29 2004
+***************
+*** 75,82 ****
+ #define GL_TEXTURE_PRIORITY_EXT 0x8066
+ #define GL_TEXTURE_RESIDENT_EXT 0x8067
+ #define GL_TEXTURE_1D_BINDING_EXT 0x8068
+- #define GL_TEXTURE_2D_BINDING_EXT 0x8069
+ #define GL_TEXTURE_3D_BINDING_EXT 0x806A
+ #endif
+
+ #endif // __FTGL__
+--- 75,83 ----
+ #define GL_TEXTURE_PRIORITY_EXT 0x8066
+ #define GL_TEXTURE_RESIDENT_EXT 0x8067
+ #define GL_TEXTURE_1D_BINDING_EXT 0x8068
+ #define GL_TEXTURE_3D_BINDING_EXT 0x806A
+ #endif
+
++ #define GL_TEXTURE_2D_BINDING_EXT 0x8069
++
+ #endif // __FTGL__
+
+
diff --git a/media-video/jahshaka/jahshaka-1.9_alpha5.ebuild b/media-video/jahshaka/jahshaka-1.9_alpha5.ebuild
new file mode 100644
index 000000000000..1d432f306302
--- /dev/null
+++ b/media-video/jahshaka/jahshaka-1.9_alpha5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/jahshaka/jahshaka-1.9_alpha5.ebuild,v 1.1 2004/08/26 02:43:44 chriswhite Exp $
+
+inherit eutils
+
+MY_P="${P/'-1.9_alpha'/_1.9a}"
+DESCRIPTION="The worlds first OpenSource Realtime Editing and Effects System."
+HOMEPAGE="http://www.jahshaka.com"
+SRC_URI="mirror://sourceforge/${PN}fx/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="virtual/x11
+ >=media-libs/glut-3.7.1
+ >=media-libs/freetype-2.1.4
+ >=x11-libs/qt-3"
+
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/${PN}"
+JAH_SRC=${S}/jah
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ftgl.h.patch || die
+ epatch ${FILESDIR}/FT_Open_Flags.patch || die
+}
+
+cflags_replacement() {
+ sed -e "s:^CFLAGS.*:CFLAGS = ${CFLAGS} -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT:" -i $*
+ sed -e "s:^CXXFLAGS.*:CXXFLAGS = ${CXXFLAGS} -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT:" -i $*
+}
+
+src_compile() {
+ ./configure || die "configure failed"
+
+ make qmake_all || die "could not create the temaplate makefiles"
+
+ local sources="Source Core/Objects Core/Render Core/World libraries desktop network player sqlite objectlibs/FTGL objectlibs/glmlib objectlibs/l3ds objectlibs/particle Modules/animate Modules/color Modules/edit Modules/effect Modules/painter Modules/text encoders/mpeg_encode encoders/mpeg_play"
+
+ for Makefiles in $sources
+ do
+ cflags_replacement ${JAH_SRC}/${Makefiles}/Makefile
+ done
+
+ make || die
+}
+
+src_install() {
+
+ # They do no harm but we don't like 'CVS' dirs in every subdir
+ for i in $(ls -la -R * | grep CVS | grep / | cut -f1 -d:)
+ do
+ rm -rf ${i}
+ done
+
+ local dirs="Pixmaps database fonts media scenes"
+ dodir /opt/${PN}
+ for i in $dirs ; do
+ cp -a $i ${D}/opt/${PN}/
+ done
+
+ cp -a jahshaka ${D}/opt/${PN}/
+
+ ln -s ${D}/opt/${PN}/jahshaka ${D}/usr/bin/jahshaka
+
+ dodoc README AUTHORS TODO
+}
+
diff --git a/media-video/jahshaka/metadata.xml b/media-video/jahshaka/metadata.xml
new file mode 100644
index 000000000000..6fb162be6d97
--- /dev/null
+++ b/media-video/jahshaka/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-video</herd>
+<maintainer>
+ <email>chriswhite@gentoo.org</email>
+</maintainer>
+</pkgmetadata>