summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-02-13 20:40:04 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-02-13 20:40:04 +0000
commitc70e9231cacf8e22fca673e5b45099b26f6b19f8 (patch)
treead086f2188fcfc73ba347fc0c8b03c44f842f7f4 /media-video/mplayer
parentgames-rpg/eternal-lands-data music flag downloads optional 30 megs worth of m... (diff)
downloadgentoo-2-c70e9231cacf8e22fca673e5b45099b26f6b19f8.tar.gz
gentoo-2-c70e9231cacf8e22fca673e5b45099b26f6b19f8.tar.bz2
gentoo-2-c70e9231cacf8e22fca673e5b45099b26f6b19f8.zip
Add musepack USE flag to support the musepack audio codec (bug #122081).
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-video/mplayer')
-rw-r--r--media-video/mplayer/ChangeLog6
-rw-r--r--media-video/mplayer/mplayer-1.0.20060102.ebuild6
2 files changed, 9 insertions, 3 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 1b0a4d247ca7..c706b54ed53d 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mplayer
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.339 2006/02/03 10:45:10 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.340 2006/02/13 20:40:03 chutzpah Exp $
+
+ 13 Feb 2006; Patrick McLean <chutzpah@gentoo.org>
+ mplayer-1.0.20060102.ebuild:
+ Add "musepack" USE flag to support the musepack audio codec (bug #122081).
03 Feb 2006; Luca Barbato <lu_zero@gentoo.org>
mplayer-1.0.20060102.ebuild:
diff --git a/media-video/mplayer/mplayer-1.0.20060102.ebuild b/media-video/mplayer/mplayer-1.0.20060102.ebuild
index 51f979dde20c..90f2148005a9 100644
--- a/media-video/mplayer/mplayer-1.0.20060102.ebuild
+++ b/media-video/mplayer/mplayer-1.0.20060102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0.20060102.ebuild,v 1.5 2006/02/03 10:45:10 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0.20060102.ebuild,v 1.6 2006/02/13 20:40:04 chutzpah Exp $
inherit eutils flag-o-matic
@@ -8,7 +8,7 @@ RESTRICT="nostrip"
IUSE="3dfx 3dnow 3dnowext aac aalib alsa altivec arts bidi bl bindist
cpudetection custom-cflags debug dga doc dts dvb cdparanoia directfb dvd dv
dvdread edl encode esd fbcon gif ggi gtk i8x0 ipv6 jack joystick jpeg libcaca
-lirc live livecd lzo mad matroska matrox mmx mmxext nas nls nvidia
+lirc live livecd lzo mad matroska matrox mmx mmxext musepack nas nls nvidia
vorbis opengl oss png real rtc samba sdl sse sse2 svga tga theora truetype
v4l v4l2 win32codecs X xanim xinerama xmms xv xvid xvmc"
@@ -64,6 +64,7 @@ RDEPEND="xvid? ( >=media-libs/xvid-0.9.0 )
lirc? ( app-misc/lirc )
lzo? ( =dev-libs/lzo-1* )
mad? ( media-libs/libmad )
+ musepack? ( >=media-libs/libmpcdec-1.2.2 )
nas? ( media-libs/nas )
nls? ( sys-devel/gettext )
vorbis? ( media-libs/libvorbis )
@@ -298,6 +299,7 @@ src_compile() {
myconf="${myconf} $(use_enable dts libdts)"
myconf="${myconf} $(use_enable lzo liblzo)"
myconf="${myconf} $(use_enable matroska internal-matroska)"
+ myconf="${myconf} $(use_enable musepack)"
myconf="${myconf} $(use_enable aac internal-faad)"
myconf="${myconf} $(use_enable vorbis)"
myconf="${myconf} $(use_enable theora)"