summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-08-30 01:32:11 +0000
committerSteve Dibb <beandog@gentoo.org>2007-08-30 01:32:11 +0000
commit37932c8f216f0889c2d5127a7720030946ff3145 (patch)
treeff481a6ed4eaef2034f40e5b7bd5f84915ab606e /media-video/ogmrip/files
parentAdd ~x86-fbsd keyword (diff)
downloadgentoo-2-37932c8f216f0889c2d5127a7720030946ff3145.tar.gz
gentoo-2-37932c8f216f0889c2d5127a7720030946ff3145.tar.bz2
gentoo-2-37932c8f216f0889c2d5127a7720030946ff3145.zip
MPlayer + dts patch, thanks to upstream, bug 190675
(Portage version: 2.1.2.12)
Diffstat (limited to 'media-video/ogmrip/files')
-rw-r--r--media-video/ogmrip/files/ogmrip-0.10.3-mplayer-dts.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-video/ogmrip/files/ogmrip-0.10.3-mplayer-dts.patch b/media-video/ogmrip/files/ogmrip-0.10.3-mplayer-dts.patch
new file mode 100644
index 000000000000..361994013a1c
--- /dev/null
+++ b/media-video/ogmrip/files/ogmrip-0.10.3-mplayer-dts.patch
@@ -0,0 +1,59 @@
+--- configure.in.orig 2007-08-27 20:04:18.000000000 +0200
++++ configure.in 2007-08-27 20:10:52.000000000 +0200
+@@ -189,26 +189,33 @@
+ AC_MSG_ERROR(Unable to find mplayer in the PATH. You need mplayer to use OGMRip. Find it on http://www.mplayerhq.hu)
+ fi
+
+-if $MPLAYER_PROG 2> /dev/null | grep -q "MPlayer dev-\(CVS\|SVN\)"; then
+- have_mplayer_dev=yes
+- MPLAYER_MAJOR_VERSION=99
+- MPLAYER_MINOR_VERSION=99
+- MPLAYER_PRE_VERSION=99
+- MPLAYER_RC_VERSION=99
+- AC_MSG_WARN(Mplayer SVN/CVS detected - USE AT YOUR OWN RISK)
+-else
++MPLAYER_VERSION=`$MPLAYER_PROG 2> /dev/null | grep "^MPlayer"`
++
++if echo $MPLAYER_VERSION | grep -q "MPlayer [[0-1]]\.[[0-9]]\+\(\(rc\|pre\)[[0-9]]\+\)\?"; then
+ have_mplayer_dev=no
+- MPLAYER_MAJOR_VERSION=`$MPLAYER_PROG 2> /dev/null | grep "^MPlayer" | $SED_PROG -e 's%^MPlayer \([[0-1]]\).*%\1%'`
+- MPLAYER_MINOR_VERSION=`$MPLAYER_PROG 2> /dev/null | grep "^MPlayer" | $SED_PROG -e 's%^MPlayer [[0-1]]\.\([[0-9]]\).*%\1%'`
++ MPLAYER_MAJOR_VERSION=`echo $MPLAYER_VERSION | grep "^MPlayer" | $SED_PROG -e 's%^MPlayer \([[0-1]]\).*%\1%'`
++ MPLAYER_MINOR_VERSION=`echo $MPLAYER_VERSION | grep "^MPlayer" | $SED_PROG -e 's%^MPlayer [[0-1]]\.\([[0-9]]\).*%\1%'`
+ MPLAYER_PRE_VERSION=0
+ MPLAYER_RC_VERSION=0
+
+- if $MPLAYER_PROG 2> /dev/null | grep -q "^MPlayer [[0-1]]\.[[0-9]]\+pre[[0-9]]\+.*"; then
+- MPLAYER_PRE_VERSION=`$MPLAYER_PROG 2> /dev/null | grep "^MPlayer" | $SED_PROG -e 's%^MPlayer [[0-1]]\.[[0-9]]\+pre\([[0-9]]\+\).*%\1%'`
++ if echo $MPLAYER_VERSION | grep -q "^MPlayer [[0-1]]\.[[0-9]]\+pre[[0-9]]\+.*"; then
++ MPLAYER_PRE_VERSION=`echo $MPLAYER_VERSION | grep "^MPlayer" | $SED_PROG -e 's%^MPlayer [[0-1]]\.[[0-9]]\+pre\([[0-9]]\+\).*%\1%'`
+ fi
+
+- if $MPLAYER_PROG 2> /dev/null | grep -q "^MPlayer [[0-1]]\.[[0-9]]\+rc[[0-9]]\+.*"; then
+- MPLAYER_RC_VERSION=`$MPLAYER_PROG 2> /dev/null | grep "^MPlayer" | $SED_PROG -e 's%^MPlayer [[0-1]]\.[[0-9]]\+rc\([[0-9]]\+\).*%\1%'`
++ if echo $MPLAYER_VERSION | grep -q "^MPlayer [[0-1]]\.[[0-9]]\+rc[[0-9]]\+.*"; then
++ MPLAYER_RC_VERSION=`echo $MPLAYER_VERSION | grep "^MPlayer" | $SED_PROG -e 's%^MPlayer [[0-1]]\.[[0-9]]\+rc\([[0-9]]\+\).*%\1%'`
++ fi
++else
++ if echo $MPLAYER_VERSION | grep -q "dev-\(CVS\|SVN\)" || \
++ echo $MPLAYER_VERSION | grep -q "SVN-"; then
++ have_mplayer_dev=yes
++ MPLAYER_MAJOR_VERSION=99
++ MPLAYER_MINOR_VERSION=99
++ MPLAYER_PRE_VERSION=99
++ MPLAYER_RC_VERSION=99
++ AC_MSG_WARN(Mplayer SVN/CVS detected - USE AT YOUR OWN RISK)
++ else
++ AC_MSG_ERROR(Unable to determine the version number of mplayer or the version number you specified with --with-version-number is invalid.)
+ fi
+ fi
+
+@@ -315,7 +322,7 @@
+ dnl **************************************************************
+
+ AC_MSG_CHECKING([for DTS support])
+-if $MPLAYER_PROG -ac help 2> /dev/null | grep -q "^ffdts.*working.*$"; then
++if $MPLAYER_PROG -ac help 2> /dev/null | grep -q "^\(ffdts\|ffdca\|dts\).*working.*$"; then
+ have_dts_support=yes
+ else
+ have_dts_support=no