summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 11:27:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 11:27:08 +0000
commit3d6a7921038863ed13f8ef3a77f24473d23281e1 (patch)
tree3e644e7be716240f65906ddf73d5627d74d468e2 /media-video/parole
parentstable amd64, bug 353642 (diff)
downloadgentoo-2-3d6a7921038863ed13f8ef3a77f24473d23281e1.tar.gz
gentoo-2-3d6a7921038863ed13f8ef3a77f24473d23281e1.tar.bz2
gentoo-2-3d6a7921038863ed13f8ef3a77f24473d23281e1.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'media-video/parole')
-rw-r--r--media-video/parole/ChangeLog8
-rw-r--r--media-video/parole/files/parole-0.2.0.2-libnotify-0.7.patch25
-rw-r--r--media-video/parole/parole-0.2.0.2-r1.ebuild9
3 files changed, 38 insertions, 4 deletions
diff --git a/media-video/parole/ChangeLog b/media-video/parole/ChangeLog
index 50fe96af0890..1373fb890f2b 100644
--- a/media-video/parole/ChangeLog
+++ b/media-video/parole/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/parole
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.14 2010/11/05 17:19:16 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.15 2011/02/05 11:27:08 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> parole-0.2.0.2-r1.ebuild,
+ +files/parole-0.2.0.2-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
05 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
parole-0.2.0.2-r1.ebuild:
diff --git a/media-video/parole/files/parole-0.2.0.2-libnotify-0.7.patch b/media-video/parole/files/parole-0.2.0.2-libnotify-0.7.patch
new file mode 100644
index 000000000000..a6fbecafb066
--- /dev/null
+++ b/media-video/parole/files/parole-0.2.0.2-libnotify-0.7.patch
@@ -0,0 +1,25 @@
+--- plugins/tray/tray-provider.c
++++ plugins/tray/tray-provider.c
+@@ -29,6 +29,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #include <libxfcegui4/libxfcegui4.h>
+@@ -260,8 +263,11 @@
+ }
+
+ message = g_strdup_printf ("%s %s %s %s", _("<b>Playing:</b>"), title, _("<b>Duration:</b>"), timestring);
+-
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ tray->n = notify_notification_new (title, message, NULL);
++#else
+ tray->n = notify_notification_new (title, message, NULL, NULL);
++#endif
+ g_free (title);
+ g_free (message);
+
diff --git a/media-video/parole/parole-0.2.0.2-r1.ebuild b/media-video/parole/parole-0.2.0.2-r1.ebuild
index 5d54b34933d5..ba5e2f7c5973 100644
--- a/media-video/parole/parole-0.2.0.2-r1.ebuild
+++ b/media-video/parole/parole-0.2.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/parole/parole-0.2.0.2-r1.ebuild,v 1.4 2011/02/04 18:06:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/parole-0.2.0.2-r1.ebuild,v 1.5 2011/02/05 11:27:08 ssuominen Exp $
EAPI=3
inherit multilib nsplugins xfconf
@@ -32,7 +32,11 @@ DEPEND="${RDEPEND}
pkg_setup() {
export BROWSER_PLUGIN_DIR="/usr/$(get_libdir)/${PLUGINS_DIR}" #333517
- PATCHES=( "${FILESDIR}"/${P}-64bit.patch )
+ PATCHES=(
+ "${FILESDIR}"/${P}-64bit.patch
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
+ )
+
XFCONF=(
--disable-dependency-tracking
$(use_enable libnotify)
@@ -40,5 +44,6 @@ pkg_setup() {
$(use_enable nsplugin browser-plugin)
$(xfconf_use_debug)
)
+
DOCS="AUTHORS ChangeLog README THANKS TODO"
}