summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-03-20 12:41:32 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-03-20 12:41:32 +0000
commit1af77bcc97edb3619f023e70ad81e254b3701380 (patch)
treea5b0d9e091dc4ffe3af7f0378b374ec813726304 /media-video/pitivi
parentmedia-libs/freeverb3: Bump to 2.5.0 (diff)
downloadgentoo-2-1af77bcc97edb3619f023e70ad81e254b3701380.tar.gz
gentoo-2-1af77bcc97edb3619f023e70ad81e254b3701380.tar.bz2
gentoo-2-1af77bcc97edb3619f023e70ad81e254b3701380.zip
Bump to 0.13.4, enable tests
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'media-video/pitivi')
-rw-r--r--media-video/pitivi/ChangeLog9
-rw-r--r--media-video/pitivi/pitivi-0.13.4.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/media-video/pitivi/ChangeLog b/media-video/pitivi/ChangeLog
index 16362be267c2..00edef434fbd 100644
--- a/media-video/pitivi/ChangeLog
+++ b/media-video/pitivi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/pitivi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/ChangeLog,v 1.20 2009/10/04 20:04:39 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/ChangeLog,v 1.21 2010/03/20 12:41:32 nirbheek Exp $
+
+*pitivi-0.13.4 (20 Mar 2010)
+
+ 20 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +pitivi-0.13.4.ebuild:
+ Bump to 0.13.4, enable tests
04 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pitivi-0.11.3.ebuild, pitivi-0.13.1.ebuild, pitivi-0.13.3.ebuild:
diff --git a/media-video/pitivi/pitivi-0.13.4.ebuild b/media-video/pitivi/pitivi-0.13.4.ebuild
new file mode 100644
index 000000000000..8419ee5f2f11
--- /dev/null
+++ b/media-video/pitivi/pitivi-0.13.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.13.4.ebuild,v 1.1 2010/03/20 12:41:32 nirbheek Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 python eutils virtualx
+
+DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
+HOMEPAGE="http://www.pitivi.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.5
+ >=dev-python/pygtk-2.14.0
+ dev-python/dbus-python
+ >=dev-python/gconf-python-2.12
+ dev-python/pycairo
+ dev-python/pygoocanvas
+ net-zope/zope-interface
+ gnome-base/librsvg
+
+ >=media-libs/gstreamer-0.10.28
+ >=dev-python/gst-python-0.10.16
+ >=media-libs/gnonlin-0.10.15
+ >=media-libs/gst-plugins-base-0.10.0
+ >=media-libs/gst-plugins-good-0.10.0
+ >=media-plugins/gst-plugins-ffmpeg-0.10.0
+ >=media-plugins/gst-plugins-xvideo-0.10.0
+ >=media-plugins/gst-plugins-libpng-0.10.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ >=dev-util/intltool-0.35.5"
+
+DOCS="AUTHORS ChangeLog NEWS RELEASE"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_configure() {
+ addpredict $(unset HOME; echo ~)/.gconf
+ addpredict $(unset HOME; echo ~)/.gconfd
+ addpredict $(unset HOME; echo ~)/.gstreamer-0.10
+
+ gnome2_src_configure
+}
+
+src_test() {
+ export XDG_CONFIG_HOME="${WORKDIR}/.config"
+ export XDG_DATA_HOME="${WORKDIR}/.local"
+ # Force Xvfb to be used
+ unset DISPLAY
+ # pitivi/configure.py checks this in get_pixmap_dir()
+ mkdir "${S}/.git"
+ Xemake check || die "tests failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize "/usr/$(get_libdir)/${PN}/python/${PN}"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "/usr/$(get_libdir)/${PN}/python/${PN}"
+}