summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-19 12:36:50 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-19 12:36:50 +0000
commit60942f86e9cb1151d98a390ddbf9c672553f39b2 (patch)
tree9b4c3de26b7ffd1ea07527f0c2ef670a0e88b71c /media-video/realplayer/realplayer-8-r6.ebuild
parentunmask (diff)
downloadgentoo-2-60942f86e9cb1151d98a390ddbf9c672553f39b2.tar.gz
gentoo-2-60942f86e9cb1151d98a390ddbf9c672553f39b2.tar.bz2
gentoo-2-60942f86e9cb1151d98a390ddbf9c672553f39b2.zip
fixed "double" ebuild
Diffstat (limited to 'media-video/realplayer/realplayer-8-r6.ebuild')
-rw-r--r--media-video/realplayer/realplayer-8-r6.ebuild78
1 files changed, 1 insertions, 77 deletions
diff --git a/media-video/realplayer/realplayer-8-r6.ebuild b/media-video/realplayer/realplayer-8-r6.ebuild
index e9156cc969dc..9f6c5ef2e08f 100644
--- a/media-video/realplayer/realplayer-8-r6.ebuild
+++ b/media-video/realplayer/realplayer-8-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/realplayer/realplayer-8-r6.ebuild,v 1.1 2003/07/19 12:32:04 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/realplayer/realplayer-8-r6.ebuild,v 1.2 2003/07/19 12:36:42 lanius Exp $
inherit nsplugins
@@ -139,79 +139,3 @@ pkg_postinst() {
einfo "You have to agree to the terms in ${BASE}/LICENSE or unmerge"
echo
}
-src_unpack() {
- if use x86 ; then
- BYTECOUNT=4799691
- RP8_BIN=`echo ${A} | awk '{ print $1 }'`
- RV9_X86=`echo ${A} | awk '{ print $2 }'`
- else
- RP8_BIN=${A}
- if use ppc ; then BYTECOUNT=7260910
- elif use alpha ; then BYTECOUNT=7130860
- elif use sparc ; then BYTECOUNT=6375000
- fi
- fi
- tail -c ${BYTECOUNT} ${DISTDIR}/${RP8_BIN} | tar xz 2> /dev/null
- if use x86 ; then
- unpack ${RV9_X86}
- fi
-}
-
-src_compile() {
- einfo "Nothing to Compile, this is a binary package"
-}
-
-src_install () {
- insinto ${BASE}/Codecs
- doins Codecs/*
- if [ -d rv9/codecs ] ; then
- doins rv9/codecs/drv4.so.6.0 rv9/codecs/rv40.so.6.0
- fi
- insinto ${BASE}/Common
- doins Common/*
- insinto ${BASE}/Plugins/ExtResources
- doins Plugins/ExtResources/*
- insinto ${BASE}/Plugins
- doins Plugins/*.so.6.0
- insinto ${BASE}
- doins *.xpm *.png *.rm rpnp.so LICENSE README ${FILESDIR}/mimeinfo
- exeinto ${BASE}
- doexe realplay
- dodir /opt/bin
- dosym ${BASE}/realplay /opt/bin
-
- # NS plugin
- for b in /opt/netscape /usr/lib/mozilla /usr/lib/nsbrowser
- do
- if [ -d ${b} ] ; then
- dodir ${b}/plugins
- dosym ${BASE}/rpnp.so ${b}/plugins
- fi
- done
-
- # Desktop menu entry ; KDE, Gnome
- if use kde ; then
- insinto ${KDEDIR}/share/applnk/Multimedia
- doins ${FILESDIR}/realplayer.desktop
- fi
- if use gnome ; then
- insinto /usr/share/applications
- doins ${FILESDIR}/realplayer.desktop
- fi
-
- cp rp7.xpm realplayer8.xpm
- insinto /usr/share/pixmaps
- doins realplayer8.xpm
-
- # Mimetypes - Intentionally left blank (for now)
- # Better not use the provided scripts from Real, they are outdated
- # See ${BASE}/mimeinfo for the correct mimetypes if you need them
-}
-
-pkg_postinst() {
- echo
- einfo "Finished installing RealPlayer8 into ${BASE}"
- einfo "You can start the player by running 'realplay'"
- einfo "You have to agree to the terms in ${BASE}/LICENSE or unmerge"
- echo
-}