summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-03 20:19:12 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-03 20:19:12 +0000
commit6cf463efa743300eb365c9b112f446bc1d4cf2d1 (patch)
treec4a9920cfa04eacdc1ae30a246dce4048bddfeef /media-video/subtitleeditor
parentStable for ppc, wrt bug #475480 (diff)
downloadgentoo-2-6cf463efa743300eb365c9b112f446bc1d4cf2d1.tar.gz
gentoo-2-6cf463efa743300eb365c9b112f446bc1d4cf2d1.tar.bz2
gentoo-2-6cf463efa743300eb365c9b112f446bc1d4cf2d1.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-video/subtitleeditor')
-rw-r--r--media-video/subtitleeditor/ChangeLog7
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.41.0.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index 57ed3657faed..be0a03ffaab0 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/subtitleeditor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.21 2013/03/29 23:22:52 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.22 2013/10/03 20:19:12 pacho Exp $
+
+*subtitleeditor-0.41.0 (03 Oct 2013)
+
+ 03 Oct 2013; Pacho Ramos <pacho@gentoo.org> +subtitleeditor-0.41.0.ebuild:
+ Version bump
29 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
-subtitleeditor-0.37.1.ebuild:
diff --git a/media-video/subtitleeditor/subtitleeditor-0.41.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.41.0.ebuild
new file mode 100644
index 000000000000..3b5bc278ad14
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.41.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.41.0.ebuild,v 1.1 2013/10/03 20:19:12 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator flag-o-matic
+
+DESCRIPTION="GTK+2 subtitle editing tool"
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls opengl"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-cpp/gtkmm-2.14:2.4
+ >=dev-cpp/glibmm-2.16.3:2
+ >=dev-cpp/libxmlpp-2.20:2.6
+ >=app-text/enchant-1.4
+ >=dev-cpp/gstreamermm-0.10.6
+ >=media-libs/gst-plugins-good-0.10:0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-pango-0.10:0.10
+ >=media-plugins/gst-plugins-xvideo-0.10:0.10
+ opengl? ( >=dev-cpp/gtkglextmm-1.2 )
+"
+# gst-plugins-pango needed for text overlay
+# gst-plugins-xvideo needed for video output
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_configure() {
+ export GST_REGISTRY="${T}/home/registry.cache.xml"
+
+ # Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
+ use debug && append-flags -DDEBUG
+
+ gnome2_src_configure \
+ --disable-debug \
+ $(use_enable nls) \
+ $(use_enable opengl gl)
+}