summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-11-08 19:06:53 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-11-08 19:06:53 +0000
commit0e6c05d697072049e4228e127e40e5be235196b3 (patch)
tree5ff0840dfb125c827dca7d2710f50c1a041b448b /media-video/ushare
parentNew package, a JSON schema validator for Python (diff)
downloadgentoo-2-0e6c05d697072049e4228e127e40e5be235196b3.tar.gz
gentoo-2-0e6c05d697072049e4228e127e40e5be235196b3.tar.bz2
gentoo-2-0e6c05d697072049e4228e127e40e5be235196b3.zip
Revbump to disable parsing of the default configuration file. /etc/conf.d/ushare should work for Gentoo users
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'media-video/ushare')
-rw-r--r--media-video/ushare/ChangeLog9
-rw-r--r--media-video/ushare/files/06_all_ushare_disable_sysconf.patch20
-rw-r--r--media-video/ushare/ushare-1.1a-r5.ebuild51
3 files changed, 79 insertions, 1 deletions
diff --git a/media-video/ushare/ChangeLog b/media-video/ushare/ChangeLog
index 56e606c3094b..a77585d5146b 100644
--- a/media-video/ushare/ChangeLog
+++ b/media-video/ushare/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/ushare
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ushare/ChangeLog,v 1.18 2012/09/16 14:31:46 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ushare/ChangeLog,v 1.19 2012/11/08 19:06:53 hwoarang Exp $
+
+*ushare-1.1a-r5 (08 Nov 2012)
+
+ 08 Nov 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/06_all_ushare_disable_sysconf.patch, +ushare-1.1a-r5.ebuild:
+ Revbump to disable parsing of the default configuration file.
+ /etc/conf.d/ushare should work for Gentoo users
16 Sep 2012; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Remove non-existing maintainer. Take over maintainership
diff --git a/media-video/ushare/files/06_all_ushare_disable_sysconf.patch b/media-video/ushare/files/06_all_ushare_disable_sysconf.patch
new file mode 100644
index 000000000000..c3adf8e54287
--- /dev/null
+++ b/media-video/ushare/files/06_all_ushare_disable_sysconf.patch
@@ -0,0 +1,20 @@
+Do not try to parse the default configuration file as everyting
+should be handled by the /etc/conf.d/ushare file in Gentoo
+Index: ushare-1.1a/src/ushare.c
+===================================================================
+--- ushare-1.1a.orig/src/ushare.c
++++ ushare-1.1a/src/ushare.c
+@@ -813,13 +813,6 @@ main (int argc, char **argv)
+ return EXIT_SUCCESS;
+ }
+
+- if (parse_config_file (ut) < 0)
+- {
+- /* fprintf here, because syslog not yet ready */
+- fprintf (stderr, _("Warning: can't parse file \"%s\".\n"),
+- ut->cfg_file ? ut->cfg_file : SYSCONFDIR "/" USHARE_CONFIG_FILE);
+- }
+-
+ if (ut->xbox360)
+ {
+ char *name;
diff --git a/media-video/ushare/ushare-1.1a-r5.ebuild b/media-video/ushare/ushare-1.1a-r5.ebuild
new file mode 100644
index 000000000000..09d6abc6e0b9
--- /dev/null
+++ b/media-video/ushare/ushare-1.1a-r5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ushare/ushare-1.1a-r5.ebuild,v 1.1 2012/11/08 19:06:53 hwoarang Exp $
+
+EAPI=4
+inherit eutils multilib user
+
+DESCRIPTION="uShare is a UPnP (TM) A/V & DLNA Media Server"
+HOMEPAGE="http://ushare.geexbox.org/"
+SRC_URI="http://ushare.geexbox.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dlna nls"
+
+RDEPEND=">=net-libs/libupnp-1.6.14
+ dlna? ( >=media-libs/libdlna-0.2.4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ EPATCH_SOURCE="${FILESDIR}" EPATCH_SUFFIX="patch" \
+ EPATCH_OPTS="-p1" epatch
+}
+
+src_configure() {
+ local myconf
+ myconf="--prefix=/usr --disable-sysconf --disable-strip $(use_enable dlna)"
+ # nls can only be disabled, on by default.
+ use nls || myconf="${myconf} --disable-nls"
+
+ # I can't use econf
+ # --host is not implemented in ./configure file
+ ./configure ${myconf} || die "./configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman src/ushare.1
+ newconfd "${FILESDIR}"/ushare.conf.d ushare
+ newinitd "${FILESDIR}"/ushare.init.d ushare
+ dodoc NEWS README TODO THANKS AUTHORS
+}
+
+pkg_postinst() {
+ enewuser ushare
+ elog "Please edit /etc/conf.d/ushare to set the shared directories"
+ elog "and other important settings. Check system log if ushare is"
+ elog "not booting."
+}