summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-12-03 17:23:08 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-12-03 17:23:08 +0000
commit6a5d3efccfb49c97e43ccc3cffa1e59177dc01d5 (patch)
treeecc499a33d6d40c459efa2320071049ba350edfa /media-video/vmaid/vmaid-2.0.6.ebuild
parentFixed pre-stripping of binaries; bug #137822. (diff)
downloadgentoo-2-6a5d3efccfb49c97e43ccc3cffa1e59177dc01d5.tar.gz
gentoo-2-6a5d3efccfb49c97e43ccc3cffa1e59177dc01d5.tar.bz2
gentoo-2-6a5d3efccfb49c97e43ccc3cffa1e59177dc01d5.zip
Version bumped.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-video/vmaid/vmaid-2.0.6.ebuild')
-rw-r--r--media-video/vmaid/vmaid-2.0.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-video/vmaid/vmaid-2.0.6.ebuild b/media-video/vmaid/vmaid-2.0.6.ebuild
new file mode 100644
index 000000000000..2e6b89a62276
--- /dev/null
+++ b/media-video/vmaid/vmaid-2.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/vmaid-2.0.6.ebuild,v 1.1 2006/12/03 17:23:08 matsuu Exp $
+
+DESCRIPTION="Video maid is the AVI file editor"
+HOMEPAGE="http://vmaid.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/vmaid/22932/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao mime win32codecs"
+
+RDEPEND=">=x11-libs/gtk+-2
+ ao? ( media-libs/libao )
+ !ao? ( alsa? ( >=media-libs/alsa-lib-0.9 ) )
+ win32codecs? ( media-libs/win32codecs )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ app-text/scrollkeeper"
+
+#MAKEOPTS="-j1"
+
+src_compile() {
+ local myconf
+
+ if use ao ; then
+ myconf="${myconf} --with-ao=yes"
+ elif use alsa ; then
+ myconf="${myconf} --with-alsa=yes"
+ fi
+
+ econf \
+ $(use_enable mime) \
+ $(use_with win32codecs w32) \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS CONTRIBUTORS ChangeLog NEWS README
+ dohtml -r doc/{en,ja}
+}