summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-11-29 14:22:40 +0000
committerMarinus Schraal <foser@gentoo.org>2004-11-29 14:22:40 +0000
commit0a77f199da0057ec4ea973b0a5add33aaec937be (patch)
tree5f2ac3fa95f88f0d4aa4d9d23bf4108fad6b0bb8 /media-video
parentUpdated the ioctl32 patch to match what has gone into cvs ustream. We also n... (diff)
downloadgentoo-2-0a77f199da0057ec4ea973b0a5add33aaec937be.tar.gz
gentoo-2-0a77f199da0057ec4ea973b0a5add33aaec937be.tar.bz2
gentoo-2-0a77f199da0057ec4ea973b0a5add33aaec937be.zip
fix the fix
Diffstat (limited to 'media-video')
-rw-r--r--media-video/totem/ChangeLog5
-rw-r--r--media-video/totem/files/totem-0.99.22-reorder_includes.patch13
-rw-r--r--media-video/totem/files/totem-0.99.22-x_includes.patch43
-rw-r--r--media-video/totem/totem-0.99.19.ebuild5
-rw-r--r--media-video/totem/totem-0.99.22-r1.ebuild7
5 files changed, 55 insertions, 18 deletions
diff --git a/media-video/totem/ChangeLog b/media-video/totem/ChangeLog
index 3d4c05bad2e5..6e1561599aa8 100644
--- a/media-video/totem/ChangeLog
+++ b/media-video/totem/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/totem
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.38 2004/11/22 14:57:14 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/ChangeLog,v 1.39 2004/11/29 14:22:40 foser Exp $
+
+ 29 Nov 2004; foser <foser@gentoo.org> totem-0.99.{19,22-r1}.ebuild :
+ Do the compile fix right #71960 -> #72124, thanks the Ed Catmur for the patch
*totem-0.99.22-r1 (22 Nov 2004)
diff --git a/media-video/totem/files/totem-0.99.22-reorder_includes.patch b/media-video/totem/files/totem-0.99.22-reorder_includes.patch
deleted file mode 100644
index 9f6f3defb7bf..000000000000
--- a/media-video/totem/files/totem-0.99.22-reorder_includes.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur totem-0.99.22/src/video-utils.c totem-0.99.22.new/src/video-utils.c
---- totem-0.99.22/src/video-utils.c 2004-10-14 14:55:46.000000000 +0200
-+++ totem-0.99.22.new/src/video-utils.c 2004-11-21 01:08:54.553510768 +0100
-@@ -3,8 +3,8 @@
-
- #include "video-utils.h"
-
--#include <glib/gi18n.h>
- #include <libintl.h>
-+#include <glib/gi18n.h>
-
- #include <gdk/gdk.h>
- #include <gdk/gdkx.h>
diff --git a/media-video/totem/files/totem-0.99.22-x_includes.patch b/media-video/totem/files/totem-0.99.22-x_includes.patch
new file mode 100644
index 000000000000..7eaac066ad30
--- /dev/null
+++ b/media-video/totem/files/totem-0.99.22-x_includes.patch
@@ -0,0 +1,43 @@
+--- configure.in 2004/11/22 21:41:20 1.1
++++ configure.in 2004/11/22 22:04:49
+@@ -199,15 +199,21 @@ AC_SUBST(REMOTE_LIBS)
+
+ AC_PATH_X
+
+-CFLAGS="-I$x_includes $CFLAGS"
+-LIBS="-L$x_libraries $LIBS"
++if test x"$x_includes" != x"NONE" && test -n "$x_includes" ; then
++ X_INCLUDES=-L`echo $x_includes | sed -e "s/:/ -I/g"`
++fi
++if test x"$x_libraries" != x"NONE" && test -n "$x_libraries" ; then
++ X_LIBRARIES=-L`echo $x_libraries | sed -e "s/:/ -L/g"`
++fi
++CFLAGS="$X_INCLUDES $CFLAGS"
++LIBS="$X_LIBRARIES $LIBS"
+
+ XTEST_LIBS=""
+ AC_CHECK_LIB(Xtst, XTestFakeKeyEvent,
+- XTEST_LIBS="-lX11 -lXtst -L$x_libraries"
++ XTEST_LIBS="-lX11 -lXtst $X_LIBRARIES"
+ AC_DEFINE(HAVE_XTEST, 1, [defined if you have XTest library]),
+ ,
+- -L$x_libraries)
++ $X_LIBRARIES)
+ AC_SUBST(XTEST_LIBS)
+
+ have_randr=no
+@@ -217,12 +223,12 @@ AC_CHECK_LIB(Xrandr, XRRUpdateConfigurat
+ RANDR_LIBS="-lX11 -lXrandr -lXrender"
+ AC_DEFINE(HAVE_RANDR, 1, Have the Xrandr extension library),
+ :, [#include <X11/Xlib.h>])], : ,
+- -L$x_libraries -lXrandr -lXrender)
++ $X_LIBRARIES -lXrandr -lXrender)
+ AM_CONDITIONAL(HAVE_RANDR, [test $have_randr = yes])
+ AC_SUBST(RANDR_LIBS)
+
+ dnl Explicitely link against libX11 to avoid problems with crappy linkers
+-X_LIBS="-L$x_libraries -lX11"
++X_LIBS="$X_LIBRARIES -lX11"
+ AC_SUBST(X_LIBS)
+
+ dnl Multimedia keys
diff --git a/media-video/totem/totem-0.99.19.ebuild b/media-video/totem/totem-0.99.19.ebuild
index bed54bc008f2..bd9e0db4e012 100644
--- a/media-video/totem/totem-0.99.19.ebuild
+++ b/media-video/totem/totem-0.99.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-0.99.19.ebuild,v 1.4 2004/11/22 01:07:30 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-0.99.19.ebuild,v 1.5 2004/11/29 14:22:40 foser Exp $
inherit gnome2 eutils
@@ -57,7 +57,8 @@ src_unpack() {
# violations, see bug #48800 <obz@gentoo.org>
gnome2_omf_fix
- epatch ${FILESDIR}/${PN}-0.99.22-reorder_includes.patch
+ epatch ${FILESDIR}/${PN}-0.99.22-x_includes.patch
+ autoconf || die
}
diff --git a/media-video/totem/totem-0.99.22-r1.ebuild b/media-video/totem/totem-0.99.22-r1.ebuild
index c5129f571ce6..104041a07ac4 100644
--- a/media-video/totem/totem-0.99.22-r1.ebuild
+++ b/media-video/totem/totem-0.99.22-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-0.99.22-r1.ebuild,v 1.1 2004/11/22 14:57:14 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/totem/totem-0.99.22-r1.ebuild,v 1.2 2004/11/29 14:22:40 foser Exp $
inherit gnome2 eutils
@@ -59,7 +59,7 @@ src_unpack() {
cd ${S}
# fix #71863
- epatch ${FILESDIR}/${P}-reorder_includes.patch
+ epatch ${FILESDIR}/${P}-x_includes.patch
# use the omf_fix for scrollkeeper sandbox
# violations, see bug #48800 <obz@gentoo.org>
gnome2_omf_fix
@@ -68,6 +68,9 @@ src_unpack() {
cd ${S}/src
epatch ${FILESDIR}/${P}-gst_object_rename.patch
+ cd ${S}
+ autoconf || die
+
}
USE_DESTDIR="1"