summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-02-24 16:07:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-02-24 16:07:47 +0000
commit2e31b286bcda521c9d581ddc6a31cb1e8b2074c2 (patch)
tree0a5093f343e60879c739d11e07f34da04bab7b3b /media-video
parentMarking shadow-4.0.18.2 ppc and ppc64 for bug 211252 (diff)
downloadgentoo-2-2e31b286bcda521c9d581ddc6a31cb1e8b2074c2.tar.gz
gentoo-2-2e31b286bcda521c9d581ddc6a31cb1e8b2074c2.tar.bz2
gentoo-2-2e31b286bcda521c9d581ddc6a31cb1e8b2074c2.zip
Version bumped, bug #202062.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vmaid/ChangeLog9
-rw-r--r--media-video/vmaid/vmaid-2.1.7.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/media-video/vmaid/ChangeLog b/media-video/vmaid/ChangeLog
index e1aae1943ded..21a206009c7b 100644
--- a/media-video/vmaid/ChangeLog
+++ b/media-video/vmaid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/vmaid
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/ChangeLog,v 1.6 2007/05/29 10:43:01 matsuu Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/ChangeLog,v 1.7 2008/02/24 16:07:47 matsuu Exp $
+
+*vmaid-2.1.7 (24 Feb 2008)
+
+ 24 Feb 2008; MATSUU Takuto <matsuu@gentoo.org> +vmaid-2.1.7.ebuild:
+ Version bumped, bug #202062.
*vmaid-2.1.2 (29 May 2007)
diff --git a/media-video/vmaid/vmaid-2.1.7.ebuild b/media-video/vmaid/vmaid-2.1.7.ebuild
new file mode 100644
index 000000000000..0e46d6cb24b8
--- /dev/null
+++ b/media-video/vmaid/vmaid-2.1.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/vmaid-2.1.7.ebuild,v 1.1 2008/02/24 16:07:47 matsuu Exp $
+
+DESCRIPTION="Video maid is the AVI file editor"
+HOMEPAGE="http://vmaid.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/vmaid/28957/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao mime win32codecs"
+
+RDEPEND=">=x11-libs/gtk+-2
+ ao? ( media-libs/libao )
+ !ao? ( alsa? ( >=media-libs/alsa-lib-0.9 ) )
+ mime? ( x11-misc/shared-mime-info )
+ win32codecs? ( media-libs/win32codecs )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ app-text/scrollkeeper"
+
+src_compile() {
+ local myconf
+
+ if use ao ; then
+ myconf="${myconf} --with-ao=yes"
+ elif use alsa ; then
+ myconf="${myconf} --with-alsa=yes"
+ fi
+
+ econf \
+ $(use_enable mime) \
+ $(use_with win32codecs w32) \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS CONTRIBUTORS ChangeLog NEWS README
+ dohtml -r doc/{en,ja}
+}