summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2003-12-29 17:26:17 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2003-12-29 17:26:17 +0000
commit3f593273326e04f050b3c372f10bda99c6e0ecbb (patch)
treecd888dfd4b6ed7a61747a65af654c0ec027f521f /media-video
parentInitial import (diff)
downloadgentoo-2-3f593273326e04f050b3c372f10bda99c6e0ecbb.tar.gz
gentoo-2-3f593273326e04f050b3c372f10bda99c6e0ecbb.tar.bz2
gentoo-2-3f593273326e04f050b3c372f10bda99c6e0ecbb.zip
Version bump. Large rewrite, based on rewrite of mtxdrivers ebuild, as well as the ati-drivers ebuild and the old form of mtxdrivers-pro. The primary end-user differences are 1) using the package's glext.h instead of some apparently random one, and 2) not auto-running opengl-update.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mtxdrivers-pro/ChangeLog11
-rw-r--r--media-video/mtxdrivers-pro/Manifest6
-rw-r--r--media-video/mtxdrivers-pro/files/digest-mtxdrivers-pro-1.1.0_beta1
-rw-r--r--media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta.ebuild62
4 files changed, 77 insertions, 3 deletions
diff --git a/media-video/mtxdrivers-pro/ChangeLog b/media-video/mtxdrivers-pro/ChangeLog
index 9aefcca6f6e2..d3f992d713d2 100644
--- a/media-video/mtxdrivers-pro/ChangeLog
+++ b/media-video/mtxdrivers-pro/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/mtxdrivers-pro
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers-pro/ChangeLog,v 1.3 2003/07/12 21:12:50 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers-pro/ChangeLog,v 1.4 2003/12/29 17:26:09 spyderous Exp $
+
+*mtxdrivers-pro-1.1.0_beta (29 Dec 2003)
+
+ 29 Dec 2003; Donnie Berkholz <spyderous@gentoo.org>;
+ mtxdrivers-pro-1.1.0_beta.ebuild:
+ Version bump. Large rewrite, based on rewrite of mtxdrivers ebuild, as well as
+ the ati-drivers ebuild and the old form of mtxdrivers-pro. The primary
+ end-user differences are 1) using the package's glext.h instead of some
+ apparently random one, and 2) not auto-running opengl-update.
*mtxdrivers-pro-1.0_beta4 (19 Apr 2003)
diff --git a/media-video/mtxdrivers-pro/Manifest b/media-video/mtxdrivers-pro/Manifest
index ad9549672ede..eeb77a3873e1 100644
--- a/media-video/mtxdrivers-pro/Manifest
+++ b/media-video/mtxdrivers-pro/Manifest
@@ -1,4 +1,6 @@
+MD5 416d16c52248a99e3641dff5252e5682 ChangeLog 888
+MD5 5fac047d4c4cb13f46084c8caf2515af mtxdrivers-pro-1.0_beta4.ebuild 2996
+MD5 2fe5fc5166a490473bb80a3f7cda3454 mtxdrivers-pro-1.1.0_beta.ebuild 2136
MD5 167169dc7cf54e2872436a73b7e5f3f1 files/digest-mtxdrivers-pro-1.0_beta4 79
MD5 f374c9160bef4d5c75df059fb5f21ad1 files/glext.h 284740
-MD5 5fac047d4c4cb13f46084c8caf2515af mtxdrivers-pro-1.0_beta4.ebuild 2996
-MD5 108a7362c83f1f4ae04196f5bc571de5 ChangeLog 457
+MD5 3f15e26d6b4149ea16fdc1c338a6506f files/digest-mtxdrivers-pro-1.1.0_beta 85
diff --git a/media-video/mtxdrivers-pro/files/digest-mtxdrivers-pro-1.1.0_beta b/media-video/mtxdrivers-pro/files/digest-mtxdrivers-pro-1.1.0_beta
new file mode 100644
index 000000000000..3ec4bba8c835
--- /dev/null
+++ b/media-video/mtxdrivers-pro/files/digest-mtxdrivers-pro-1.1.0_beta
@@ -0,0 +1 @@
+MD5 f6a0889f98df944b6d0e6b1d68dc3de5 mtxdrivers-rh9.0-v1.1.0-pro-beta.tar.gz 2658433
diff --git a/media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta.ebuild b/media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta.ebuild
new file mode 100644
index 000000000000..99b4d28fa1f6
--- /dev/null
+++ b/media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mtxdrivers-pro/mtxdrivers-pro-1.1.0_beta.ebuild,v 1.1 2003/12/29 17:26:09 spyderous Exp $
+
+inherit matrox
+
+# GL lib version
+GL_V="1.3.0"
+
+# Stupid naming scheme requires this, probably only works for betas
+MY_PV="${PV/_/-pro-}"
+MY_PN="${PN/-pro}"
+MY_P="${MY_PN}-rh9.0-v${MY_PV}"
+S="${WORKDIR}/${MY_PN}"
+DESCRIPTION="Drivers for the Matrox Parhelia and Millenium P650/P750 cards with OpenGL support."
+SRC_URI="${MY_P}.tar.gz"
+
+KEYWORDS="~x86"
+
+RDEPEND="x11-base/opengl-update
+ !media-video/mtxdrivers"
+
+pkg_nofetch() {
+ einfo "Matrox requires you e-mail them for the 'pro' version of their drivers"
+ einfo "(i.e., the ones with OpenGL support). If you do not need OpenGL, please"
+ einfo "emerge mtxdrivers. Otherwise, e-mail cad-support@matrox.com and request"
+ einfo "the Matrox Parhelia drivers with OpenGL support. Please remember to"
+ einfo "download the RH9.0 driver once you are given the site address."
+}
+
+src_install() {
+ # Install 2D driver and DRM kernel module
+ matrox_base_src_install
+
+ dodoc README*
+
+ # Install OpenGL driver, libs, etc.
+ local GENTOO_GL_ROOT="/usr/lib/opengl"
+ local GENTOO_MTX_ROOT="${GENTOO_GL_ROOT}/mtx"
+
+ dodir ${GENTOO_MTX_ROOT}/extensions; exeinto ${GENTOO_MTX_ROOT}/extensions
+ doexe xfree86/${GENTOO_X_VERSION}/libglx.a
+
+ dodir ${GENTOO_MTX_ROOT}/include; insinto ${GENTOO_MTX_ROOT}/include
+ doins include/GL/gl.h include/GL/glx.h include/GL/glext.h
+
+ dodir ${GENTOO_MTX_ROOT}/lib; exeinto ${GENTOO_MTX_ROOT}/lib
+ doexe lib/libGL.so.${GL_V}
+ dosym ${GENTOO_MTX_ROOT}/lib/libGL.so.${GL_V} ${GENTOO_MTX_ROOT}/lib/libGL.so.1
+ dosym ${GENTOO_MTX_ROOT}/lib/libGL.so.${GL_V} ${GENTOO_MTX_ROOT}/lib/libGL.so
+
+ # Same as XFree86
+ dosym ${GENTOO_GL_ROOT}/xfree/lib/libGL.la ${GENTOO_MTX_ROOT}/lib/libGL.la
+}
+
+pkg_postinst() {
+ # modules-update, maybe some info on busmastering
+ matrox_base_pkg_postinst
+
+ # Don't run opengl-update for them. Tell them how, instead. (spyderous)
+ einfo "To switch to Matrox OpenGL, run \"opengl-update mtx\""
+}