summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-11-19 19:36:39 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-11-19 19:36:39 +0000
commit6113e194db37c1ca55b606abc7a72cec754f3c83 (patch)
treea6ceb74553959e652e826d17240fcaabc2ac8b8c /media-video
parentVersion bump. Add ruby20. Drop ppc64, bug 465948. (diff)
downloadgentoo-2-6113e194db37c1ca55b606abc7a72cec754f3c83.tar.gz
gentoo-2-6113e194db37c1ca55b606abc7a72cec754f3c83.tar.bz2
gentoo-2-6113e194db37c1ca55b606abc7a72cec754f3c83.zip
Add useflag to enable/disable support for downloading youtube videos. Bug #491344
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/minitube/ChangeLog7
-rw-r--r--media-video/minitube/metadata.xml3
-rw-r--r--media-video/minitube/minitube-2.1.3.ebuild17
3 files changed, 24 insertions, 3 deletions
diff --git a/media-video/minitube/ChangeLog b/media-video/minitube/ChangeLog
index 3b472e08821f..cd76aee6af77 100644
--- a/media-video/minitube/ChangeLog
+++ b/media-video/minitube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/minitube
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.90 2013/11/06 17:29:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.91 2013/11/19 19:36:39 hwoarang Exp $
+
+ 19 Nov 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml,
+ minitube-2.1.3.ebuild:
+ Add useflag to enable/disable support for downloading youtube videos. Bug
+ #491344
06 Nov 2013; Markos Chandras <hwoarang@gentoo.org> minitube-2.1.3.ebuild:
Add missing dev-qt/qtsqli dependency. Bug #490494
diff --git a/media-video/minitube/metadata.xml b/media-video/minitube/metadata.xml
index a1db186ad8a9..0a5b314a808a 100644
--- a/media-video/minitube/metadata.xml
+++ b/media-video/minitube/metadata.xml
@@ -7,4 +7,7 @@
<email>hwoarang@gentoo.org</email>
<name>Markos Chandras</name>
</maintainer>
+<use>
+<flag name='download'>Enable support for downloading YouTube videos</flag>
+</use>
</pkgmetadata>
diff --git a/media-video/minitube/minitube-2.1.3.ebuild b/media-video/minitube/minitube-2.1.3.ebuild
index 6321bd01b534..90161756ab9b 100644
--- a/media-video/minitube/minitube-2.1.3.ebuild
+++ b/media-video/minitube/minitube-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/minitube-2.1.3.ebuild,v 1.2 2013/11/06 17:29:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/minitube-2.1.3.ebuild,v 1.3 2013/11/19 19:36:39 hwoarang Exp $
EAPI=5
PLOCALES="ar ca ca_ES da de_DE el en es es_AR es_ES fi fi_FI fr he_IL hr hu
@@ -16,7 +16,7 @@ SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug gstreamer kde"
+IUSE="debug download gstreamer kde"
DEPEND=">=dev-qt/qtgui-4.8:4[accessibility,gtkstyle]
>=dev-qt/qtdbus-4.8:4
@@ -54,9 +54,22 @@ src_prepare() {
# gcc-4.7. Bug #422977. Will probably be fixed
# once ubuntu moves to gcc-4.7
epatch "${FILESDIR}"/${PN}-1.9-gcc47.patch
+ # Enable video downloads. Bug #491344
+ use download && { echo "DEFINES += APP_DOWNLOADS" >> ${PN}.pro; }
}
src_install() {
qt4-r2_src_install
newicon images/app.png minitube.png
}
+
+pkg_postinst() {
+ if use download; then
+ elog "You activated the 'download' USE flag. This allows you to"
+ elog "download videos from youtube, which might violate the youtube"
+ elog "terms-of-service (TOS) in some legislations. If downloading"
+ elog "youtube-videos is not allowed in your legislation, please"
+ elog "disable the 'download' use flag. For details on the youtube TOS,"
+ elog "see http://www.youtube.com/t/terms"
+ fi
+}