summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-26 22:28:42 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-26 22:28:42 +0000
commit6f2f52ba3351cd076de7766347c77ef67953b2fa (patch)
tree76ea7779b23188937d8f48d1e5541dc7f6c34e00 /media-video
parentUpdate for the latest version. (diff)
downloadgentoo-2-6f2f52ba3351cd076de7766347c77ef67953b2fa.tar.gz
gentoo-2-6f2f52ba3351cd076de7766347c77ef67953b2fa.tar.bz2
gentoo-2-6f2f52ba3351cd076de7766347c77ef67953b2fa.zip
Update for the latest version.
Looks like the directfb hack is no longer needed (as it was for 0.9.9).
Diffstat (limited to 'media-video')
-rw-r--r--media-video/xine-ui/ChangeLog8
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.101
-rw-r--r--media-video/xine-ui/xine-ui-0.9.10.ebuild47
3 files changed, 55 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index 82f9ea2d30da..1f24aff9f03b 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.8 2002/05/02 01:29:13 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.9 2002/05/26 22:28:42 agenkin Exp $
+
+*xine-ui-0.9.10 (26 May 2002)
+
+ 26 May 2002; Arcady Genkin <agenkin@thpoon.com> xine-ui-0.9.10.ebuld :
+
+ Update to version 0.9.10.
*xine-ui-0.9.9-r1 (1 May 2002)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.10 b/media-video/xine-ui/files/digest-xine-ui-0.9.10
new file mode 100644
index 000000000000..017a038eb743
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.10
@@ -0,0 +1 @@
+MD5 1811dba3177a40bd704adb6e806c700e xine-ui-0.9.10.tar.gz 2663431
diff --git a/media-video/xine-ui/xine-ui-0.9.10.ebuild b/media-video/xine-ui/xine-ui-0.9.10.ebuild
new file mode 100644
index 000000000000..851031a995de
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.10.ebuild,v 1.1 2002/05/26 22:28:42 agenkin Exp $
+
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ media-libs/libpng
+ >=media-libs/xine-lib-${PV}
+ nls? ( sys-devel/gettext )
+ X? ( virtual/x11 )
+ directfb? ( >=dev-libs/DirectFB-0.9.9 )
+ gnome? ( gnome-base/ORBit )"
+
+SLOT="0"
+
+SRC_URI="http://xine.sourceforge.net/files/xine-ui-${PV}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}