summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-08 12:29:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-08 12:29:51 +0000
commit70916f7e4d6be7da56e14bd84d11924fa80122a2 (patch)
treeed93a114d8fa5389c64afd5f257e5dc8cbc16f5f /media-video
parentCleanups. (diff)
downloadgentoo-2-70916f7e4d6be7da56e14bd84d11924fa80122a2.tar.gz
gentoo-2-70916f7e4d6be7da56e14bd84d11924fa80122a2.tar.bz2
gentoo-2-70916f7e4d6be7da56e14bd84d11924fa80122a2.zip
As per bug #113449, disable ability to build vlc with wxGTK built without unicode, as 2.6 version has non-experimental support, and vlc 0.8.4 seems to require it strictly.
(Portage version: 2.0.53)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/ChangeLog8
-rw-r--r--media-video/vlc/vlc-0.8.4-r1.ebuild12
-rw-r--r--media-video/vlc/vlc-0.8.4.ebuild12
3 files changed, 15 insertions, 17 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index 083be1fee475..289b1afacc9b 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/vlc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.125 2005/12/02 16:55:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.126 2005/12/08 12:29:51 flameeyes Exp $
+
+ 08 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> vlc-0.8.4.ebuild,
+ vlc-0.8.4-r1.ebuild:
+ As per bug #113449, disable ability to build vlc with wxGTK built without
+ unicode, as 2.6 version has non-experimental support, and vlc 0.8.4 seems to
+ require it strictly.
02 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> vlc-0.8.4-r1.ebuild:
Added patch from Giandomenico De Tullio for enabing avahi support on 0.6
diff --git a/media-video/vlc/vlc-0.8.4-r1.ebuild b/media-video/vlc/vlc-0.8.4-r1.ebuild
index 968df503ec44..79b7046b3464 100644
--- a/media-video/vlc/vlc-0.8.4-r1.ebuild
+++ b/media-video/vlc/vlc-0.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.8.4-r1.ebuild,v 1.3 2005/12/02 16:55:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.8.4-r1.ebuild,v 1.4 2005/12/08 12:29:51 flameeyes Exp $
inherit eutils wxwidgets flag-o-matic nsplugins multilib autotools toolchain-funcs
@@ -21,7 +21,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="a52 3dfx nls unicode debug altivec httpd vlm gnutls live v4l cdda ogg matroska
+IUSE="a52 3dfx nls debug altivec httpd vlm gnutls live v4l cdda ogg matroska
dvb dvd vcd ffmpeg aac dts flac mpeg vorbis theora X opengl freetype svg fbcon svga
oss aalib ggi libcaca esd arts alsa wxwindows ncurses xosd lirc joystick stream
mp3 xv bidi sdl png xml2 samba daap corba screen mod speex nsplugin shout real
@@ -101,11 +101,7 @@ S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use wxwindows; then
WX_GTK_VER="2.6"
- if use unicode; then
- need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
- else
- need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
- fi
+ need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
fi
if use skins && ! use freetype; then
@@ -149,7 +145,6 @@ src_compile () {
econf \
$(use_enable altivec) \
- $(use_enable unicode utf8) \
$(use_enable stream sout) \
$(use_enable httpd) \
$(use_enable vlm) \
@@ -210,6 +205,7 @@ src_compile () {
--disable-portaudio \
--disable-slp \
--disable-x264 \
+ --enable-utf8 \
${myconf} || die "configuration failed"
if [[ $(gcc-major-version) == 2 ]]; then
diff --git a/media-video/vlc/vlc-0.8.4.ebuild b/media-video/vlc/vlc-0.8.4.ebuild
index 513a442cba8d..543dd22a46ad 100644
--- a/media-video/vlc/vlc-0.8.4.ebuild
+++ b/media-video/vlc/vlc-0.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.8.4.ebuild,v 1.1 2005/11/27 15:00:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.8.4.ebuild,v 1.2 2005/12/08 12:29:51 flameeyes Exp $
inherit eutils wxwidgets flag-o-matic nsplugins multilib autotools toolchain-funcs
@@ -21,7 +21,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="a52 3dfx nls unicode debug altivec httpd vlm gnutls live v4l cdda ogg matroska
+IUSE="a52 3dfx nls debug altivec httpd vlm gnutls live v4l cdda ogg matroska
dvb dvd vcd ffmpeg aac dts flac mpeg vorbis theora X opengl freetype svg fbcon svga
oss aalib ggi libcaca esd arts alsa wxwindows ncurses xosd lirc joystick stream
mp3 xv bidi sdl png xml2 samba daap corba screen mod speex nsplugin shout real
@@ -99,11 +99,7 @@ S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use wxwindows; then
WX_GTK_VER="2.6"
- if use unicode; then
- need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
- else
- need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
- fi
+ need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
fi
}
@@ -148,7 +144,6 @@ src_compile () {
econf \
$(use_enable altivec) \
- $(use_enable unicode utf8) \
$(use_enable stream sout) \
$(use_enable httpd) \
$(use_enable vlm) \
@@ -208,6 +203,7 @@ src_compile () {
--disable-hal \
--disable-x264 \
--disable-bonjour \
+ --enable-utf8 \
${myconf} || die "configuration failed"
if [[ $(gcc-major-version) == 2 ]]; then