summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-15 15:49:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-15 15:49:12 +0000
commit8854c7e21fcf437eb18cf8742565d7c0a406cd90 (patch)
treeb8f851063033fea9d59903582981d41b033b7a99 /media-video
parentUpdate PIL imports, bug 472774. Migrate to distutils-r1. Commited by proxy fo... (diff)
downloadgentoo-2-8854c7e21fcf437eb18cf8742565d7c0a406cd90.tar.gz
gentoo-2-8854c7e21fcf437eb18cf8742565d7c0a406cd90.tar.bz2
gentoo-2-8854c7e21fcf437eb18cf8742565d7c0a406cd90.zip
add amrenc useflag to have a more finegrained control, bug #473284
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild10
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 11 insertions, 6 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index a2dcfa3b2cca..42286a8af6ef 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.654 2013/06/14 17:15:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.655 2013/06/15 15:49:12 aballier Exp $
+
+ 15 Jun 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add amrenc useflag to have a more finegrained control, bug #473284
14 Jun 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
add wavpack useflag
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index a6f6b151f2da..7a0e9880c37d 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.131 2013/06/14 17:15:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.132 2013/06/15 15:49:12 aballier Exp $
EAPI="4"
@@ -29,7 +29,7 @@ if [ "${PV#9999}" = "${PV}" ] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
fi
IUSE="
- aac aacplus alsa amr bindist bluray +bzip2 cdio celt
+ aac aacplus alsa amr amrenc bindist bluray +bzip2 cdio celt
cpudetection debug doc +encode examples faac fdk flite fontconfig frei0r
gnutls gsm +hardcoded-tables +iconv iec61883 ieee1394 jack jpeg2k libass
libcaca libsoxr libv4l modplug mp3 network openal openssl opus oss pic
@@ -61,7 +61,7 @@ RDEPEND="
encode? (
aac? ( media-libs/vo-aacenc )
aacplus? ( media-libs/libaacplus )
- amr? ( media-libs/vo-amrwbenc )
+ amrenc? ( media-libs/vo-amrwbenc )
faac? ( media-libs/faac )
fdk? ( media-libs/fdk-aac )
mp3? ( >=media-sound/lame-3.98.3 )
@@ -150,13 +150,13 @@ src_configure() {
# Encoders
if use encode
then
- ffuse="${ffuse} aac:libvo-aacenc amr:libvo-amrwbenc mp3:libmp3lame fdk:libfdk-aac"
+ ffuse="${ffuse} aac:libvo-aacenc amrenc:libvo-amrwbenc mp3:libmp3lame fdk:libfdk-aac"
for i in aacplus faac theora twolame wavpack x264 xvid; do
ffuse="${ffuse} ${i}:lib${i}"
done
# Licensing.
- if use aac || use amr ; then
+ if use aac || use amrenc ; then
myconf="${myconf} --enable-version3"
fi
if use aacplus || use faac || use fdk ; then
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 664200ffd17f..e97d08f82718 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -13,6 +13,7 @@
</flag>
<flag name="aacplus">AAC+ encoding via <pkg>media-libs/libaacplus</pkg>.</flag>
<flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
+ <flag name="amrenc">Enables Adaptive Multi-Rate Audio encoding support with <pkg>media-libs/vo-amrwbenc</pkg>.</flag>
<flag name="avx">Adds support for Advanced Vector Extensions instructions (Intel Sandy Bridge, AMD Bulldozer and later chips)</flag>
<flag name="bindist">Enforces license compatibility constraints via REQUIRED_USE.</flag>
<flag name="bluray">Enable playback of Blu-ray filesystems</flag>