summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-10-27 12:35:25 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-10-27 12:35:25 +0000
commitaa040bac0e35e6d099a7b92e06e3318f9ccca640 (patch)
tree050b2f8edf9b11065a67a3de3598a60e2eecc89d /media-video
parentUpdate homepage, see bug #196998. (diff)
downloadgentoo-2-aa040bac0e35e6d099a7b92e06e3318f9ccca640.tar.gz
gentoo-2-aa040bac0e35e6d099a7b92e06e3318f9ccca640.tar.bz2
gentoo-2-aa040bac0e35e6d099a7b92e06e3318f9ccca640.zip
Version bump.
(Portage version: 2.1.3.16)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/griffith/ChangeLog7
-rw-r--r--media-video/griffith/files/digest-griffith-0.9.56
-rw-r--r--media-video/griffith/griffith-0.9.5.ebuild66
3 files changed, 78 insertions, 1 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index f288684a1140..1c312e131b38 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.14 2007/10/27 12:32:13 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.15 2007/10/27 12:35:24 nelchael Exp $
+
+*griffith-0.9.5 (27 Oct 2007)
+
+ 27 Oct 2007; Krzysiek Pawlik <nelchael@gentoo.org> +griffith-0.9.5.ebuild:
+ Version bump.
27 Oct 2007; Krzysiek Pawlik <nelchael@gentoo.org> griffith-0.9.2.ebuild,
griffith-0.9.3.1.ebuild:
diff --git a/media-video/griffith/files/digest-griffith-0.9.5 b/media-video/griffith/files/digest-griffith-0.9.5
new file mode 100644
index 000000000000..05df2c2e1802
--- /dev/null
+++ b/media-video/griffith/files/digest-griffith-0.9.5
@@ -0,0 +1,6 @@
+MD5 212e63425aac0da3b962d4ae06b21a54 griffith-0.9.5.tar.gz 886950
+RMD160 9a8c5d9b728997bd4d8ccefca95f769314d09b54 griffith-0.9.5.tar.gz 886950
+SHA256 3cf4a199ed945137fec08902a4e7e1415b787ce9a5fff163210ee4385fdedaed griffith-0.9.5.tar.gz 886950
+MD5 a18f9f900dc467f8ee801bb70776072f griffith-extra-artwork-0.9.4.tar.gz 124008
+RMD160 926081627d650803d4a16b140a23de4e9798321e griffith-extra-artwork-0.9.4.tar.gz 124008
+SHA256 96bc01a05ad54aad9fabcf411809c46c78b990fc7656ea004cebdfd8ea9894fd griffith-extra-artwork-0.9.4.tar.gz 124008
diff --git a/media-video/griffith/griffith-0.9.5.ebuild b/media-video/griffith/griffith-0.9.5.ebuild
new file mode 100644
index 000000000000..36dcb3f2bf9c
--- /dev/null
+++ b/media-video/griffith/griffith-0.9.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.5.ebuild,v 1.1 2007/10/27 12:35:24 nelchael Exp $
+
+inherit python
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="http://download.berlios.de/griffith/${P/_/-}.tar.gz
+ http://download.berlios.de/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc spell"
+
+RDEPEND="dev-python/imaging
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1
+ >=dev-python/pysqlite-2.0
+ >=dev-python/sqlalchemy-0.3
+ >=dev-python/reportlab-1.19
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/docbook2x-man/docbook2man.pl/' \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ docs/*/Makefile || die "sed failed"
+ sed -i \
+ -e 's/latin1/iso-8859-1/' \
+ docs/en/*.xml || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ lib/gconsole.py || die "sed failed"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/share/${PN}/lib
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${ROOT}usr/share/${PN}/lib
+}