summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-06-01 20:01:40 +0000
committerSamuli Suominen <drac@gentoo.org>2007-06-01 20:01:40 +0000
commitd1bf7603c70822398e7676b5573e370d59c02852 (patch)
treedccd6fabe4b4898a6fefb1797a0d5c8c30b23cd4 /media-video
parentStable on ppc wrt bug 179940 (diff)
downloadgentoo-2-d1bf7603c70822398e7676b5573e370d59c02852.tar.gz
gentoo-2-d1bf7603c70822398e7676b5573e370d59c02852.tar.bz2
gentoo-2-d1bf7603c70822398e7676b5573e370d59c02852.zip
Fix building with media-video/ffmpeg-0.4.9_p20070525. Idea from aballier and dvbcut so thanks.
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog9
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.1-r1.ebuild29
-rw-r--r--media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1.1-r13
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1.1-ffmpeg.patch29
4 files changed, 69 insertions, 1 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 885972c0f88a..8fe9da8e2a88 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.18 2007/06/01 11:49:18 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.19 2007/06/01 20:01:40 drac Exp $
+
+*ffmpegthumbnailer-1.1.1-r1 (01 Jun 2007)
+
+ 01 Jun 2007; Samuli Suominen <drac@gentoo.org>
+ +files/ffmpegthumbnailer-1.1.1-ffmpeg.patch,
+ +ffmpegthumbnailer-1.1.1-r1.ebuild:
+ Fix building with media-video/ffmpeg-0.4.9_p20070525.
01 Jun 2007; Samuli Suominen <drac@gentoo.org>
ffmpegthumbnailer-1.1.1.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.1-r1.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..b4d3c9db9aee
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.1.1-r1.ebuild,v 1.1 2007/06/01 20:01:40 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng
+ >=media-video/ffmpeg-0.4.9_p20070330"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ffmpeg.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1.1-r1 b/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1.1-r1
new file mode 100644
index 000000000000..23e8eba30ccd
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/digest-ffmpegthumbnailer-1.1.1-r1
@@ -0,0 +1,3 @@
+MD5 d1758d11def56f3d7367947f87606c27 ffmpegthumbnailer-1.1.1.tar.gz 80116
+RMD160 9793f0126a49321a23adfcaa35c7dc70e85e3c17 ffmpegthumbnailer-1.1.1.tar.gz 80116
+SHA256 80b35f18b07d1409f8d860b36398ae6d11f929b6068ced2439ca53118d36e13e ffmpegthumbnailer-1.1.1.tar.gz 80116
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1.1-ffmpeg.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1.1-ffmpeg.patch
new file mode 100644
index 000000000000..f92a896b04e5
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-1.1.1-ffmpeg.patch
@@ -0,0 +1,29 @@
+diff -ur ffmpegthumbnailer-1.1.1.orig/src/moviedecoder.cpp ffmpegthumbnailer-1.1.1/src/moviedecoder.cpp
+--- ffmpegthumbnailer-1.1.1.orig/src/moviedecoder.cpp 2007-05-07 21:05:11.000000000 +0300
++++ ffmpegthumbnailer-1.1.1/src/moviedecoder.cpp 2007-06-01 22:47:21.000000000 +0300
+@@ -3,7 +3,10 @@
+
+ #include <assert.h>
+ #include <iostream>
++
++extern "C" {
+ #include <ffmpeg/swscale.h>
++}
+
+ using namespace std;
+
+diff -ur ffmpegthumbnailer-1.1.1.orig/src/moviedecoder.h ffmpegthumbnailer-1.1.1/src/moviedecoder.h
+--- ffmpegthumbnailer-1.1.1.orig/src/moviedecoder.h 2007-05-07 20:49:26.000000000 +0300
++++ ffmpegthumbnailer-1.1.1/src/moviedecoder.h 2007-06-01 22:41:01.000000000 +0300
+@@ -7,8 +7,11 @@
+
+ #include <string>
+ #include <vector>
++
++extern "C" {
+ #include <ffmpeg/avcodec.h>
+ #include <ffmpeg/avformat.h>
++}
+
+ typedef unsigned char byte;
+