summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-02-15 19:56:41 +0000
committerJulian Ospald <hasufell@gentoo.org>2015-02-15 19:56:41 +0000
commitd6319b3f2e08b2a80bb55e0b1bce6ced044af785 (patch)
treef0d35895c373c337f1a9cea4127d14ef65fb192d /media-video
parentRestore keywords (diff)
downloadgentoo-2-d6319b3f2e08b2a80bb55e0b1bce6ced044af785.tar.gz
gentoo-2-d6319b3f2e08b2a80bb55e0b1bce6ced044af785.tar.bz2
gentoo-2-d6319b3f2e08b2a80bb55e0b1bce6ced044af785.zip
fix build with ffmpeg-2.4 (patch by Olivier Laurantin), move to libav USE flag
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffdiaporama/ChangeLog9
-rw-r--r--media-video/ffdiaporama/ffdiaporama-2.1.ebuild11
-rw-r--r--media-video/ffdiaporama/files/ffdiaporama-2.1-ffmpeg-2.4.patch16
3 files changed, 29 insertions, 7 deletions
diff --git a/media-video/ffdiaporama/ChangeLog b/media-video/ffdiaporama/ChangeLog
index 601cd2926f9a..b862166bdadf 100644
--- a/media-video/ffdiaporama/ChangeLog
+++ b/media-video/ffdiaporama/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffdiaporama
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ChangeLog,v 1.22 2014/06/13 03:04:07 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ChangeLog,v 1.23 2015/02/15 19:56:41 hasufell Exp $
+
+ 15 Feb 2015; Julian Ospald <hasufell@gentoo.org> ffdiaporama-2.1.ebuild,
+ +files/ffdiaporama-2.1-ffmpeg-2.4.patch:
+ fix build with ffmpeg-2.4 (patch by Olivier Laurantin), move to libav USE
+ flag
13 Jun 2014; Patrick Lauer <patrick@gentoo.org> ffdiaporama-2.1.ebuild:
Fix header
diff --git a/media-video/ffdiaporama/ffdiaporama-2.1.ebuild b/media-video/ffdiaporama/ffdiaporama-2.1.ebuild
index 3458383262e4..86aca17f8da4 100644
--- a/media-video/ffdiaporama/ffdiaporama-2.1.ebuild
+++ b/media-video/ffdiaporama/ffdiaporama-2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ffdiaporama-2.1.ebuild,v 1.3 2014/06/13 03:04:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ffdiaporama-2.1.ebuild,v 1.4 2015/02/15 19:56:41 hasufell Exp $
EAPI=5
@@ -23,7 +23,7 @@ LICENSE="GPL-2
texturemate? ( CC-BY-3.0 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="openclipart texturemate"
+IUSE="libav openclipart texturemate"
RDEPEND="
dev-qt/qtcore:4
@@ -34,11 +34,12 @@ RDEPEND="
media-gfx/exiv2
media-libs/libsdl[sound]
media-libs/taglib
- !<media-video/ffmpeg-1.2:0
- virtual/ffmpeg[encode]"
+ !libav? ( >media-video/ffmpeg-1.2:0=[encode] )
+ libav? ( >=media-video/libav-9:0=[encode] )"
DEPEND="${RDEPEND}"
DOCS=( authors.txt )
+PATCHES=( "${FILESDIR}"/${P}-ffmpeg-2.4.patch )
S="${WORKDIR}/ffDiaporama"
diff --git a/media-video/ffdiaporama/files/ffdiaporama-2.1-ffmpeg-2.4.patch b/media-video/ffdiaporama/files/ffdiaporama-2.1-ffmpeg-2.4.patch
new file mode 100644
index 000000000000..7a8e664add37
--- /dev/null
+++ b/media-video/ffdiaporama/files/ffdiaporama-2.1-ffmpeg-2.4.patch
@@ -0,0 +1,16 @@
+--- src/ffDiaporama/engine/cDeviceModelDef.h 2015-02-14 10:02:12.592365100 +0100
++++ src/ffDiaporama/engine/cDeviceModelDef.h 2015-02-14 10:01:59.202463800 +0100
+@@ -84,7 +84,12 @@
+ #elif (LIBAVUTIL_VERSION_MICRO>=100)&&(LIBAVCODEC_VERSION_MICRO>=100)&&(LIBAVFORMAT_VERSION_MICRO>=100)&&(LIBAVDEVICE_VERSION_MICRO>=100)&&(LIBAVFILTER_VERSION_MICRO>=100)&&(LIBSWSCALE_VERSION_MICRO>=100)
+ #define FFMPEG
+ #include "libswresample/swresample.h"
+- #define RESAMPLE_MAX_CHANNELS SWR_CH_MAX
++ #ifdef SWR_CH_MAX
++ #define RESAMPLE_MAX_CHANNELS SWR_CH_MAX
++ #else
++ #define RESAMPLE_MAX_CHANNELS 32
++ #endif
++
+ #include "libavfilter/avcodec.h"
+ #include "libavfilter/buffersink.h"
+ #include "libavfilter/buffersrc.h"