summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-21 04:19:54 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-21 04:19:54 +0000
commit46a32aa58f4427e9a60478bde73f3d26e798d4a0 (patch)
treea3c68372bc9f5fa430e3a39749c5482ba83d85b4 /net-analyzer/angst/angst-0.4b-r1.ebuild
parentbetter SLOTs #17772 (diff)
downloadgentoo-2-46a32aa58f4427e9a60478bde73f3d26e798d4a0.tar.gz
gentoo-2-46a32aa58f4427e9a60478bde73f3d26e798d4a0.tar.bz2
gentoo-2-46a32aa58f4427e9a60478bde73f3d26e798d4a0.zip
compile against SLOT-ed libnet-1.0.x
Diffstat (limited to 'net-analyzer/angst/angst-0.4b-r1.ebuild')
-rw-r--r--net-analyzer/angst/angst-0.4b-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/angst/angst-0.4b-r1.ebuild b/net-analyzer/angst/angst-0.4b-r1.ebuild
new file mode 100644
index 000000000000..9ec15719f05e
--- /dev/null
+++ b/net-analyzer/angst/angst-0.4b-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/angst/angst-0.4b-r1.ebuild,v 1.1 2003/08/21 04:19:54 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="an active sniffer that provides methods for aggressive sniffing on switched LANs"
+HOMEPAGE="http://angst.sourceforge.net/"
+SRC_URI="http://angst.sourceforge.net/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=net-libs/libpcap-0.7.1
+ >=net-libs/libnet-1.0.2a-r3
+ <net-libs/libnet-1.1*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+}
+
+src_compile() {
+ make CFLAGS="${CFLAGS}" -f Makefile.linux || die
+}
+
+src_install() {
+ dosbin angst
+ doman angst.8
+ dodoc README LICENSE TODO ChangeLog
+}