summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-05-02 15:53:07 +0000
committerPeter Volkov <pva@gentoo.org>2010-05-02 15:53:07 +0000
commit8634c2ece8c87539b51d0b94e863f67ea0018e3a (patch)
treef7ce6bc59259d9c1465d38aec886965783b85bd6 /net-analyzer/argus-clients/argus-clients-3.0.3.7.ebuild
parentVersion bump, as requested by Johan Bergström in bug #299729. Patched out a ... (diff)
downloadgentoo-2-8634c2ece8c87539b51d0b94e863f67ea0018e3a.tar.gz
gentoo-2-8634c2ece8c87539b51d0b94e863f67ea0018e3a.tar.bz2
gentoo-2-8634c2ece8c87539b51d0b94e863f67ea0018e3a.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus-clients/argus-clients-3.0.3.7.ebuild')
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.3.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.3.7.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.3.7.ebuild
new file mode 100644
index 000000000000..874dc3375498
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.3.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.3.7.ebuild,v 1.1 2010/05/02 15:53:07 pva Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug geoip mysql"
+
+#sasl? ( >=dev-libs/cyrus-sasl-1.5.24 )
+MY_CDEPEND="net-libs/libpcap
+ net-analyzer/rrdtool[perl]
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )"
+
+# >=net-analyzer/argus-2.0.6[sasl?]"
+RDEPEND="${MY_CDEPEND}
+ >=net-analyzer/argus-3.0.2"
+
+DEPEND="${MY_CDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_configure() {
+ use debug && touch .debug
+ # $(use_with sasl) \
+ econf \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with mysql)
+}
+
+src_install() {
+ # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
+ dobin bin/ra* || die "Failed to install ra*"
+ dodoc ChangeLog CREDITS README doc/{CHANGES,FAQ,HOW-TO} || die
+ doman man/man{1,5}/*
+}