summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-09-05 20:20:50 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-09-05 20:20:50 +0000
commitfddaf5ada35f5532064163876a12b8a22ef34162 (patch)
tree2a8f75f138330a0e0a44ab3c179e3d8022210806 /net-analyzer/bmon/bmon-2.1.0-r3.ebuild
parentUse the latest autotools from the autotools eclass #191410. (diff)
downloadgentoo-2-fddaf5ada35f5532064163876a12b8a22ef34162.tar.gz
gentoo-2-fddaf5ada35f5532064163876a12b8a22ef34162.tar.bz2
gentoo-2-fddaf5ada35f5532064163876a12b8a22ef34162.zip
Fix for bug #176378
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-analyzer/bmon/bmon-2.1.0-r3.ebuild')
-rw-r--r--net-analyzer/bmon/bmon-2.1.0-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/bmon/bmon-2.1.0-r3.ebuild b/net-analyzer/bmon/bmon-2.1.0-r3.ebuild
new file mode 100644
index 000000000000..d55926e3c4f9
--- /dev/null
+++ b/net-analyzer/bmon/bmon-2.1.0-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.0-r3.ebuild,v 1.1 2007/09/05 20:20:50 jokey Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="interface bandwidth monitor"
+HOMEPAGE="http://people.suug.ch/~tgr/bmon/"
+SRC_URI="http://people.suug.ch/~tgr/bmon/files/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="dbi rrdtool"
+
+DEPEND=">=sys-libs/ncurses-5.3-r2
+ >=dev-libs/libnl-0.5.0
+ dbi? ( >=dev-db/libdbi-0.7.2-r1 )
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.6-r1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # gcc4 fix, bug 105343
+ epatch "${FILESDIR}"/${P}-gcc4.diff
+ # Don't strip, bug #144370
+ epatch "${FILESDIR}"/${P}-nostrip.patch
+ # libnl crap, bug 176378
+ epatch "${FILESDIR}"/${P}-libnl-1.0.patch
+
+}
+
+src_compile() {
+ econf \
+ $(use_enable dbi) \
+ $(use_enable rrdtool rrd) || die "econf failed"
+ emake CPPFLAGS="${CXXFLAGS} -I${WORKDIR}/libnl-${NLVER}/include" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog
+}