summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-12-12 08:27:34 +0000
committerPeter Volkov <pva@gentoo.org>2011-12-12 08:27:34 +0000
commit0a1413aef9a59845eb46defe1b56f3463fe8e37b (patch)
treed93335ea5c43c359a7ee8f62903ed3f1dc906d7e /net-analyzer/cacti
parentTrivial fix for rst2html build failure in non-unicode locales (bug #363679, t... (diff)
downloadgentoo-2-0a1413aef9a59845eb46defe1b56f3463fe8e37b.tar.gz
gentoo-2-0a1413aef9a59845eb46defe1b56f3463fe8e37b.tar.bz2
gentoo-2-0a1413aef9a59845eb46defe1b56f3463fe8e37b.zip
Version bump. Plugin architecture is now includded, bug #346741 wrt Jens Ott and Alon Bar-Lev.
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog6
-rw-r--r--net-analyzer/cacti/cacti-0.8.7i.ebuild82
2 files changed, 87 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 015d5d7a50ae..48b83cf579fa 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/cacti
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.183 2011/11/13 14:50:52 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.184 2011/12/12 08:27:34 pva Exp $
+
+ 12 Dec 2011; Peter Volkov <pva@gentoo.org> +cacti-0.8.7i.ebuild:
+ Version bump. Plugin architecture is now includded, bug #346741 wrt Jens Ott
+ and Alon Bar-Lev.
13 Nov 2011; Markus Meier <maekke@gentoo.org> cacti-0.8.7h.ebuild:
x86 stable, bug #387661
diff --git a/net-analyzer/cacti/cacti-0.8.7i.ebuild b/net-analyzer/cacti/cacti-0.8.7i.ebuild
new file mode 100644
index 000000000000..656ef019fb05
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.7i.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7i.ebuild,v 1.1 2011/12/12 08:27:34 pva Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+UPSTREAM_PATCHES=""
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ for i in ${UPSTREAM_PATCHES}; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+DEPEND=""
+
+need_httpd
+
+RDEPEND="snmp? ( >=net-analyzer/net-snmp-5.1.2 )
+ net-analyzer/rrdtool
+ dev-php/adodb
+ virtual/mysql
+ virtual/cron
+ dev-lang/php[cli,mysql,xml,session,sockets]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ fi
+}
+
+src_prepare() {
+ if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ fi
+
+ sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php || die
+
+ rm -rf lib/adodb || die # don't use bundled adodb
+}
+
+src_compile() { :; }
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README || die
+ dodoc docs/{CHANGELOG,CONTRIB,README,txt/manual.txt} || die
+ use doc && dohtml -r docs/html/
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}