summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-07-03 13:25:29 +0000
committerMatti Bickel <mabi@gentoo.org>2010-07-03 13:25:29 +0000
commit357d3ef9eb7250f8e42bd550360391b8644095c4 (patch)
tree1d4eb1d3bf07c31816c4689478ea7e411b79a9ae /net-analyzer/cacti
parentFix compilation on Darwin8 (diff)
downloadgentoo-2-357d3ef9eb7250f8e42bd550360391b8644095c4.tar.gz
gentoo-2-357d3ef9eb7250f8e42bd550360391b8644095c4.tar.bz2
gentoo-2-357d3ef9eb7250f8e42bd550360391b8644095c4.zip
eapi bump for bug #298205
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/cacti-0.8.7e-r3.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 33b59b10e037..76981aabc336 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.171 2010/06/01 15:22:56 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.172 2010/07/03 13:25:29 mabi Exp $
+
+*cacti-0.8.7e-r3 (03 Jul 2010)
+
+ 03 Jul 2010; Matti Bickel <mabi@gentoo.org> +cacti-0.8.7e-r3.ebuild:
+ eapi bump for php-5.3 (bug #298205)
01 Jun 2010; Joseph Jezak <josejx@gentoo.org> cacti-0.8.7e-r2.ebuild:
Marked ppc stable for bug #317615.
diff --git a/net-analyzer/cacti/cacti-0.8.7e-r3.ebuild b/net-analyzer/cacti/cacti-0.8.7e-r3.ebuild
new file mode 100644
index 000000000000..1cda1a33fc6d
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.7e-r3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7e-r3.ebuild,v 1.1 2010/07/03 13:25:29 mabi Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+HAS_PATCHES=1
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ "${HAS_PATCHES}" == "1" ] ; then
+ UPSTREAM_PATCHES="cli_add_graph
+ snmp_invalid_response
+ template_duplication
+ fix_icmp_on_windows_iis_servers
+ cross_site_fix
+ sql_injection_template_export"
+ for i in ${UPSTREAM_PATCHES} ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+DEPEND=""
+
+need_httpd_cgi
+
+RDEPEND="snmp? ( >=net-analyzer/net-snmp-5.1.2 )
+ <net-analyzer/rrdtool-1.4
+ dev-php/adodb
+ virtual/mysql
+ virtual/cron
+ dev-lang/php[cli,mysql,xml,session,sockets]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if [ "${HAS_PATCHES}" == "1" ] ; then
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ fi
+}
+
+src_prepare() {
+ if [ "${HAS_PATCHES}" == "1" ] ; then
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ fi
+
+ sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php
+
+ rm -rf lib/adodb # don't use bundled adodb
+}
+
+src_compile() { :; }
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README
+ dodoc docs/{CHANGELOG,CONTRIB,README,txt/manual.txt} || die
+ use doc && dohtml -r docs/html/
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}