summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-11-14 08:39:16 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-11-14 08:39:16 +0000
commitded23465b387784bc0bd78429dde9eb9aece3cdd (patch)
treecf174d40e5e013b4b1a82086631e0e76c5941747 /net-analyzer/dsniff
parentthere is a security issue with kdelibs < 3.0.4-r1. (diff)
downloadgentoo-2-ded23465b387784bc0bd78429dde9eb9aece3cdd.tar.gz
gentoo-2-ded23465b387784bc0bd78429dde9eb9aece3cdd.tar.bz2
gentoo-2-ded23465b387784bc0bd78429dde9eb9aece3cdd.zip
Initial Import.
Diffstat (limited to 'net-analyzer/dsniff')
-rw-r--r--net-analyzer/dsniff/ChangeLog8
-rw-r--r--net-analyzer/dsniff/dsniff-2.3.ebuild85
-rw-r--r--net-analyzer/dsniff/files/digest-dsniff-2.32
3 files changed, 95 insertions, 0 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
new file mode 100644
index 000000000000..3ac447957ee6
--- /dev/null
+++ b/net-analyzer/dsniff/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-analyzer/dsniff
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.1 2002/11/14 08:39:16 jhhudso Exp $
+
+*dsniff-2.3 (14 Nov 2002)
+
+ 14 Nov 2002; Jared Hudson <jhhudso@gentoo.org> : Initial import. Ebuild
+ submitted by foser <foser@gentoo.org>. Bug #6906
diff --git a/net-analyzer/dsniff/dsniff-2.3.ebuild b/net-analyzer/dsniff/dsniff-2.3.ebuild
new file mode 100644
index 000000000000..f7a0032da6b1
--- /dev/null
+++ b/net-analyzer/dsniff/dsniff-2.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3.ebuild,v 1.1 2002/11/14 08:39:16 jhhudso Exp $
+
+# dsniff needs to build it's own version of sys-libs/db, since the one
+# normally installed is for some reason unusable for dsniffs configure script.
+# The version is chosen as being the standard one around at the time i wrote
+# this ebuild, it's not set in stone.
+
+DB_VER="3.2.9"
+
+DESCRIPTION="A collection of tools for network auditing and penetration testing"
+HOMEPAGE="http://monkey.org/~dugsong/dsniff/"
+
+SRC_URI="http://www.sleepycat.com/update/snapshot/db-${DB_VER}.tar.gz
+ http://monkey.org/~dugsong/${PN}/${P}.tar.gz"
+
+# dsniff has it's own small license which is in the docs section
+LICENSE="DSNIFF"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND=">=net-libs/libpcap-0.7.1
+ >=net-libs/libnet-1.0.2
+ >=net-libs/libnids-1.16
+ >=dev-libs/openssl-0.9.6e"
+
+# dependencies only for building our own sys-libs/db
+DEPEND="${RDEPEND}
+ virtual/glibc
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+
+S="${WORKDIR}/${P}"
+IUSE=""
+
+src_unpack() {
+ unpack db-${DB_VER}.tar.gz
+ unpack ${P}.tar.gz
+
+ # Making sure data files get correctly installed and that dsniff
+ # can find them
+ # Working around dsniff b0rky config script
+ # Data stuff goes into /etc/dsniff
+ cd ${S}
+
+ mv configure configure.orig
+ sed "s:lib':':" configure.orig > configure
+ chmod +x configure
+
+ mv Makefile.in Makefile.in.orig
+ sed 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in.orig > Makefile.in
+
+ mv pathnames.h pathnames.h.orig
+ sed 's:/usr/local/lib:/etc/dsniff:' pathnames.h.orig > pathnames.h
+}
+
+src_compile() {
+ cd ${WORKDIR}/db-${DB_VER}/dist
+ ./configure \
+ --host=${CHOST} \
+ --enable-compat185 || die "./configure of db-${DB_VER} failed"
+ emake || die "build of db-${DB_VER} failed"
+
+ # Another workaround around the crappy config script
+ cd ${S}
+ ./configure \
+ --host=${CHOST} \
+ --with-db=../db-${DB_VER} \
+ --exec-prefix=${D}/etc/dsniff \
+ --bindir=${D}/usr/bin \
+ --sbindir=${D}/usr/sbin \
+ --datadir=${D}/usr/share/ \
+ --infodir=${D}/usr/share/info \
+ --mandir=${D}/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make install || die
+
+ dodoc CHANGES LICENSE README TODO
+}
diff --git a/net-analyzer/dsniff/files/digest-dsniff-2.3 b/net-analyzer/dsniff/files/digest-dsniff-2.3
new file mode 100644
index 000000000000..e1135460a43f
--- /dev/null
+++ b/net-analyzer/dsniff/files/digest-dsniff-2.3
@@ -0,0 +1,2 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
+MD5 183e336a45e38013f3af840bddec44b4 dsniff-2.3.tar.gz 126797