summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-14 19:14:13 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-14 19:14:13 +0000
commit5cd2f710a59e013ccef9a21e7ff5a4e4472959c4 (patch)
tree571e780b5a4ecee615925e77f773fe05ee5ab18b /net-analyzer/ethereal
parentsync IUSE (missing), don't assign S=${WORKDIR}/${P} (Manifest recommit) (diff)
downloadgentoo-2-5cd2f710a59e013ccef9a21e7ff5a4e4472959c4.tar.gz
gentoo-2-5cd2f710a59e013ccef9a21e7ff5a4e4472959c4.tar.bz2
gentoo-2-5cd2f710a59e013ccef9a21e7ff5a4e4472959c4.zip
gtk/gtk2 issue, closes 57022
Diffstat (limited to 'net-analyzer/ethereal')
-rw-r--r--net-analyzer/ethereal/ChangeLog6
-rw-r--r--net-analyzer/ethereal/ethereal-0.10.5-r1.ebuild18
-rw-r--r--net-analyzer/ethereal/ethereal-0.10.5.ebuild18
3 files changed, 25 insertions, 17 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index e176d92238d1..9ba38e0bfe02 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.77 2004/07/09 21:51:57 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.78 2004/07/14 19:14:13 eldad Exp $
+
+ 14 Jul 2004; Eldad Zack <eldad@gentoo.org> ethereal-0.10.5-r1.ebuild,
+ ethereal-0.10.5.ebuild:
+ Fixed -gtk +gtk2 dependency issue. Closes #57022.
09 Jul 2004; Lars Weiler <pylon@gentoo.org> ethereal-0.10.5-r1.ebuild:
Stable on ppc.
diff --git a/net-analyzer/ethereal/ethereal-0.10.5-r1.ebuild b/net-analyzer/ethereal/ethereal-0.10.5-r1.ebuild
index 1f2653382a98..53ceaa1213f8 100644
--- a/net-analyzer/ethereal/ethereal-0.10.5-r1.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.10.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.5-r1.ebuild,v 1.3 2004/07/09 21:51:57 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.5-r1.ebuild,v 1.4 2004/07/14 19:14:13 eldad Exp $
inherit libtool flag-o-matic gcc eutils
@@ -13,8 +13,7 @@ SLOT="0"
KEYWORDS="~x86 ~sparc ppc ~alpha ~amd64 ~ia64"
IUSE="adns gtk ipv6 snmp ssl gtk2"
-# since if --disable-gtk2 is not passed to configure it will try to build with glib-2.0,
-# the logic is reversed. if gtk2 USE flag is on, gtk2 will be built, even if gtk is not in USE.
+# if --disable-gtk2 is not passed to configure it will try to build with glib-2.0.
# --disable-ethereal do not have an influence.
# snmp support requires >=net-snmp-5.1.1. Taking virtual off: snmp? ( virtual/snmp )
@@ -22,8 +21,8 @@ IUSE="adns gtk ipv6 snmp ssl gtk2"
RDEPEND=">=sys-libs/zlib-1.1.4
snmp? ( >=net-analyzer/net-snmp-5.1.1 )
>=dev-util/pkgconfig-0.15.0
- gtk2? ( >=dev-libs/glib-2.0.4 =x11-libs/gtk+-2* )
- gtk? ( !gtk2? ( =x11-libs/gtk+-1.2* ) )
+ gtk? ( gtk2? ( >=dev-libs/glib-2.0.4 =x11-libs/gtk+-2* )
+ !gtk2? ( =x11-libs/gtk+-1.2* ) )
!gtk? ( =dev-libs/glib-1.2* )
ssl? ( >=dev-libs/openssl-0.9.6e )
>=net-libs/libpcap-0.7.1
@@ -52,10 +51,13 @@ src_compile() {
local myconf="
$(use_with ssl)
$(use_enable ipv6)
- $(use_with adns)
- $(use_enable gtk2)"
+ $(use_with adns)"
+
+ if use gtk; then
+ myconf="$(use_enable gtk2)"
+ else
+ myconf="--disable-gtk2"
- if ! use gtk; then
# --disable-ethereal do not have an influence
#myconf="${myconf} --disable-ethereal"
# the asn1 plugin needs gtk
diff --git a/net-analyzer/ethereal/ethereal-0.10.5.ebuild b/net-analyzer/ethereal/ethereal-0.10.5.ebuild
index 0f88b60fbae4..91d30c08baf9 100644
--- a/net-analyzer/ethereal/ethereal-0.10.5.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.10.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.5.ebuild,v 1.6 2004/07/09 19:56:45 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.5.ebuild,v 1.7 2004/07/14 19:14:13 eldad Exp $
inherit libtool flag-o-matic gcc eutils
@@ -13,15 +13,14 @@ SLOT="0"
KEYWORDS="x86 sparc ppc alpha amd64 ~ia64"
IUSE="adns gtk ipv6 snmp ssl gtk2"
-# since if --disable-gtk2 is not passed to configure it will try to build with glib-2.0,
-# the logic is reversed. if gtk2 USE flag is on, gtk2 will be built, even if gtk is not in USE.
+# if --disable-gtk2 is not passed to configure it will try to build with glib-2.0.
# --disable-ethereal do not have an influence.
RDEPEND=">=sys-libs/zlib-1.1.4
snmp? ( virtual/snmp )
>=dev-util/pkgconfig-0.15.0
- gtk2? ( >=dev-libs/glib-2.0.4 =x11-libs/gtk+-2* )
- gtk? ( !gtk2? ( =x11-libs/gtk+-1.2* ) )
+ gtk? ( gtk2? ( >=dev-libs/glib-2.0.4 =x11-libs/gtk+-2* )
+ !gtk2? ( =x11-libs/gtk+-1.2* ) )
!gtk? ( =dev-libs/glib-1.2* )
ssl? ( >=dev-libs/openssl-0.9.6e )
>=net-libs/libpcap-0.7.1
@@ -50,10 +49,13 @@ src_compile() {
local myconf="
$(use_with ssl)
$(use_enable ipv6)
- $(use_with adns)
- $(use_enable gtk2)"
+ $(use_with adns)"
+
+ if use gtk; then
+ myconf="$(use_enable gtk2)"
+ else
+ myconf="--disable-gtk2"
- if ! use gtk; then
# --disable-ethereal do not have an influence
#myconf="${myconf} --disable-ethereal"
# the asn1 plugin needs gtk