summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-30 03:06:55 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-30 03:06:55 +0000
commit9895783508201597a70ca9cbaf69b5a5cfcb5c11 (patch)
treecb5c32960c3cc7bbe13b37e4461749764a23f496 /net-analyzer/ethereal
parentfix0red migrated depend (diff)
downloadgentoo-2-9895783508201597a70ca9cbaf69b5a5cfcb5c11.tar.gz
gentoo-2-9895783508201597a70ca9cbaf69b5a5cfcb5c11.tar.bz2
gentoo-2-9895783508201597a70ca9cbaf69b5a5cfcb5c11.zip
GCC-3.1 configure fix!
Diffstat (limited to 'net-analyzer/ethereal')
-rw-r--r--net-analyzer/ethereal/ChangeLog8
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild77
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.9.5-r21
3 files changed, 85 insertions, 1 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index 5b56d77ba00c..6057e211dcac 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.8 2002/06/29 19:30:01 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.9 2002/06/30 03:06:55 lostlogic Exp $
+
+*ethereal-0.9.5-r2 (29 Jun 2002)
+
+ 29 Jun 2002; Brandon Low <lostlogic@gentoo.org> ethereal-0.9.5-r2.ebuild:
+
+ GCC-3.1 configure fix
*ethereal-0.9.5-r1 (29 Jun 2002)
diff --git a/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild b/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild
new file mode 100644
index 000000000000..7b99714030de
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild,v 1.1 2002/06/30 03:06:55 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A commercial-quality network protocol analyzer"
+SRC_URI="http://www.ethereal.com/distribution/${P}.tar.gz"
+HOMEPAGE="http://www.ethereal.com/"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.4
+ =dev-libs/glib-1.2*
+ snmp? ( >=net-analyzer/ucd-snmp-4.2.5 )
+ X? ( virtual/x11 =x11-libs/gtk+-1.2* )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl
+ sys-devel/bison
+ sys-devel/flex
+ >=net-libs/libpcap-0.7.1"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #This is a new hack for gcc-3.1 compatibility
+ sed -e "1961,1962d;3358,3359d;3382,3383d" configure \
+ >configure.hacked
+ mv configure.hacked configure
+ chmod +x configure
+
+}
+
+src_compile() {
+ local myconf
+ use X || myconf="${myconf} --disable-ethereal"
+ use ssl || myconf="${myconf} --without-ssl"
+ use snmp || myconf="${myconf} --without-ucdsnmp"
+
+ ./configure \
+ --prefix=/usr \
+ --enable-pcap \
+ --enable-zlib \
+ --enable-ipv6 \
+ --enable-tethereal \
+ --enable-editcap \
+ --enable-mergecap \
+ --enable-text2cap \
+ --enable-idl2eth \
+ --enable-dftest \
+ --enable-randpkt \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/ethereal \
+ --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ #this was an old hack for gcc-3 compatibility
+ #--includedir="" \
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/lib/ethereal/plugins/${PV}
+
+ make install \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc/ethereal \
+ plugindir=${D}/usr/lib/ethereal/plugins/${PV} || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
+}
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.9.5-r2 b/net-analyzer/ethereal/files/digest-ethereal-0.9.5-r2
new file mode 100644
index 000000000000..08d48ba93256
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest-ethereal-0.9.5-r2
@@ -0,0 +1 @@
+MD5 a7a02706c0f22e56a45bd8999dbb35e3 ethereal-0.9.5.tar.gz 3384282