summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-05-10 05:55:46 +0000
committerPeter Volkov <pva@gentoo.org>2010-05-10 05:55:46 +0000
commitf89554d09df623638b6d40c8aa5124a920dcd114 (patch)
tree8a5fef1b956d3e5d20a77bb786fc25e64f7fd2a9 /net-analyzer/httping
parentbump to pre4 (diff)
downloadgentoo-2-f89554d09df623638b6d40c8aa5124a920dcd114.tar.gz
gentoo-2-f89554d09df623638b6d40c8aa5124a920dcd114.tar.bz2
gentoo-2-f89554d09df623638b6d40c8aa5124a920dcd114.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/ChangeLog8
-rw-r--r--net-analyzer/httping/httping-1.2.6.ebuild29
-rw-r--r--net-analyzer/httping/httping-1.4.1.ebuild (renamed from net-analyzer/httping/httping-1.2.9-r1.ebuild)24
3 files changed, 23 insertions, 38 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 232abf29bff9..15695b30693b 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.55 2010/01/06 19:57:18 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.56 2010/05/10 05:55:46 pva Exp $
+
+*httping-1.4.1 (10 May 2010)
+
+ 10 May 2010; Peter Volkov <pva@gentoo.org> -httping-1.2.6.ebuild,
+ -httping-1.2.9-r1.ebuild, +httping-1.4.1.ebuild:
+ Version bump.
06 Jan 2010; Brent Baude <ranger@gentoo.org> httping-1.3.1.ebuild:
Marking httping-1.3.1 ppc64 for bug 297836
diff --git a/net-analyzer/httping/httping-1.2.6.ebuild b/net-analyzer/httping/httping-1.2.6.ebuild
deleted file mode 100644
index 75e132a050e9..000000000000
--- a/net-analyzer/httping/httping-1.2.6.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.2.6.ebuild,v 1.4 2008/08/27 12:03:16 gentoofan23 Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="http protocol ping-like program"
-HOMEPAGE="http://www.vanheusden.com/httping/"
-SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~mips ~ppc ppc64 ~sparc x86"
-IUSE="ssl"
-
-DEPEND=">=sys-libs/ncurses-5
- ssl? ( dev-libs/openssl )"
-
-src_compile() {
- local makefile
- use ssl || makefile="-f Makefile.nossl"
- emake CC="$(tc-getCC)" ${makefile} || die "emake failed"
-}
-
-src_install() {
- dobin httping || die "dobin failed"
- doman httping.1 || die "doman failed"
- dodoc readme.txt || die "dodoc failed"
-}
diff --git a/net-analyzer/httping/httping-1.2.9-r1.ebuild b/net-analyzer/httping/httping-1.4.1.ebuild
index 1996a71ff04e..6739a11693f0 100644
--- a/net-analyzer/httping/httping-1.2.9-r1.ebuild
+++ b/net-analyzer/httping/httping-1.4.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.2.9-r1.ebuild,v 1.3 2009/10/31 14:34:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.4.1.ebuild,v 1.1 2010/05/10 05:55:46 pva Exp $
+
+EAPI="2"
inherit flag-o-matic toolchain-funcs
@@ -10,18 +12,24 @@ SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~hppa ~mips ~ppc ppc64 ~sparc x86"
-IUSE="ssl"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl"
RDEPEND=">=sys-libs/ncurses-5
ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}"
+#src_prepare() {
+# sed 's:^CFLAGS=:CFLAGS+=:' -i Makefile || die
+#}
+
src_compile() {
- local makefile
- use ssl || makefile="-f Makefile.nossl"
- append-flags -Dstrndup=strndup
- emake CC="$(tc-getCC)" ${makefile} || die "emake failed"
+ append-flags -D_GNU_SOURCE
+ emake \
+ CC="$(tc-getCC)" \
+ $(use ssl && echo SSL=yes || echo SSL=no) \
+ $(use debug && echo DEBUG=yes || echo DEBUG=no) \
+ || die "emake failed"
}
src_install() {