summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-10-24 15:23:57 +0000
committerPeter Volkov <pva@gentoo.org>2008-10-24 15:23:57 +0000
commit74dd0d9f4e8c5ac24e1ca0c36da7f5259b899225 (patch)
treed87ca8e2122ca64059c88ce3490f26f003209523 /net-analyzer/iptraf
parentAdded suid bin on fping binary, required by many monitoring tools (nagious, z... (diff)
downloadgentoo-2-74dd0d9f4e8c5ac24e1ca0c36da7f5259b899225.tar.gz
gentoo-2-74dd0d9f4e8c5ac24e1ca0c36da7f5259b899225.tar.bz2
gentoo-2-74dd0d9f4e8c5ac24e1ca0c36da7f5259b899225.zip
Fixes ability to listen on vlan interfaces, bug #231745, thank Tomas Vasek for report and Ross Dougherty for actual tests. Removed old.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-openvz.git-777e816 i686)
Diffstat (limited to 'net-analyzer/iptraf')
-rw-r--r--net-analyzer/iptraf/ChangeLog11
-rw-r--r--net-analyzer/iptraf/files/iptraf-3.0.0-vlan.patch28
-rw-r--r--net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild (renamed from net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild)34
3 files changed, 53 insertions, 20 deletions
diff --git a/net-analyzer/iptraf/ChangeLog b/net-analyzer/iptraf/ChangeLog
index 6683111740c3..923bdfbf3869 100644
--- a/net-analyzer/iptraf/ChangeLog
+++ b/net-analyzer/iptraf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/iptraf
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.67 2007/11/06 17:26:07 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.68 2008/10/24 15:23:57 pva Exp $
+
+*iptraf-3.0.0-r5 (24 Oct 2008)
+
+ 24 Oct 2008; Peter Volkov <pva@gentoo.org> +files/iptraf-3.0.0-vlan.patch,
+ -iptraf-3.0.0-r3.ebuild, +iptraf-3.0.0-r5.ebuild:
+ Fixes ability to listen on vlan interfaces, bug #231745, thank Tomas Vasek
+ for report and Ross Dougherty for actual tests. Removed old.
06 Nov 2007; Markus Rothe <corsair@gentoo.org> iptraf-3.0.0-r4.ebuild:
Stable on ppc64; bug #197609
diff --git a/net-analyzer/iptraf/files/iptraf-3.0.0-vlan.patch b/net-analyzer/iptraf/files/iptraf-3.0.0-vlan.patch
new file mode 100644
index 000000000000..f0087bf39478
--- /dev/null
+++ b/net-analyzer/iptraf/files/iptraf-3.0.0-vlan.patch
@@ -0,0 +1,28 @@
+--- src/packet.c.orig 2008-03-07 17:56:48.000000000 +0200
++++ src/packet.c 2008-03-07 18:05:41.000000000 +0200
+@@ -101,8 +101,8 @@
+ result = LINK_ETHERNET;
+ else if (strncmp(ifname, "tun", 3) == 0)
+ result = LINK_ETHERNET;
+- else if (strncmp(ifname, "vlan", 3) == 0)
+- result = LINK_VLAN;
++ else if (strncmp(ifname, "vlan", 4) == 0)
++ result = LINK_ETHERNET;
+ else if (strncmp(ifname, "brg", 3) == 0)
+ result = LINK_ETHERNET;
+ else if (strncmp(ifname, "tap", 3) == 0)
+@@ -231,14 +231,6 @@
+ case LINK_IPIP:
+ *packet = tpacket;
+ break;
+- case LINK_VLAN:
+- *packet = tpacket + VLAN_ETH_HLEN;
+- readlen -= VLAN_ETH_HLEN;
+- /*
+- * Move IP datagram into an aligned buffer.
+- */
+- memmove(aligned_buf, *packet, min(SNAPSHOT_LEN, *readlen));
+- *packet = aligned_buf;
+ default:
+ *packet = (char *) NULL; /* return a NULL packet to signal */
+ break; /* an unrecognized link protocol */
diff --git a/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild b/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild
index b4ad643af3d0..3b96d4393f98 100644
--- a/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild
+++ b/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/iptraf-3.0.0-r3.ebuild,v 1.11 2007/06/27 16:15:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/iptraf-3.0.0-r5.ebuild,v 1.1 2008/10/24 15:23:57 pva Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="ftp://iptraf.seul.org/pub/iptraf/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="ipv6 suid unicode"
DEPEND=">=sys-libs/ncurses-5.2-r1"
@@ -25,18 +25,16 @@ pkg_setup() {
src_unpack() {
unpack ${P}.tar.gz
- cd ${S}
- epatch ${FILESDIR}/${P}-atheros.patch
- epatch ${FILESDIR}/${P}-build.patch
- epatch ${FILESDIR}/${P}-linux-headers.patch
- epatch ${FILESDIR}/${P}-bnep.patch
- epatch ${FILESDIR}/${P}-Makefile.patch
- # bug 152883
- use unicode && epatch "${FILESDIR}/${P}-ncursesw.patch"
- epatch "${FILESDIR}/${P}-setlocale.patch"
+ cd "${S}"
- # bug 128965
- epatch ${FILESDIR}/${P}-headerfix.patch
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-add-devnames.patch
+ epatch "${FILESDIR}"/${P}-linux-headers.patch
+ use unicode && epatch "${FILESDIR}/${P}-ncursesw.patch" #152883
+ epatch "${FILESDIR}/${P}-setlocale.patch"
+ epatch "${FILESDIR}"/${P}-headerfix.patch #128965
+ epatch "${FILESDIR}"/${P}-vlan.patch
sed -i \
-e 's:/var/local/iptraf:/var/lib/iptraf:g' \
@@ -44,15 +42,15 @@ src_unpack() {
Documentation/*.* || die "sed doc paths"
if use ipv6 ; then
- epatch ${DISTDIR}/${P}-ipv6.patch.bz2
+ epatch "${DISTDIR}"/${P}-ipv6.patch.bz2
# bug 126479
if has_version '>=sys-libs/glibc-2.4' ; then
- epatch ${FILESDIR}/${P}-ipv6-glibc24.patch
+ epatch "${FILESDIR}"/${P}-ipv6-glibc24.patch
fi
# bug 128965
- epatch ${FILESDIR}/${P}-ipv6-headerfix.patch
+ epatch "${FILESDIR}"/${P}-ipv6-headerfix.patch
fi
}
@@ -60,7 +58,7 @@ src_compile() {
if use suid ; then
append-flags -DALLOWUSERS
fi
- emake CFLAGS="$CFLAGS" CC="$(tc-getCC)" -C src || die "emake failed"
+ emake -C src CFLAGS="$CFLAGS" CC="$(tc-getCC)" || die "emake failed"
}
src_install() {