summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-12-17 23:30:56 +0000
committerEldad Zack <eldad@gentoo.org>2004-12-17 23:30:56 +0000
commit1b4f7fc8f98c1ecf0c5ffdd0e6068cba053c7617 (patch)
tree32263b8e2a005798fada5982a92fd9cc3d24f076 /net-analyzer/mtr/mtr-0.67.ebuild
parentRemoved comments from metadata.xml. (Manifest recommit) (diff)
downloadgentoo-2-1b4f7fc8f98c1ecf0c5ffdd0e6068cba053c7617.tar.gz
gentoo-2-1b4f7fc8f98c1ecf0c5ffdd0e6068cba053c7617.tar.bz2
gentoo-2-1b4f7fc8f98c1ecf0c5ffdd0e6068cba053c7617.zip
Version bump. Fixed lazy-binding suid issue.
Diffstat (limited to 'net-analyzer/mtr/mtr-0.67.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-0.67.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/mtr/mtr-0.67.ebuild b/net-analyzer/mtr/mtr-0.67.ebuild
new file mode 100644
index 000000000000..532c63394bd3
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.67.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.67.ebuild,v 1.1 2004/12/17 23:30:56 eldad Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86"
+IUSE="gtk gtk2"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ gtk? ( !gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2* ) )"
+
+src_compile() {
+ local myconf
+ use gtk || myconf="${myconf} --without-gtk"
+
+ append-ldflags -Wl,-z,now
+
+ epatch ${FILESDIR}/mtr-ac-res_mkquery.patch
+ autoconf
+
+ econf ${myconf} \
+ `use_enable gtk2` || die
+
+ emake || die
+}
+
+src_install() {
+ # this binary is universal. ie: it does both console and gtk.
+ make DESTDIR=${D} sbindir=/usr/bin install || die
+
+ fowners root:wheel /usr/bin/mtr
+ fperms 4710 /usr/bin/mtr
+
+ dodoc AUTHORS COPYING ChangeLog FORMATS NEWS README SECURITY TODO
+}