summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-22 01:57:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-22 01:57:41 +0000
commite63d68d3d6af037b7904a485c0ecda47e65e2984 (patch)
treeee8e3c406e160a94379fcd238d88ee8340541cda /net-analyzer/munin
parentVersion bump and remove old. (diff)
downloadgentoo-2-e63d68d3d6af037b7904a485c0ecda47e65e2984.tar.gz
gentoo-2-e63d68d3d6af037b7904a485c0ecda47e65e2984.tar.bz2
gentoo-2-e63d68d3d6af037b7904a485c0ecda47e65e2984.zip
Fix the owner of /var/spool/munin-async so that you can use the cmd protocol for the master. Change the home for munin-async. Apply new patches to make sure that the SSH sessions are non-interactive. Add support for using the -W option to ssh. The new init script no longer 'need net'.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'net-analyzer/munin')
-rw-r--r--net-analyzer/munin/ChangeLog12
-rw-r--r--net-analyzer/munin/files/munin-asyncd.init.24
-rw-r--r--net-analyzer/munin/files/munin-node_init.d_2.0.737
-rw-r--r--net-analyzer/munin/files/munin.env1
-rw-r--r--net-analyzer/munin/munin-2.0.7-r5.ebuild (renamed from net-analyzer/munin/munin-2.0.7-r4.ebuild)36
5 files changed, 67 insertions, 23 deletions
diff --git a/net-analyzer/munin/ChangeLog b/net-analyzer/munin/ChangeLog
index 64b28c392c0c..08520be8a258 100644
--- a/net-analyzer/munin/ChangeLog
+++ b/net-analyzer/munin/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-analyzer/munin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.114 2012/10/21 06:00:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.115 2012/10/22 01:57:41 flameeyes Exp $
+
+*munin-2.0.7-r5 (22 Oct 2012)
+
+ 22 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/munin-node_init.d_2.0.7, +munin-2.0.7-r5.ebuild, -files/munin.env,
+ -munin-2.0.7-r4.ebuild, files/munin-asyncd.init.2:
+ Fix the owner of /var/spool/munin-async so that you can use the cmd protocol
+ for the master. Change the home for munin-async. Apply new patches to make
+ sure that the SSH sessions are non-interactive. Add support for using the -W
+ option to ssh. The new init script no longer 'need net'.
21 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org>
files/munin-asyncd.init.2:
diff --git a/net-analyzer/munin/files/munin-asyncd.init.2 b/net-analyzer/munin/files/munin-asyncd.init.2
index 5c9981412295..e9703dcf1d90 100644
--- a/net-analyzer/munin/files/munin-asyncd.init.2
+++ b/net-analyzer/munin/files/munin-asyncd.init.2
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/files/munin-asyncd.init.2,v 1.3 2012/10/21 06:00:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/files/munin-asyncd.init.2,v 1.4 2012/10/22 01:57:41 flameeyes Exp $
command=/usr/libexec/munin/munin-asyncd
command_args="--fork"
@@ -14,7 +14,7 @@ depend() {
}
start_pre() {
- checkpath -d -o munin-async -m 0700 /var/spool/munin-async
+ checkpath -d -o munin-async:munin -m 0750 /var/spool/munin-async
}
# vim: filetype=gentoo-init-d:
diff --git a/net-analyzer/munin/files/munin-node_init.d_2.0.7 b/net-analyzer/munin/files/munin-node_init.d_2.0.7
new file mode 100644
index 000000000000..63bf6eaaee4c
--- /dev/null
+++ b/net-analyzer/munin/files/munin-node_init.d_2.0.7
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/files/munin-node_init.d_2.0.7,v 1.1 2012/10/22 01:57:41 flameeyes Exp $
+
+get_munin_config() {
+ awk '$1 == "'$1'" { s=$2 } END { print s }' "$CFGFILE"
+}
+
+: ${CFGFILE:=/etc/munin/munin-node.conf}
+
+command=/usr/sbin/munin-node
+command_args="--config ${CFGFILE}"
+pidfile=$(get_munin_config pid_file)
+start_stop_daemon_args="--nicelevel ${NICE_LEVEL:-0}"
+extra_started_commands="reload"
+
+depend() {
+ config "$CFGFILE"
+
+ before cron
+
+ [ "$(get_munin_config log_file)" == "Sys::Syslog" ] && \
+ use logger
+}
+
+start_pre() {
+ checkpath -d $(dirname ${pidfile})
+}
+
+reload() {
+ ebegin "Reloading ${SERVICE}"
+ kill -HUP `cat ${pidfile}`
+ eend $?
+}
+
+# vim: filetype=gentoo-init-d:
diff --git a/net-analyzer/munin/files/munin.env b/net-analyzer/munin/files/munin.env
deleted file mode 100644
index d43d5177ad8a..000000000000
--- a/net-analyzer/munin/files/munin.env
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_PROTECT=/var/lib/munin-async/.ssh
diff --git a/net-analyzer/munin/munin-2.0.7-r4.ebuild b/net-analyzer/munin/munin-2.0.7-r5.ebuild
index d7e577e5a988..c4f9c4026d80 100644
--- a/net-analyzer/munin/munin-2.0.7-r4.ebuild
+++ b/net-analyzer/munin/munin-2.0.7-r5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.7-r4.ebuild,v 1.1 2012/10/21 05:39:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.7-r5.ebuild,v 1.1 2012/10/22 01:57:41 flameeyes Exp $
EAPI=4
-PATCHSET=3
+PATCHSET=6
inherit eutils user java-pkg-opt-2
@@ -94,7 +94,8 @@ S="${WORKDIR}/${MY_P}"
pkg_setup() {
enewgroup munin
enewuser munin 177 -1 /var/lib/munin munin
- enewuser munin-async -1 /usr/libexec/munin/munin-async /var/lib/munin-async
+ enewuser munin-async -1 /bin/sh /var/spool/munin-async
+ esethome munin-async /var/spool/munin-async
java-pkg-opt-2_pkg_setup
}
@@ -139,19 +140,14 @@ src_install() {
/var/lib/munin/plugin-state
/etc/munin/plugin-conf.d
/etc/munin/plugins"
+ use minimal || dirs+=" /etc/munin/munin-conf.d/"
+
keepdir ${dirs}
fowners munin:munin ${dirs}
- local install_targets="install-common-prime install-node-prime install-plugins-prime
- install-async-prime"
- use java && install_targets+=" install-plugins-java"
-
- use minimal || install_targets=install
- use minimal || dirs+=" /etc/munin/munin-conf.d/"
-
# parallel install doesn't work and it's also pointless to have this
# run in parallel for now (because it uses internal loops).
- emake -j1 DESTDIR="${D}" ${install_targets}
+ emake -j1 DESTDIR="${D}" $(usex minimal install-minimal install)
# remove the plugins for non-Gentoo package managers
rm "${D}"/usr/libexec/munin/plugins/{apt{,_all},yum} || die
@@ -159,12 +155,15 @@ src_install() {
insinto /etc/munin/plugin-conf.d/
newins "${FILESDIR}"/${PN}-1.3.2-plugins.conf munin-node
- newinitd "${FILESDIR}"/munin-node_init.d_2.0.5 munin-node
+ newinitd "${FILESDIR}"/munin-node_init.d_2.0.7 munin-node
newconfd "${FILESDIR}"/munin-node_conf.d_1.4.6-r2 munin-node
newinitd "${FILESDIR}"/munin-asyncd.init.2 munin-asyncd
- newenvd "${FILESDIR}"/munin.env 50munin
+ cat - >> "${T}"/munin.env <<EOF
+CONFIG_PROTECT=/var/spool/munin-async/.ssh
+EOF
+ newenvd "${T}"/munin.env 50munin
dodoc README ChangeLog INSTALL
if use doc; then
@@ -190,11 +189,11 @@ src_install() {
sed -i -e 's:/var/run/munin/munin-node.pid:/var/run/munin-node.pid:' \
"${D}"/etc/munin/munin-node.conf || die
- keepdir /var/lib/munin-async/.ssh /var/spool/munin-async
- touch "${D}"/var/lib/munin-async/.ssh/authorized_keys
- fowners munin-async /var/lib/munin-async/.ssh/{,authorized_keys} /var/spool/munin-async
- fperms 0700 /var/lib/munin-async/.ssh /var/spool/munin-async
- fperms 0600 /var/lib/munin-async/.ssh/authorized_keys
+ keepdir /var/spool/munin-async/.ssh
+ touch "${D}"/var/spool/munin-async/.ssh/authorized_keys
+ fowners munin-async:munin /var/spool/munin-async{,/.ssh/{,authorized_keys}}
+ fperms 0750 /var/spool/munin-async{,/.ssh}
+ fperms 0600 /var/spool/munin-async/.ssh/authorized_keys
if use minimal; then
# This requires the presence of munin-update, which is part of
@@ -217,7 +216,6 @@ src_install() {
cat - >> "${D}"/var/lib/munin/.ssh/config <<EOF
IdentityFile /var/lib/munin/.ssh/id_ecdsa
IdentityFile /var/lib/munin/.ssh/id_rsa
-StrictHostKeyChecking no
EOF
fowners munin:munin /var/lib/munin/.ssh/{,config}