summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-15 13:51:24 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-15 13:51:24 +0000
commit56d7e24adb9e0805ca3aff71b9c4e9d43b96f955 (patch)
tree32dcbe613be58eaf21146829fdd7a9c7d890ea05 /net-analyzer/nessus-core/nessus-core-2.3.1.ebuild
parentUpdated description to include the ipw2225. (diff)
downloadgentoo-2-56d7e24adb9e0805ca3aff71b9c4e9d43b96f955.tar.gz
gentoo-2-56d7e24adb9e0805ca3aff71b9c4e9d43b96f955.tar.bz2
gentoo-2-56d7e24adb9e0805ca3aff71b9c4e9d43b96f955.zip
Version bump.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'net-analyzer/nessus-core/nessus-core-2.3.1.ebuild')
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.3.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/nessus-core/nessus-core-2.3.1.ebuild b/net-analyzer/nessus-core/nessus-core-2.3.1.ebuild
new file mode 100644
index 000000000000..efac39691872
--- /dev/null
+++ b/net-analyzer/nessus-core/nessus-core-2.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.3.1.ebuild,v 1.1 2005/05/15 13:51:24 ka0ttic Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A remote security scanner for Linux (nessus-core)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/experimental/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64"
+IUSE="tcpd gtk gtk2 debug"
+
+DEPEND="=net-analyzer/nessus-libraries-${PV}
+ =net-analyzer/libnasl-${PV}
+ tcpd? ( sys-apps/tcp-wrappers )
+ gtk? ( virtual/x11
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ )
+ prelude? ( dev-libs/libprelude )"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc4.diff
+}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ econf \
+ $(use_enable tcpd tcpwrappers) \
+ $(use_enable debug) \
+ $(use_enable gtk) \
+ || die "configure failed"
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # net-analyzer/nessus-libraries provides includes.h
+ rm ${D}/usr/include/nessus/includes.h
+
+ dodoc README* UPGRADE_README CHANGES
+ dodoc doc/*.txt doc/ntp/*
+
+ newinitd ${FILESDIR}/nessusd-r7 nessusd || die "newinitd failed"
+ keepdir /var/lib/nessus/logs
+ keepdir /var/lib/nessus/users
+}