summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-01-06 18:10:03 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-01-06 18:10:03 +0000
commit7677b794c504d80527ec5d26e102903889a27ebc (patch)
treead0a6825ec8be09e58e0a703e88b5d5e25c3cb73 /net-analyzer/net-snmp/files
parentUse need_php_by_category. (diff)
downloadgentoo-2-7677b794c504d80527ec5d26e102903889a27ebc.tar.gz
gentoo-2-7677b794c504d80527ec5d26e102903889a27ebc.tar.bz2
gentoo-2-7677b794c504d80527ec5d26e102903889a27ebc.zip
Add patch from bug 118016 to allow use of --as-needed. Thanks to Diego Petteno <flameeyes at gentoo dot org>.
(Portage version: 2.0.53)
Diffstat (limited to 'net-analyzer/net-snmp/files')
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch b/net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch
new file mode 100644
index 000000000000..d84c58ebdf9a
--- /dev/null
+++ b/net-analyzer/net-snmp/files/net-snmp-5.2.2-asneeded.patch
@@ -0,0 +1,38 @@
+Index: net-snmp-5.2.2/snmplib/Makefile.in
+===================================================================
+--- net-snmp-5.2.2.orig/snmplib/Makefile.in
++++ net-snmp-5.2.2/snmplib/Makefile.in
+@@ -185,11 +185,11 @@ all: standardall
+
+ # how to build the libraries.
+ libnetsnmp.$(LIB_EXTENSION)$(LIB_VERSION): ${TOBJS}
+- $(LIB_LD_CMD) libnetsnmp.$(LIB_EXTENSION)$(LIB_VERSION) ${TOBJS}
++ $(LIB_LD_CMD) libnetsnmp.$(LIB_EXTENSION)$(LIB_VERSION) ${TOBJS} @LIBCRYPTO@
+ $(RANLIB) libnetsnmp.$(LIB_EXTENSION)$(LIB_VERSION)
+
+ libsnmp.$(LIB_EXTENSION)$(LIB_VERSION): ${TOBJS}
+- $(LIB_LD_CMD) libsnmp.$(LIB_EXTENSION)$(LIB_VERSION) ${TOBJS}
++ $(LIB_LD_CMD) libsnmp.$(LIB_EXTENSION)$(LIB_VERSION) ${TOBJS} @LIBCRYPTO@
+ $(RANLIB) libsnmp.$(LIB_EXTENSION)$(LIB_VERSION)
+
+ #
+Index: net-snmp-5.2.2/configure.in
+===================================================================
+--- net-snmp-5.2.2.orig/configure.in
++++ net-snmp-5.2.2/configure.in
+@@ -2671,6 +2671,7 @@ if test "x$useopenssl" != "xno" ; then
+ encrmodes="[disabled]"
+ fi
+ AC_DEFINE(USE_OPENSSL)
++ LIBCRYPTO="-lcrypto"
+ AC_MSG_RESULT(OpenSSL Support)
+ elif test "x$usepkcs" != "xno" ; then
+ authmodes="MD5 SHA1"
+@@ -2690,6 +2691,7 @@ fi
+ if test "x$enable_md5" = "xno"; then
+ authmodes=`echo $authmodes | sed 's/MD5 *//;'`
+ fi
++AC_SUBST(LIBCRYPTO)
+
+ AC_MSG_CACHE_ADD(Authentication support: $authmodes)
+ AC_MSG_CACHE_ADD(Encryption support: $encrmodes)