summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-15 01:52:55 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-15 01:52:55 +0000
commit015dee7df0515556f63ee31099a3ac545f5e7fab (patch)
tree67d421cfa68e04c9e4afb200bc8973547429a58f /net-analyzer/netwag/netwag-5.38.0.ebuild
parentVersion bump. Update license. Unconditionally install certain docs. (diff)
downloadgentoo-2-015dee7df0515556f63ee31099a3ac545f5e7fab.tar.gz
gentoo-2-015dee7df0515556f63ee31099a3ac545f5e7fab.tar.bz2
gentoo-2-015dee7df0515556f63ee31099a3ac545f5e7fab.zip
Version bump. Update license. Unconditionally install certain docs.
(Portage version: 2.2_rc96/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/netwag/netwag-5.38.0.ebuild')
-rw-r--r--net-analyzer/netwag/netwag-5.38.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/netwag/netwag-5.38.0.ebuild b/net-analyzer/netwag/netwag-5.38.0.ebuild
new file mode 100644
index 000000000000..91d99e640172
--- /dev/null
+++ b/net-analyzer/netwag/netwag-5.38.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwag/netwag-5.38.0.ebuild,v 1.1 2010/10/15 01:52:55 jer Exp $
+
+# NOTE: netwib, netwox and netwag go together, bump all or bump none
+
+EAPI="2"
+
+DESCRIPTION="Tcl/tk interface to netwox (Toolbox of 222 utilities for testing Ethernet/IP networks)"
+HOMEPAGE="http://www.laurentconstantin.com/en/netw/netwag/"
+BASEURI="http://www.laurentconstantin.com/common/netw/${PN}/download/"
+SRC_URI="
+ ${BASEURI}v${PV/.*}/${P}-src.tgz
+ doc? ( ${BASEURI}v${PV/.*}/${P}-doc_html.tgz )
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="~net-analyzer/netwox-${PV}
+ >=dev-lang/tk-8
+ || ( x11-terms/xterm
+ x11-terms/eterm
+ x11-terms/rxvt
+ x11-terms/gnome-terminal
+ kde-base/konsole )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-src/src"
+
+src_prepare() {
+ sed -i \
+ -e 's:/man$:/share/man:g' \
+ -e "s:/usr/local:/usr:" \
+ config.dat
+}
+
+src_configure() {
+ sh genemake || die "problem creating Makefile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ../README.TXT
+ if use doc;
+ then
+ mv "${WORKDIR}"/${P}-doc_html \
+ "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ dodoc "${S}"/../doc/{changelog.txt,credits.txt} \
+ "${S}"/../doc/{problemreport.txt,problemusage.txt,todo.txt}
+}