summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-23 21:03:40 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-23 21:03:40 +0000
commit48b4abd8a2d6d507f5e8fa36d2df2b407adbf0b4 (patch)
treec6846cab4f2e16172adb2fef60f1ef376fe364c0 /net-analyzer/nmap
parentRemoved old nmap ebuilds (diff)
downloadgentoo-2-48b4abd8a2d6d507f5e8fa36d2df2b407adbf0b4.tar.gz
gentoo-2-48b4abd8a2d6d507f5e8fa36d2df2b407adbf0b4.tar.bz2
gentoo-2-48b4abd8a2d6d507f5e8fa36d2df2b407adbf0b4.zip
Version bump + cleanup
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog15
-rw-r--r--net-analyzer/nmap/files/digest-nmap-3.10_alpha31
-rw-r--r--net-analyzer/nmap/nmap-3.10_alpha3.ebuild46
3 files changed, 53 insertions, 9 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 9537da2547ae..7e31192557fb 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,51 +1,48 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.7 2002/08/02 16:50:31 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.8 2002/10/23 21:03:40 vapier Exp $
+
+*nmap-3.10_alpha3 (23 Oct 2002)
+
+ 23 Oct 2002; Mike Frysinger <vapier@gentoo.org> nmap-3.10_alpha3.ebuild :
+ Version bump with ~ in KEYWORDS, and general ebuild cleanup
*nmap-3.00 (02 Aug 2002)
02 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> nmap-3.00.ebuild:
-
Final is out. Ebuild contributed by Hannes Mehnert <hannes@mehnert.org>.
*nmap-2.99_rc1 (28 Jul 2002)
28 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> nmap-2.99_rc1.ebuild :
-
Version bump. Ebuild contributed by SpanKY <vapier@netzero.com>.
*nmap-2.54_beta37 (19 Jul 2002)
19 Jul 2002; Seemant Kulleen <seemant@gentoo.org> nmap-2.54_beta37.ebuild
files/digest-nmap-2.54_beta37 :
-
Version bump.
*nmap-2.54_beta36 (17 Jun 2002)
17 Jun 2002; Seemant Kulleen <seemant@gentoo.org> nmap-2.54_beta36.ebuild
files/digest-nmap-2.54_beta36 :
-
Version bump thanks to: kikov@fco-gimeno.com (Francisco Gimeno) in bug
#3833
*nmap-2.54_beta33 (27 Apr 2002)
27 Apr 2002; Seemant Kulleen <seemant@gentoo.org> nmap-2.54_beta33.ebuild :
-
Version bump.
*nmap-2.54_beta31 (21 Mar 2002)
21 Mar 2002; Seemant Kulleen <seemant@gentoo.org> nmap-2.54_beta31 :
-
Version bump. Copied old ebuild over, and updated to reflect new syntax style
-
*nmap-2.54_beta30 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/net-analyzer/nmap/files/digest-nmap-3.10_alpha3 b/net-analyzer/nmap/files/digest-nmap-3.10_alpha3
new file mode 100644
index 000000000000..0208fea4f188
--- /dev/null
+++ b/net-analyzer/nmap/files/digest-nmap-3.10_alpha3
@@ -0,0 +1 @@
+MD5 d29161fa21f6ce0a6446e8f80d648d85 nmap-3.10ALPHA3.tgz 949572
diff --git a/net-analyzer/nmap/nmap-3.10_alpha3.ebuild b/net-analyzer/nmap/nmap-3.10_alpha3.ebuild
new file mode 100644
index 000000000000..2f17ce40adb0
--- /dev/null
+++ b/net-analyzer/nmap/nmap-3.10_alpha3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.10_alpha3.ebuild,v 1.1 2002/10/23 21:03:40 vapier Exp $
+
+IUSE="gtk gnome ipv6"
+
+MY_P="${P/_alpha/ALPHA}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Portscanner"
+SRC_URI="http://www.insecure.org/nmap/dist/${MY_P}.tgz"
+HOMEPAGE="http://www.insecure.org/nmap/"
+DEPEND="virtual/glibc
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+src_compile() {
+ use ipv6 \
+ && econf --enable-ipv6 \
+ || econf
+
+ use gtk \
+ && make \
+ || make nmap
+}
+
+src_install() {
+ local myinst
+
+ # If gnome does not exist on the system, there is no need for the gnome
+ # menu item.
+ use gnome || myinst="${myinst} deskdir=${S}"
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ nmapdatadir=${D}/usr/share/nmap \
+ install || die
+
+ dodoc CHANGELOG COPYING HACKING README*
+ cd docs
+ dodoc *.txt
+ dohtml *.html
+}